Updating gcc-config-2* ebuild to rc1, so users don't need to download a different...
authorJeremy Huddleston <eradicator@gentoo.org>
Tue, 6 Jun 2006 01:48:46 +0000 (01:48 +0000)
committerJeremy Huddleston <eradicator@gentoo.org>
Tue, 6 Jun 2006 01:48:46 +0000 (01:48 +0000)
Package-Manager: portage-2.1_rc4-r1

sys-devel/gcc-config/ChangeLog
sys-devel/gcc-config/files/digest-gcc-config-2.0.0_rc1 [new file with mode: 0644]
sys-devel/gcc-config/gcc-config-2.0.0_rc1.ebuild [new file with mode: 0644]

index 1ca397e0b44d05596a2416d6401fb4ac44907bbd..dd52bbc56f9b0b6ba5e03d6a47c7c124a8bd6189 100644 (file)
@@ -1,6 +1,14 @@
 # ChangeLog for sys-devel/gcc-config
 # Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc-config/ChangeLog,v 1.127 2006/04/25 00:20:17 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc-config/ChangeLog,v 1.128 2006/06/06 01:48:46 eradicator Exp $
+
+*gcc-config-2.0.0_rc1 (06 Jun 2006)
+
+  06 Jun 2006; Jeremy Huddleston <eradicator@gentoo.org>
+  -gcc-config-2.0.0_beta2.ebuild, +gcc-config-2.0.0_rc1.ebuild:
+  Updating gcc-config-2* ebuild to rc1, so users don't need to download a
+  different tarball than for eselect-compiler when it gets unmasked. There is
+  actually no change in the wrapper other than the version number.
 
 *gcc-config-1.3.13-r2 (25 Apr 2006)
 
diff --git a/sys-devel/gcc-config/files/digest-gcc-config-2.0.0_rc1 b/sys-devel/gcc-config/files/digest-gcc-config-2.0.0_rc1
new file mode 100644 (file)
index 0000000..e5670a7
--- /dev/null
@@ -0,0 +1,3 @@
+MD5 b67d2f339f159da455d19c49e4868d9c compiler-config-2.0.0_rc1.tar.gz 117180
+RMD160 dbcd8120139c75f40ae2405746ab2a5f26e810b4 compiler-config-2.0.0_rc1.tar.gz 117180
+SHA256 a911a7b0a1184c576500df8530e77823f976dce387001c581ba89ac8edfe30c2 compiler-config-2.0.0_rc1.tar.gz 117180
diff --git a/sys-devel/gcc-config/gcc-config-2.0.0_rc1.ebuild b/sys-devel/gcc-config/gcc-config-2.0.0_rc1.ebuild
new file mode 100644 (file)
index 0000000..ac84918
--- /dev/null
@@ -0,0 +1,28 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc-config/gcc-config-2.0.0_rc1.ebuild,v 1.1 2006/06/06 01:48:46 eradicator Exp $
+
+DESCRIPTION="Utility to configure the active toolchain compiler"
+HOMEPAGE="http://www.gentoo.org/"
+
+MY_PN="compiler-config"
+MY_P="${MY_PN}-${PV}"
+S="${WORKDIR}/${MY_P}"
+
+SRC_URI=" http://dev.gentoo.org/~eradicator/toolchain/${MY_PN}/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE=""
+
+RDEPEND=">=app-admin/eselect-compiler-${PV}"
+
+src_compile() {
+       # Just need to make gcc-config from gcc-config.in
+       econf
+}
+
+src_install() {
+       dobin src/profile-manager/gcc-config
+}