sci-visualization/gnuplot: Version bump.
authorUlrich Müller <ulm@gentoo.org>
Wed, 29 Aug 2018 21:20:34 +0000 (23:20 +0200)
committerUlrich Müller <ulm@gentoo.org>
Wed, 29 Aug 2018 21:21:35 +0000 (23:21 +0200)
Package-Manager: Portage-2.3.48, Repoman-2.3.10

sci-visualization/gnuplot/Manifest
sci-visualization/gnuplot/gnuplot-5.2.4.ebuild [new file with mode: 0644]

index e141324658ad9cd7d466c6f0febe1e3e89a851d7..03224b5074d6e9c333b938f40c10e3bfce52e44e 100644 (file)
@@ -1,2 +1,3 @@
 DIST gnuplot-5.0.7.tar.gz 5100186 BLAKE2B 97fcefa12148fc2b581113c5283eb09217e87858ae293931758d0bb595fd7aaca4671216956211a3d30492be35f91809a975c9c80c25861c477e9235a8b5b309 SHA512 5d7241dc1472f87af8632110a1e88f83b5ea3f41e1bc8c89a45dc4662a3071d91a25bf9ae5196a2b8bef09c8079c22f635bb947c02def3416d78880d61eea919
 DIST gnuplot-5.2.2.tar.gz 5282973 BLAKE2B a15c72aaa8d62079ea3e9f20fa9fe3aaaf6036cf8dc67a784dee79ac7bd0ad7bfac754c9583b50c46deeef2f1bcd920d1094a5d1e19a1dae75405de8c3249621 SHA512 51d5b2234dae358580cc2794ed63f8a5b950baf73edc5362f5bb18d77e8066c3c010239c3b29840db11e5936cb9381bb57193de751bd274af5547a45d6d88b0b
+DIST gnuplot-5.2.4.tar.gz 5292321 BLAKE2B a2eee046de6707ffcaf1a5b175601c18da14db350095a949deed0e241d8476c177e2cecb35eab3059234231ad4be42e5e8a9e3083651313cc4b5997156813c67 SHA512 b276e379fe5e493a176750d9ccd84a8b02c8784b1d8701dc4252945a7e9e0455eebba0085d0d98824a4acf5da0def3b71ad3362803365a32e7c29f18af7854bb
diff --git a/sci-visualization/gnuplot/gnuplot-5.2.4.ebuild b/sci-visualization/gnuplot/gnuplot-5.2.4.ebuild
new file mode 100644 (file)
index 0000000..8c07cfc
--- /dev/null
@@ -0,0 +1,210 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit autotools flag-o-matic readme.gentoo-r1 toolchain-funcs wxwidgets
+
+DESCRIPTION="Command-line driven interactive plotting program"
+HOMEPAGE="http://www.gnuplot.info/"
+
+if [[ -z ${PV%%*9999} ]]; then
+       inherit git-r3
+       EGIT_REPO_URI="https://git.code.sf.net/p/gnuplot/gnuplot-main"
+       EGIT_BRANCH="branch-5-2-stable"
+       MY_P="${PN}"
+       EGIT_CHECKOUT_DIR="${WORKDIR}/${MY_P}"
+else
+       MY_P="${P/_/.}"
+       SRC_URI="mirror://sourceforge/gnuplot/${MY_P}.tar.gz"
+       KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sparc ~x86 ~ppc-aix ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
+fi
+
+LICENSE="gnuplot bitmap? ( free-noncomm )"
+SLOT="0"
+IUSE="aqua bitmap cairo compat doc examples +gd ggi latex libcaca libcerf lua qt5 readline regis svga wxwidgets X"
+
+RDEPEND="
+       cairo? (
+               x11-libs/cairo
+               x11-libs/pango )
+       gd? ( >=media-libs/gd-2.0.35-r3:2=[png] )
+       ggi? ( media-libs/libggi )
+       latex? (
+               virtual/latex-base
+               lua? (
+                       dev-tex/pgf
+                       >=dev-texlive/texlive-latexrecommended-2008-r2 ) )
+       libcaca? ( media-libs/libcaca )
+       lua? ( dev-lang/lua:0 )
+       qt5? ( dev-qt/qtcore:5=
+               dev-qt/qtgui:5=
+               dev-qt/qtnetwork:5=
+               dev-qt/qtprintsupport:5=
+               dev-qt/qtsvg:5=
+               dev-qt/qtwidgets:5= )
+       readline? ( sys-libs/readline:0= )
+       libcerf? ( sci-libs/libcerf )
+       svga? ( media-libs/svgalib )
+       wxwidgets? (
+               x11-libs/wxGTK:3.0[X]
+               x11-libs/cairo
+               x11-libs/pango
+               x11-libs/gtk+:2 )
+       X? ( x11-libs/libXaw )"
+DEPEND="${RDEPEND}
+       virtual/pkgconfig
+       doc? (
+               virtual/latex-base
+               dev-texlive/texlive-latexextra
+               app-text/ghostscript-gpl )
+       qt5? ( dev-qt/linguist-tools:5 )"
+
+S="${WORKDIR}/${MY_P}"
+
+GP_VERSION="${PV%.*}"
+E_SITEFILE="lisp/50${PN}-gentoo.el"
+TEXMF="${EPREFIX}/usr/share/texmf-site"
+
+src_prepare() {
+       eapply "${FILESDIR}"/${PN}-5.0.1-fix-underlinking.patch
+       eapply "${FILESDIR}"/${PN}-5.0.6-no-picins.patch
+       eapply "${FILESDIR}"/${PN}-5.2.2-regis.patch
+       eapply_user
+
+       if [[ -z ${PV%%*9999} ]]; then
+               local dir
+               for dir in config demo m4 term tutorial; do
+                       emake -C "$dir" -f Makefile.am.in Makefile.am
+               done
+       fi
+
+       # Add special version identification as required by provision 2
+       # of the gnuplot license
+       sed -i -e "1s/.*/& (Gentoo revision ${PR})/" PATCHLEVEL || die
+
+       DOC_CONTENTS='Gnuplot no longer links against pdflib, see the ChangeLog
+               for details. You can use the "pdfcairo" terminal for PDF output.'
+       use cairo || DOC_CONTENTS+=' It is available with USE="cairo".'
+       use svga && DOC_CONTENTS+='\n\nIn order to enable ordinary users to use
+               SVGA console graphics, gnuplot needs to be set up as setuid root.
+               Please note that this is usually considered to be a security hazard.
+               As root, manually "chmod u+s /usr/bin/gnuplot".'
+       use gd && DOC_CONTENTS+='\n\nFor font support in png/jpeg/gif output,
+               you may have to set the GDFONTPATH and GNUPLOT_DEFAULT_GDFONT
+               environment variables. See the FAQ file in /usr/share/doc/${PF}/
+               for more information.'
+
+       eautoreconf
+
+       # Make sure we don't mix build & host flags.
+       sed -i \
+               -e 's:@CPPFLAGS@:$(BUILD_CPPFLAGS):' \
+               -e 's:@CFLAGS@:$(BUILD_CFLAGS):' \
+               -e 's:@LDFLAGS@:$(BUILD_LDFLAGS):' \
+               -e 's:@CC@:$(CC_FOR_BUILD):' \
+               docs/Makefile.in || die
+}
+
+src_configure() {
+       if ! use latex; then
+               sed -i -e '/SUBDIRS/s/LaTeX//' share/Makefile.in || die
+       fi
+
+       if use wxwidgets; then
+               WX_GTK_VER="3.0"
+               need-wxwidgets unicode
+       fi
+
+       tc-export CC CXX                        #453174
+       tc-export_build_env BUILD_CC
+       export CC_FOR_BUILD=${BUILD_CC}
+
+       use qt5 && append-cxxflags -std=c++11
+
+       econf \
+               --with-texdir="${TEXMF}/tex/latex/${PN}" \
+               --with-readline=$(usex readline gnu builtin) \
+               $(use_with bitmap bitmap-terminals) \
+               $(use_with cairo) \
+               $(use_enable compat backwards-compatibility) \
+               $(use_with doc tutorial) \
+               $(use_with gd) \
+               "$(use_with ggi ggi "${EPREFIX}/usr/$(get_libdir)")" \
+               "$(use_with ggi xmi "${EPREFIX}/usr/$(get_libdir)")" \
+               "$(use_with libcaca caca "${EPREFIX}/usr/$(get_libdir)")" \
+               $(use_with libcerf) \
+               $(use_with lua) \
+               $(use_with regis) \
+               $(use_with svga linux-vga) \
+               $(use_with X x) \
+               --enable-stats \
+               $(use_with qt5 qt qt5) \
+               $(use_enable wxwidgets) \
+               DIST_CONTACT="https://bugs.gentoo.org/" \
+               EMACS=no
+}
+
+src_compile() {
+       # Prevent access violations, see bug 201871
+       export VARTEXFONTS="${T}/fonts"
+
+       # We believe that the following line is no longer needed.
+       # In case of problems file a bug report at bugs.gentoo.org.
+       #addwrite /dev/svga:/dev/mouse:/dev/tts/0
+
+       emake all
+
+       if use doc; then
+               # Avoid sandbox violation in epstopdf/ghostscript
+               addpredict /var/cache/fontconfig
+               if use cairo; then
+                       emake -C docs pdf
+               else
+                       ewarn "Cannot build figures unless cairo is enabled."
+                       ewarn "Building documentation without figures."
+                       emake -C docs pdf_nofig
+                       mv docs/nofigures.pdf docs/gnuplot.pdf || die
+               fi
+               emake -C tutorial pdf
+       fi
+}
+
+src_install () {
+       emake DESTDIR="${D}" install
+
+       dodoc BUGS ChangeLog NEWS PGPKEYS README* RELEASE_NOTES TODO
+       newdoc term/PostScript/README README-ps
+       newdoc term/js/README README-js
+       use lua && newdoc term/lua/README README-lua
+       readme.gentoo_create_doc
+
+       if use examples; then
+               # Demo files
+               insinto /usr/share/${PN}/${GP_VERSION}
+               doins -r demo
+               rm -f "${ED%/}"/usr/share/${PN}/${GP_VERSION}/demo/Makefile*
+               rm -f "${ED%/}"/usr/share/${PN}/${GP_VERSION}/demo/binary*
+       fi
+
+       if use doc; then
+               # Manual, tutorial, FAQ
+               dodoc docs/gnuplot.pdf tutorial/{tutorial.dvi,tutorial.pdf} FAQ.pdf
+               # Documentation for making PostScript files
+               docinto psdoc
+               dodoc docs/psdoc/{*.doc,*.tex,*.ps,*.gpi,README}
+       fi
+}
+
+src_test() {
+       GNUTERM="unknown" default_src_test
+}
+
+pkg_postinst() {
+       use latex && texmf-update
+       readme.gentoo_print_elog
+}
+
+pkg_postrm() {
+       use latex && texmf-update
+}