Version bump.
authorDiego Elio Pettenò <flameeyes@gentoo.org>
Mon, 11 Dec 2006 19:45:58 +0000 (19:45 +0000)
committerDiego Elio Pettenò <flameeyes@gentoo.org>
Mon, 11 Dec 2006 19:45:58 +0000 (19:45 +0000)
Package-Manager: portage-2.1.2_rc3-r2

15 files changed:
media-sound/alsa-driver/ChangeLog
media-sound/alsa-driver/alsa-driver-1.0.14_rc1.ebuild [new file with mode: 0644]
media-sound/alsa-driver/files/digest-alsa-driver-1.0.14_rc1 [new file with mode: 0644]
media-sound/alsa-firmware/ChangeLog
media-sound/alsa-firmware/alsa-firmware-1.0.14_rc1.ebuild [new file with mode: 0644]
media-sound/alsa-firmware/files/digest-alsa-firmware-1.0.14_rc1 [new file with mode: 0644]
media-sound/alsa-headers/ChangeLog
media-sound/alsa-headers/alsa-headers-1.0.14_rc1.ebuild [new file with mode: 0644]
media-sound/alsa-headers/files/digest-alsa-headers-1.0.14_rc1 [new file with mode: 0644]
media-sound/alsa-tools/ChangeLog
media-sound/alsa-tools/alsa-tools-1.0.14_rc1.ebuild [new file with mode: 0644]
media-sound/alsa-tools/files/digest-alsa-tools-1.0.14_rc1 [new file with mode: 0644]
media-sound/alsa-utils/ChangeLog
media-sound/alsa-utils/alsa-utils-1.0.14_rc1.ebuild [new file with mode: 0644]
media-sound/alsa-utils/files/digest-alsa-utils-1.0.14_rc1 [new file with mode: 0644]

index 20598c4676b371f31fb99ac588268fa3d3c67546..5879fb8f3c5a5d7057b2ba65f05a03a690debeb9 100644 (file)
@@ -1,6 +1,12 @@
 # ChangeLog for media-sound/alsa-driver
 # Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/alsa-driver/ChangeLog,v 1.243 2006/12/07 08:07:13 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/alsa-driver/ChangeLog,v 1.244 2006/12/11 19:45:58 flameeyes Exp $
+
+*alsa-driver-1.0.14_rc1 (11 Dec 2006)
+
+  11 Dec 2006; Diego Pettenò <flameeyes@gentoo.org>
+  +alsa-driver-1.0.14_rc1.ebuild:
+  Version bump.
 
   07 Dec 2006; Diego Pettenò <flameeyes@gentoo.org>
   alsa-driver-1.0.14_pre20061130.ebuild:
diff --git a/media-sound/alsa-driver/alsa-driver-1.0.14_rc1.ebuild b/media-sound/alsa-driver/alsa-driver-1.0.14_rc1.ebuild
new file mode 100644 (file)
index 0000000..6d7a0ac
--- /dev/null
@@ -0,0 +1,189 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/alsa-driver/alsa-driver-1.0.14_rc1.ebuild,v 1.1 2006/12/11 19:45:58 flameeyes Exp $
+
+WANT_AUTOCONF="latest"
+WANT_AUTOMAKE="latest"
+
+inherit linux-mod flag-o-matic eutils multilib autotools
+
+MY_P="${P/_rc/rc}"
+S="${WORKDIR}/${MY_P}"
+
+DESCRIPTION="Advanced Linux Sound Architecture kernel modules"
+HOMEPAGE="http://www.alsa-project.org/"
+SRC_URI="mirror://alsaproject/driver/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2 LGPL-2.1"
+SLOT="0"
+
+KEYWORDS="~alpha ~amd64 ~ia64 ~mips ~ppc ~ppc64 ~x86"
+IUSE="oss debug"
+
+IUSE_CARDS="seq-dummy dummy virmidi mtpav mts64 serial-u16550 mpu401 serialmidi loopback
+portman2x4 pcsp ad1848-lib cs4231-lib adlib ad1816a ad1848 als100 azt2320 cmi8330
+cs4231 cs4232 cs4236 dt019x es968 es1688 es18xx gusclassic gusextreme gusmax
+interwave interwave-stb opl3sa2 opti92x-ad1848 opti92x-cs4231 opti93x miro
+sb8 sb16 sbawe sgalaxy sscape wavefront pc98-cs4232 msnd-pinnacle ad1889 als300
+als4000 ali5451 atiixp atiixp-modem au8810 au8820 au8830 azt3328 bt87x ca0106 cmipci
+cs4281 cs46xx cs5535audio darla20 gina20 layla20 darla24 gina24 layla24 mona mia
+echo3g indigo indigoio indigodj emu10k1 emu10k1x ens1370 ens1371 es1938 es1968
+fm801 fm801-tea575x hda-intel hdsp hdspm ice1712 ice1724 intel8x0 intel8x0m korg1212
+maestro3 mixart nm256 pcxhr riptide rme32 rme96 rme9652 sonicvibes trident via82xx
+via82xx-modem vx222 ymfpci pdplus asihpi powermac aoa aoa-fabric-layout aoa-onyx
+aoa-tas aoa-toonie aoa-soundbus aoa-soundbus-i2s sa11xx-uda1341 armaaci
+s3c2410 pxa2xx-i2sound au1x00 usb-audio usb-usx2y vxpocket pdaudiocf sun-amd7930
+sun-cs4231 sun-dbri harmony soc at91-soc at91-soc-eti-b1-wm8731 pxa2xx-soc
+pxa2xx-soc-corgi pxa2xx-soc-spitz pxa2xx-soc-poodle pxa2xx-soc-tosa"
+
+for iuse_card in ${IUSE_CARDS}; do
+       IUSE="${IUSE} alsa_cards_${iuse_card}"
+done
+
+
+RDEPEND="virtual/modutils
+        ~media-sound/alsa-headers-${PV}
+        !media-sound/snd-aoa"
+DEPEND="${RDEPEND}
+       virtual/linux-sources
+       sys-apps/debianutils"
+
+PROVIDE="virtual/alsa"
+
+pkg_setup() {
+       # By default, drivers for all supported cards will be compiled.
+       # If you want to only compile for specific card(s), set ALSA_CARDS
+       # environment to a space-separated list of drivers that you want to build.
+       # For example:
+       #
+       #       env ALSA_CARDS='emu10k1 intel8x0 ens1370' emerge alsa-driver
+       #
+       ALSA_CARDS=${ALSA_CARDS:-${IUSE_ALSA_CARDS}}
+
+       local PNP_DRIVERS="interwave interwave-stb"
+       local PNP_ERROR="Some of the drivers you selected require PnP support in your kernel (${PNP_DRIVERS}). Either enable PnP in your kernel or trim which drivers get compiled using ALSA_CARDS in /etc/make.conf."
+
+       local ISA_DRIVERS="cs4232 msnd-pinnacle cs4231-lib adlib ad1816a ad1848 als100 azt2320
+               cmi8330 cs4231 cs4236 dt019x  es968 es1688 es18xx gusclassic gusextreme gusmax
+               interwave interwave-stb opl3sa2 opti92x-ad1848 opti92x-cs4231 opti93x miro sb8
+               sb16 sbawe sb16_csp sgalaxy sscape wavefront"
+       local ISA_ERROR="Some of the drivers you selected require ISA support in your kernel ($(echo $ISA_DRIVERS)). Either enable ISA in your kernel or trim which drivers get compiled using ALSA_CARDS in /etc/make.conf."
+
+       local FW_DRIVERS="emu10k1 asihpi"
+       local FW_LOADER_ERROR="Some of the drivers you selected require 'Userspace firmware loading support' in your kernel (${FW_DRIVERS}). Either enable that feature or trim which drivers get compiled using ALSA_CARDS in /etc/make.conf."
+
+       local TMP_ALSA_CARDS
+       local CHECK_PNP
+       local CHECK_ISA
+       local CHECK_FW
+       for card in ${ALSA_CARDS}; do
+               if has alsa_cards_${card} ${IUSE} && use alsa_cards_${card}; then
+                       TMP_ALSA_CARDS="${TMP_ALSA_CARDS} ${card}"
+                       has ${card} ${PNP_DRIVERS} && CHECK_PNP="PNP"
+                       has ${card} ${ISA_DRIVERS} && CHECK_ISA="ISA"
+                       has ${card} ${FW_DRIVERS} && CHECK_FW="FW_LOADER"
+               fi
+       done
+       ALSA_CARDS="${TMP_ALSA_CARDS}"
+
+       local CONFIG_CHECK="!SND SOUND ${CHECK_PNP} ${CHECK_ISA} ${CHECK_FW}"
+       local SND_ERROR="ALSA is already compiled into the kernel."
+       local SOUND_ERROR="Your kernel doesn't have sound support enabled."
+       local SOUND_PRIME_ERROR="Your kernel is configured to use the deprecated OSS drivers.    Please disable them and re-emerge alsa-driver."
+
+       linux-mod_pkg_setup
+
+       if [[ ${PROFILE_ARCH} == "sparc64" ]] ; then
+               export CBUILD=${CBUILD-${CHOST}}
+               export CHOST="sparc64-unknown-linux-gnu"
+       fi
+}
+
+src_unpack() {
+       unpack ${A}
+
+       cd "${S}"
+
+       epatch "${FILESDIR}/${PN}-1.0.10_rc1-include.patch"
+
+       epatch "${FILESDIR}/${PN}-mcp55.patch"
+
+       if kernel_is ge 2 6 17 ; then
+               # These are needed for some drivers to build with kernel 2.6.17
+               # until a refreshed release of alsa-driver is done
+               epatch "${FILESDIR}/${PN}-1.0.11-kernel-2.6.17.patch"
+
+               # asihpi driver is broken, skip it until upstream releases something
+               # working.
+               sed -i -e 's:asihpi/::' "${S}/pci/Makefile"
+       fi
+
+       convert_to_m "${S}/Makefile"
+       sed -i -e 's:\(.*depmod\):#\1:' "${S}/Makefile"
+
+       emake -j1 all-deps || die "make all-deps failed"
+       eaclocal
+       eautoconf
+}
+
+src_compile() {
+       local myABI=${ABI:-${DEFAULT_ABI}}
+
+       # Should fix bug #46901
+       is-flag "-malign-double" && filter-flags "-fomit-frame-pointer"
+       append-flags "-I${KV_DIR}/arch/$(tc-arch-kernel)/include"
+
+       econf $(use_with oss) \
+               $(use_with debug debug full) \
+               --with-kernel="${KV_DIR}" \
+               --with-build="${KV_OUT_DIR}" \
+               --with-isapnp=yes \
+               --with-sequencer=yes \
+               --with-cards="${ALSA_CARDS}" || die "econf failed"
+
+       # linux-mod_src_compile doesn't work well with alsa
+
+       ARCH=$(tc-arch-kernel)
+       ABI=${KERNEL_ABI}
+       emake LDFLAGS="$(raw-ldflags)" HOSTCC=$(tc-getBUILD_CC) CC=$(tc-getCC) || die "Make Failed"
+       ARCH=$(tc-arch)
+       ABI=${myABI}
+}
+
+
+src_install() {
+       emake DESTDIR="${D}" install-modules || die "make install failed"
+
+       dodoc CARDS-STATUS FAQ README WARNING TODO
+
+       if kernel_is 2 6; then
+               # mv the drivers somewhere they won't be killed by the kernel's make modules_install
+               mv "${D}/lib/modules/${KV_FULL}/kernel/sound" "${D}/lib/modules/${KV_FULL}/${PN}"
+               rmdir "${D}/lib/modules/${KV_FULL}/kernel" &> /dev/null
+       fi
+}
+
+pkg_postinst() {
+       elog
+       elog "The alsasound initscript and modules.d/alsa have now moved to alsa-utils"
+       elog
+       elog "Also, remember that all mixer channels will be MUTED by default."
+       elog "Use the 'alsamixer' program to unmute them."
+       elog
+       elog "If you experience problems, please report bugs to http://bugs.gentoo.org."
+       elog
+
+       linux-mod_pkg_postinst
+
+       elog "Check out the ALSA installation guide availible at the following URL:"
+       elog "http://www.gentoo.org/doc/en/alsa-guide.xml"
+
+       if kernel_is 2 6 && [ -e "${ROOT}/lib/modules/${KV_FULL}/kernel/sound" ]; then
+               # Cleanup if they had older alsa installed
+               for file in $(find "${ROOT}/lib/modules/${KV_FULL}/${PN}" -type f); do
+                       rm -f ${file//${KV_FULL}\/${PN}/${KV_FULL}\/kernel\/sound}
+               done
+
+               find "${ROOT}/lib/modules/${KV_FULL}/kernel/sound" -type d -print0 | xargs rmdir
+       fi
+}
diff --git a/media-sound/alsa-driver/files/digest-alsa-driver-1.0.14_rc1 b/media-sound/alsa-driver/files/digest-alsa-driver-1.0.14_rc1
new file mode 100644 (file)
index 0000000..b9790ac
--- /dev/null
@@ -0,0 +1,3 @@
+MD5 4cff99be4b225e96663fbd61cabe3182 alsa-driver-1.0.14rc1.tar.bz2 2515938
+RMD160 83f18e77bcd28e1eaccd66967de0dab0bfa84106 alsa-driver-1.0.14rc1.tar.bz2 2515938
+SHA256 09318cc3cc5bcf2eb69c1d75e2e045f625b8756d4879e5c2c0a1f3951524766d alsa-driver-1.0.14rc1.tar.bz2 2515938
index e6af110f99d1327e35935f1114549a9897554348..ad64104bc3ddb798eaffad8fcc1ea8979b7b3a19 100644 (file)
@@ -1,6 +1,12 @@
 # ChangeLog for media-sound/alsa-firmware
 # Copyright 2000-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/alsa-firmware/ChangeLog,v 1.45 2006/11/13 02:02:21 josejx Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/alsa-firmware/ChangeLog,v 1.46 2006/12/11 19:44:00 flameeyes Exp $
+
+*alsa-firmware-1.0.14_rc1 (11 Dec 2006)
+
+  11 Dec 2006; Diego Pettenò <flameeyes@gentoo.org>
+  +alsa-firmware-1.0.14_rc1.ebuild:
+  Version bump.
 
   13 Nov 2006; Joseph Jezak <josejx@gentoo.org> alsa-firmware-1.0.13.ebuild:
   Marked ppc stable.
diff --git a/media-sound/alsa-firmware/alsa-firmware-1.0.14_rc1.ebuild b/media-sound/alsa-firmware/alsa-firmware-1.0.14_rc1.ebuild
new file mode 100644 (file)
index 0000000..c318b84
--- /dev/null
@@ -0,0 +1,31 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/alsa-firmware/alsa-firmware-1.0.14_rc1.ebuild,v 1.1 2006/12/11 19:44:00 flameeyes Exp $
+
+MY_P="${P/_rc/rc}"
+
+DESCRIPTION="Advanced Linux Sound Architecture firmware"
+HOMEPAGE="http://www.alsa-project.org/"
+SRC_URI="mirror://alsaproject/firmware/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+
+S="${WORKDIR}/${MY_P}"
+
+DEPEND=""
+
+src_compile() {
+       econf \
+               --with-hotplug-dir=/lib/firmware \
+               || die "configure failed"
+
+       emake || die "make failed"
+}
+
+src_install () {
+       emake DESTDIR="${D}" install || die "make install failed"
+       dodoc README
+}
diff --git a/media-sound/alsa-firmware/files/digest-alsa-firmware-1.0.14_rc1 b/media-sound/alsa-firmware/files/digest-alsa-firmware-1.0.14_rc1
new file mode 100644 (file)
index 0000000..0c274f0
--- /dev/null
@@ -0,0 +1,3 @@
+MD5 8a9507ae2e3fcfa239c0f672c327b067 alsa-firmware-1.0.14rc1.tar.bz2 3003831
+RMD160 b5e8885f97f33c95d8175832574a687207bc9da3 alsa-firmware-1.0.14rc1.tar.bz2 3003831
+SHA256 57d4bc483b940ff92f241e18e1eaa9a12e6b504c1b689092c85853cbb8890097 alsa-firmware-1.0.14rc1.tar.bz2 3003831
index 3c77edf645efee1fcdc01d0d83e55efa3e4db4ad..f044be8342543728f76d1592ab663571a5a6f661 100644 (file)
@@ -1,6 +1,12 @@
 # ChangeLog for media-sound/alsa-headers
 # Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/alsa-headers/ChangeLog,v 1.108 2006/12/03 18:55:49 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/alsa-headers/ChangeLog,v 1.109 2006/12/11 19:44:12 flameeyes Exp $
+
+*alsa-headers-1.0.14_rc1 (11 Dec 2006)
+
+  11 Dec 2006; Diego Pettenò <flameeyes@gentoo.org>
+  +alsa-headers-1.0.14_rc1.ebuild:
+  Version bump.
 
   03 Dec 2006; Diego Pettenò <flameeyes@gentoo.org>
   alsa-headers-1.0.13.ebuild, alsa-headers-1.0.14_pre20061130.ebuild,
diff --git a/media-sound/alsa-headers/alsa-headers-1.0.14_rc1.ebuild b/media-sound/alsa-headers/alsa-headers-1.0.14_rc1.ebuild
new file mode 100644 (file)
index 0000000..dd87fe6
--- /dev/null
@@ -0,0 +1,44 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/alsa-headers/alsa-headers-1.0.14_rc1.ebuild,v 1.1 2006/12/11 19:44:12 flameeyes Exp $
+
+inherit eutils
+
+MY_PN=${PN/headers/driver}
+MY_P="${MY_PN}-${PV/_rc/rc}"
+S=${WORKDIR}/${MY_P}
+
+DESCRIPTION="Header files for Advanced Linux Sound Architecture kernel modules"
+HOMEPAGE="http://www.alsa-project.org/"
+SRC_URI="mirror://alsaproject/driver/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2 LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86"
+IUSE=""
+
+DEPEND=""
+
+RESTRICT="binchecks strip"
+
+# Remove the sound symlink workaround...
+pkg_setup() {
+       if [[ -L "${ROOT}/usr/include/sound" ]]; then
+               rm      "${ROOT}/usr/include/sound"
+       fi
+}
+
+src_unpack() {
+       unpack ${A}
+
+       cd "${S}"
+       epatch "${FILESDIR}/${PN}-1.0.6a-user.patch"
+}
+
+src_compile() { :; }
+
+src_install() {
+       cd "${S}/alsa-kernel/include"
+       insinto /usr/include/sound
+       doins *.h || die "include failed"
+}
diff --git a/media-sound/alsa-headers/files/digest-alsa-headers-1.0.14_rc1 b/media-sound/alsa-headers/files/digest-alsa-headers-1.0.14_rc1
new file mode 100644 (file)
index 0000000..b9790ac
--- /dev/null
@@ -0,0 +1,3 @@
+MD5 4cff99be4b225e96663fbd61cabe3182 alsa-driver-1.0.14rc1.tar.bz2 2515938
+RMD160 83f18e77bcd28e1eaccd66967de0dab0bfa84106 alsa-driver-1.0.14rc1.tar.bz2 2515938
+SHA256 09318cc3cc5bcf2eb69c1d75e2e045f625b8756d4879e5c2c0a1f3951524766d alsa-driver-1.0.14rc1.tar.bz2 2515938
index 3d97fd38b4a0c84ca87a4e1a24d274139185a073..45fa88cac3b1f442f0f4fc44c4107f9de4d33ae3 100644 (file)
@@ -1,6 +1,12 @@
 # ChangeLog for media-sound/alsa-tools
 # Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/alsa-tools/ChangeLog,v 1.124 2006/11/13 02:04:12 josejx Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/alsa-tools/ChangeLog,v 1.125 2006/12/11 19:45:19 flameeyes Exp $
+
+*alsa-tools-1.0.14_rc1 (11 Dec 2006)
+
+  11 Dec 2006; Diego Pettenò <flameeyes@gentoo.org>
+  +alsa-tools-1.0.14_rc1.ebuild:
+  Version bump.
 
   13 Nov 2006; Joseph Jezak <josejx@gentoo.org> alsa-tools-1.0.13.ebuild:
   Marked ppc stable.
diff --git a/media-sound/alsa-tools/alsa-tools-1.0.14_rc1.ebuild b/media-sound/alsa-tools/alsa-tools-1.0.14_rc1.ebuild
new file mode 100644 (file)
index 0000000..7970ea7
--- /dev/null
@@ -0,0 +1,111 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/alsa-tools/alsa-tools-1.0.14_rc1.ebuild,v 1.1 2006/12/11 19:45:19 flameeyes Exp $
+
+inherit eutils flag-o-matic autotools
+
+MY_P="${P/_rc/rc}"
+
+DESCRIPTION="Advanced Linux Sound Architecture tools"
+HOMEPAGE="http://www.alsa-project.org"
+SRC_URI="mirror://alsaproject/tools/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0.9"
+KEYWORDS="~amd64 ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
+IUSE="fltk gtk"
+
+RDEPEND=">=media-libs/alsa-lib-1.0.0
+       virtual/alsa
+       fltk? ( =x11-libs/fltk-1.1* )
+       gtk? ( =x11-libs/gtk+-2* )"
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}/${MY_P}"
+
+pkg_setup() {
+       # This is a list of the tools in the package.
+       # Some of the tools don't make proper use of CFLAGS, even though
+       # all of them seem to use autoconf.      This needs to be fixed.
+       #
+       # By default, all the supported tools will be compiled.
+       # If you want to only compile for specific tool(s), set ALSA_TOOLS
+       # environment to a space-separated list of tools that you want to build.
+       # For example:
+       #
+       #       env ALSA_TOOLS='as10k1 ac3dec' emerge alsa-tools
+       #
+       if [ -z "${ALSA_TOOLS}" ]; then
+               ALSA_TOOLS="ac3dec as10k1 hdsploader mixartloader seq/sbiload \
+                                       sscape_ctl us428control usx2yloader vxloader"
+
+               if use fltk; then
+                       ALSA_TOOLS="${ALSA_TOOLS} hdspconf hdspmixer"
+               fi
+
+               if use gtk; then
+                       ALSA_TOOLS="${ALSA_TOOLS} echomixer envy24control rmedigicontrol"
+               fi
+
+               # sb16_csp won't build on ppc64 _AND_ ppc (and is not needed)
+               if      use !ppc64 && use !ppc; then
+                       ALSA_TOOLS="${ALSA_TOOLS} sb16_csp"
+               fi
+
+       fi
+}
+
+src_unpack() {
+       unpack ${A}
+       cd "${S}"
+
+       epatch "${FILESDIR}/${PN}-1.0.11-asneeded.patch"
+
+       for dir in echomixer envy24control rmedigicontrol; do
+               pushd ${dir} &> /dev/null
+               eautomake
+               popd &> /dev/null
+       done
+
+       elibtoolize
+}
+
+src_compile() {
+       if use fltk; then
+               # hdspmixer requires fltk
+               append-ldflags "-L/usr/$(get_libdir)/fltk-1.1"
+               append-flags "-I/usr/include/fltk-1.1"
+       fi
+
+       # hdspmixer is missing depconf - copy from the hdsploader directory
+       cp ${S}/hdsploader/depcomp ${S}/hdspmixer/
+
+       local f
+       for f in ${ALSA_TOOLS}
+       do
+               cd "${S}/${f}"
+               econf || die "econf failed"
+               make || die "make failed"
+       done
+}
+
+src_install() {
+       local f
+       for f in ${ALSA_TOOLS}
+       do
+               # Install the main stuff
+               cd "${S}/${f}"
+               emake DESTDIR="${D}" install || die
+
+               # Install the text documentation
+               local doc
+               for doc in README TODO ChangeLog AUTHORS
+               do
+                       if [ -f "${doc}" ]
+                       then
+                       mv "${doc}" "${doc}.`basename ${f}`"
+                       dodoc "${doc}.`basename ${f}`"
+                       fi
+               done
+       done
+}
diff --git a/media-sound/alsa-tools/files/digest-alsa-tools-1.0.14_rc1 b/media-sound/alsa-tools/files/digest-alsa-tools-1.0.14_rc1
new file mode 100644 (file)
index 0000000..ea2770e
--- /dev/null
@@ -0,0 +1,3 @@
+MD5 09f083d7fdc7647d883dcb1cf872fa90 alsa-tools-1.0.14rc1.tar.bz2 1466476
+RMD160 7c0e0131bfa91b9b07705204ebacca2b5b87a19b alsa-tools-1.0.14rc1.tar.bz2 1466476
+SHA256 d29ebd324359263d98428213f4fc2f58a12b108f9fce9c3b8bde18e315f4ac36 alsa-tools-1.0.14rc1.tar.bz2 1466476
index 6010896ffdd8da71471c722408ae9b8be3cee9fc..eb46e57cd8fdbc146cc0521904c18fe96a1f6467 100644 (file)
@@ -1,6 +1,12 @@
 # ChangeLog for media-sound/alsa-utils
 # Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/alsa-utils/ChangeLog,v 1.176 2006/11/08 01:27:21 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/alsa-utils/ChangeLog,v 1.177 2006/12/11 19:44:06 flameeyes Exp $
+
+*alsa-utils-1.0.14_rc1 (11 Dec 2006)
+
+  11 Dec 2006; Diego Pettenò <flameeyes@gentoo.org>
+  +alsa-utils-1.0.14_rc1.ebuild:
+  Version bump.
 
   08 Nov 2006; Jeroen Roovers <jer@gentoo.org> alsa-utils-1.0.13.ebuild:
   Stable for HPPA (bug #150540).
diff --git a/media-sound/alsa-utils/alsa-utils-1.0.14_rc1.ebuild b/media-sound/alsa-utils/alsa-utils-1.0.14_rc1.ebuild
new file mode 100644 (file)
index 0000000..34cf5b4
--- /dev/null
@@ -0,0 +1,84 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/alsa-utils/alsa-utils-1.0.14_rc1.ebuild,v 1.1 2006/12/11 19:44:06 flameeyes Exp $
+
+inherit eutils autotools
+
+MY_P="${P/_rc/rc}"
+
+DESCRIPTION="Advanced Linux Sound Architecture Utils (alsactl, alsamixer, etc.)"
+HOMEPAGE="http://www.alsa-project.org/"
+SRC_URI="mirror://alsaproject/utils/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0.9"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86"
+IUSE="nls"
+
+DEPEND=">=sys-libs/ncurses-5.1
+       dev-util/dialog
+       >=media-libs/alsa-lib-1.0.12"
+RDEPEND="${DEPEND}
+       sys-apps/pciutils"
+
+S=${WORKDIR}/${MY_P}
+
+src_unpack() {
+       unpack ${A}
+       cd "${S}"
+
+       epatch "${FILESDIR}/${PN}-1.0.11_rc2-nls.patch"
+       epatch "${FILESDIR}/${PN}-1.0.11_rc5-alsaconf-redirect.patch"
+}
+
+src_compile() {
+       econf \
+               $(use_enable nls) \
+               || die "configure failed"
+
+       emake || die "make failed"
+}
+
+src_install() {
+       local ALSA_UTILS_DOCS="ChangeLog README TODO
+               seq/aconnect/README.aconnect
+               seq/aseqnet/README.aseqnet"
+
+       emake DESTDIR="${D}" install || die "Installation Failed"
+
+       dodoc ${ALSA_UTILS_DOCS}
+       newdoc alsamixer/README README.alsamixer
+
+       newconfd "${FILESDIR}/alsasound.confd" alsasound
+       insinto /etc/modules.d
+       newins "${FILESDIR}/alsa-modules.conf-rc" alsa
+       newinitd "${FILESDIR}/alsasound-1.0.10_rc2" alsasound
+}
+
+pkg_postinst() {
+       echo
+       einfo "The alsasound initscript is now provided by alsa-utils"
+       einfo "instead of alsa-driver for compatibility with kernel-sources"
+       einfo "which provide ALSA internally."
+       echo
+       einfo "To take advantage of this, and automate the process of"
+       einfo "loading and unloading the ALSA sound drivers as well as"
+       einfo "storing and restoring sound-card mixer levels you should"
+       einfo "add alsasound to the boot runlevel. You can do this as"
+       einfo "root like so:"
+       einfo " # rc-update add alsasound boot"
+       echo
+       einfo "You will also need to edit the file /etc/modules.d/alsa"
+       einfo "and run modules-update. You can do this like so:"
+       einfo " # nano -w /etc/modules.d/alsa && modules-update"
+       echo
+
+       if use sparc; then
+               ewarn "Old versions of alsa-drivers had a broken snd-ioctl32 module"
+               ewarn "which causes sparc64 machines to lockup on such tasks as"
+               ewarn "changing the volume.      Because of this, it is VERY important"
+               ewarn "that you do not use the snd-ioctl32 modules contained in"
+               ewarn "development-sources or <=gentoo-dev-sources-2.6.7-r14.  Doing so"
+               ewarn "may result in an unbootable system if you start alsasound at boot."
+       fi
+}
diff --git a/media-sound/alsa-utils/files/digest-alsa-utils-1.0.14_rc1 b/media-sound/alsa-utils/files/digest-alsa-utils-1.0.14_rc1
new file mode 100644 (file)
index 0000000..165051f
--- /dev/null
@@ -0,0 +1,3 @@
+MD5 931b22590a3a897d71c92fef6b1c1949 alsa-utils-1.0.14rc1.tar.bz2 980802
+RMD160 7d05cca060486d64e6ba87aa8c4a7e9b7a069ddb alsa-utils-1.0.14rc1.tar.bz2 980802
+SHA256 9b8ede92cfa5f28d6bf6bb1253bdc562f8ac937797fb5e5303609e2e49c2e886 alsa-utils-1.0.14rc1.tar.bz2 980802