dev-python/pytables: Fix for Python 3.7
authorCraig Andrews <candrews@gentoo.org>
Mon, 26 Nov 2018 20:57:17 +0000 (15:57 -0500)
committerCraig Andrews <candrews@gentoo.org>
Thu, 6 Dec 2018 20:40:54 +0000 (15:40 -0500)
Closes: https://bugs.gentoo.org/664258
Package-Manager: Portage-2.3.52, Repoman-2.3.12
Signed-off-by: Craig Andrews <candrews@gentoo.org>
dev-python/pytables/pytables-3.4.2.ebuild

index 02d1be95e967b23a6acbbfe5b6022f05c4a50b2c..71c6708813cac29f5aec1155658b10bbaba2e047 100644 (file)
@@ -1,9 +1,9 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=6
 
-PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
+PYTHON_COMPAT=( python2_7 python3_{4,5,6,7} )
 PYTHON_REQ_USE="threads(+)"
 
 MY_PN=tables
@@ -45,6 +45,7 @@ python_prepare_all() {
        sed -e "s:/usr:${EPREFIX}/usr:g" \
                -i setup.py || die
        rm -r c-blosc/{blosc,internal-complibs} || die
+       sed -i -e '/_version/ s/\\s\*/\\s\+/' setup.py || die
        distutils-r1_python_prepare_all
 }