x11-misc/xstroke: Port to EAPI 7
authorDavid Seifert <soap@gentoo.org>
Tue, 24 Dec 2019 17:40:12 +0000 (18:40 +0100)
committerDavid Seifert <soap@gentoo.org>
Tue, 24 Dec 2019 17:40:12 +0000 (18:40 +0100)
Package-Manager: Portage-2.3.82, Repoman-2.3.20
Signed-off-by: David Seifert <soap@gentoo.org>
x11-misc/xstroke/xstroke-0.6-r1.ebuild

index c797405cf80245f58d9a3fb604ae0c2c41cb25e6..63e05e04026d186c7fcabfe46b49623f4123dbb2 100644 (file)
@@ -1,19 +1,17 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
-EAPI=4
-inherit autotools eutils
+EAPI=7
+
+inherit autotools
 
 DESCRIPTION="Gesture/Handwriting recognition engine for X"
-# Dead upstream?
-#HOMEPAGE="http://www.xstroke.org/"
 HOMEPAGE="http://freshmeat.net/projects/xstroke/"
 SRC_URI="mirror://gentoo/${P}.tar.bz2"
 
 LICENSE="GPL-2"
 SLOT="0"
 KEYWORDS="alpha ~amd64 hppa ~mips ppc sparc x86"
-IUSE=""
 
 RDEPEND="
        x11-libs/libX11
@@ -21,21 +19,21 @@ RDEPEND="
        x11-libs/libXft
        x11-libs/libXpm
        x11-libs/libXrender
-       x11-libs/libXtst
-"
+       x11-libs/libXtst"
 DEPEND="
        ${RDEPEND}
+       x11-base/xorg-proto"
+BDEPEND="
        sys-devel/flex
        virtual/pkgconfig
-       virtual/yacc
-       x11-base/xorg-proto
-"
+       virtual/yacc"
 
-DOCS=( AUTHORS ChangeLog NEWS README TODO )
+PATCHES=(
+       "${FILESDIR}"/${P}-sigsegv_sprintf.patch
+       "${FILESDIR}"/${P}-underlinking.patch
+)
 
 src_prepare() {
-       epatch \
-               "${FILESDIR}"/${P}-sigsegv_sprintf.patch \
-               "${FILESDIR}"/${P}-underlinking.patch
+       default
        eautoreconf
 }