dev-python/editorconfig-core-py: Enable py3.{7,8}
authorMichał Górny <mgorny@gentoo.org>
Wed, 22 Apr 2020 05:22:42 +0000 (07:22 +0200)
committerMichał Górny <mgorny@gentoo.org>
Wed, 22 Apr 2020 05:59:43 +0000 (07:59 +0200)
Signed-off-by: Michał Górny <mgorny@gentoo.org>
dev-python/editorconfig-core-py/editorconfig-core-py-0.12.0.ebuild

index 97128a013059bcece8032a944669b00ad866020a..c9cfa0e96b43ab965b860a79820f1d679681c0c0 100644 (file)
@@ -4,7 +4,7 @@
 EAPI=6
 
 TESTVER="abb579e00f2deeede91cb485e53512efab9c6474"
-PYTHON_COMPAT=( python3_6 )
+PYTHON_COMPAT=( python3_{6,7,8} )
 inherit distutils-r1
 
 DESCRIPTION="Clone of EditorConfig core written in Python"
@@ -43,11 +43,8 @@ python_install() {
        #use cli || rm -f "${D}/${EPREFIX}"/usr/bin
 }
 
-src_test() {
-       __src_test_run_python_impl() {
-               cmake -DPYTHON_EXECUTABLE="${PYTHON}" . || die "tests failed to build with ${EPYTHON}"
-               ctest . || die "tests failed with ${EPYTHON}"
-       }
-       python_foreach_impl __src_test_run_python_impl
-       unset __src_test_run_python_impl
+python_test() {
+       cmake -DPYTHON_EXECUTABLE="${PYTHON}" . ||
+               die "tests failed to build with ${EPYTHON}"
+       ctest . || die "tests failed with ${EPYTHON}"
 }