x11-misc/xkeyboard-config: Fix shebang
authorMatt Turner <mattst88@gentoo.org>
Tue, 17 Mar 2020 07:19:02 +0000 (00:19 -0700)
committerMatt Turner <mattst88@gentoo.org>
Tue, 17 Mar 2020 07:21:53 +0000 (00:21 -0700)
Bug: https://bugs.gentoo.org/712792
Signed-off-by: Matt Turner <mattst88@gentoo.org>
x11-misc/xkeyboard-config/files/xkeyboard-config-2.29-fix-python3-support.patch [new file with mode: 0644]
x11-misc/xkeyboard-config/xkeyboard-config-2.29.ebuild

diff --git a/x11-misc/xkeyboard-config/files/xkeyboard-config-2.29-fix-python3-support.patch b/x11-misc/xkeyboard-config/files/xkeyboard-config-2.29-fix-python3-support.patch
new file mode 100644 (file)
index 0000000..0f4d455
--- /dev/null
@@ -0,0 +1,34 @@
+From c847c834cce190c5c835a454bfe548195da9fa53 Mon Sep 17 00:00:00 2001
+From: MilhouseVH <milhouseVH.github@nmacleod.com>
+Date: Sun, 16 Feb 2020 09:41:43 +0000
+Subject: [PATCH] fix python3 support
+
+https://gitlab.freedesktop.org/xkeyboard-config/xkeyboard-config/issues/197
+---
+ rules/compat/map-variants.py | 6 +++---
+ 1 file changed, 3 insertions(+), 3 deletions(-)
+
+diff --git a/rules/compat/map-variants.py b/rules/compat/map-variants.py
+index ebbfec9..979ba43 100755
+--- a/rules/compat/map-variants.py
++++ b/rules/compat/map-variants.py
+@@ -1,4 +1,4 @@
+-#!/usr/bin/python3
++#!/usr/bin/env python3
+ import argparse
+ import re
+@@ -12,8 +12,8 @@ class Layout(object):
+             assert variant is None
+             # parse a layout(variant) string
+             match = re.match(r'([^(]+)\(([^)]+)\)', layout)
+-            self.layout = match[1]
+-            self.variant = match[2]
++            self.layout = match.groups()[0]
++            self.variant = match.groups()[1]
+     def __str__(self):
+         if self.variant:
+-- 
+2.24.1
+
index 318c18a9da630afbc0828c63a7b1ab0e8f03b1a3..6ff6eec8778a2f019c2d68171312e955a7127099 100644 (file)
@@ -28,6 +28,10 @@ BDEPEND="
 RDEPEND=""
 DEPEND="${LIVE_DEPEND}"
 
+PATCHES=(
+       "${FILESDIR}"/${P}-fix-python3-support.patch
+)
+
 src_prepare() {
        default
        [[ ${PV} == 9999 ]] && eautoreconf