use the new emul-libs.eclass
authorSimon Stelling <blubb@gentoo.org>
Wed, 21 Feb 2007 09:29:52 +0000 (09:29 +0000)
committerSimon Stelling <blubb@gentoo.org>
Wed, 21 Feb 2007 09:29:52 +0000 (09:29 +0000)
Package-Manager: portage-2.1.2-r9

app-emulation/emul-linux-x86-xlibs/ChangeLog
app-emulation/emul-linux-x86-xlibs/emul-linux-x86-xlibs-10.0.ebuild

index c8ef122da58b935c1904e8e0271d1391f86527f4..bcb6a6c035e68f5ec8761f0b1f044fa7ee18725e 100644 (file)
@@ -1,6 +1,10 @@
 # ChangeLog for app-emulation/emul-linux-x86-xlibs
 # Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/emul-linux-x86-xlibs/ChangeLog,v 1.57 2007/02/19 21:57:34 blubb Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/emul-linux-x86-xlibs/ChangeLog,v 1.58 2007/02/21 09:29:52 blubb Exp $
+
+  21 Feb 2007; Simon Stelling <blubb@gentoo.org>
+  emul-linux-x86-xlibs-10.0.ebuild:
+  use the new emul-libs.eclass
 
   19 Feb 2007; Simon Stelling <blubb@gentoo.org>
   emul-linux-x86-xlibs-10.0.ebuild:
index 5746bf6653c994a3e0140ce616e74f5249a0cdb6..3a61c99a820d067675ae23aa6d7d2c3fe956d3f3 100644 (file)
@@ -1,9 +1,9 @@
 # Copyright 1999-2007 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/emul-linux-x86-xlibs/emul-linux-x86-xlibs-10.0.ebuild,v 1.2 2007/02/19 21:57:34 blubb Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/emul-linux-x86-xlibs/emul-linux-x86-xlibs-10.0.ebuild,v 1.3 2007/02/21 09:29:52 blubb Exp $
+
+inherit emul-libs
 
-DESCRIPTION="Provides precompiled 32bit libraries"
-HOMEPAGE="http://amd64.gentoo.org/emul/content.xml"
 SRC_URI="mirror://gentoo/fontconfig-2.4.2.tbz2
        mirror://gentoo/freetype-2.1.10-r2.tbz2
        mirror://gentoo/glut-3.7.1.tbz2
@@ -41,46 +41,14 @@ LICENSE="fontconfig FTL GPL-2 LGPL-2 glut libdrm libICE libSM libX11 libXau
                libXaw libXcomposite libXcursor libXdamage libXdmcp libXext libXfixes libXft
                libXi libXinerama libXmu libXp libXpm libXrandr libXrender libXScrnSaver libXt
                libXtst libXv libXvMC libXxf86dga libXxf86dga libXxf86vm"
-SLOT="0"
 KEYWORDS="-* ~amd64"
 IUSE="opengl"
 
-RESTRICT="strip"
-S=${WORKDIR}
-
 DEPEND=""
 RDEPEND=">=app-emulation/emul-linux-x86-baselibs-10.0
        x11-libs/libX11
        opengl? ( app-admin/eselect-opengl )"
 
-pkg_setup() {
-       einfo "Note: You can safely ignore the 'trailing garbage after EOF'"
-       einfo "      warnings below"
-}
-
-src_unpack() {
-       unpack ${A}
-
-       # we only want the libs
-       ALLOWED="${S}/etc/env.d"
-       find ${S} ! -type d ! -name '*.so*' | grep -v "${ALLOWED}" | xargs rm -f
-}
-
-src_install() {
-       for dir in etc/env.d etc/revdep-rebuild ; do
-               if [[ -d ${S}/${dir} ]] ; then
-                       for f in ${S}/${dir}/* ; do
-                               mv -f $f{,-emul}
-                       done
-               fi
-       done
-
-       # remove void directories or portage will show weird output
-       find ${S} -type d -depth | xargs rmdir 2&>/dev/null
-
-       cp -a "${WORKDIR}"/* "${D}"/ || die "copying files failed!"
-}
-
 pkg_postinst() {
        #update GL symlinks
        use opengl && eselect opengl set --use-old