dev-python/widgetsnbextension: bump to 3.4.2
authorVirgil Dupras <vdupras@gentoo.org>
Sat, 4 May 2019 20:46:30 +0000 (16:46 -0400)
committerVirgil Dupras <vdupras@gentoo.org>
Sat, 4 May 2019 22:58:04 +0000 (18:58 -0400)
Also, drop py2.

Bug: https://bugs.gentoo.org/685040
Signed-off-by: Virgil Dupras <vdupras@gentoo.org>
Package-Manager: Portage-2.3.62, Repoman-2.3.11

dev-python/widgetsnbextension/Manifest
dev-python/widgetsnbextension/widgetsnbextension-3.4.2.ebuild [new file with mode: 0644]

index 61ab3c57b850a66d17c2f95f45f49bb27243f077..670ef3d424653024d765f7943992036f076aa07d 100644 (file)
@@ -1 +1,2 @@
 DIST widgetsnbextension-3.0.0.tar.gz 1253392 BLAKE2B 88d435b06fcbf759f7ea919ee69d3523f86f2a150bb7d411d9f2a41f9e4a6176a7900595ae5bd30232c203b81f3462a1178c001fbbf456f847597b0acbd20f12 SHA512 079a2ce837e37a8d1707b6686e5c23989bb79af298847ae6bd01dd0f6e570f91e86ff53ff4aa3a8cb4f56f895e3839ef96c722bd156599eb01893870aa1fb4dd
+DIST widgetsnbextension-3.4.2.tar.gz 1103610 BLAKE2B 1cbd08dc1b9e4a8350b2d3a6e21ad106cacae8da308b82af5c55a7d520fa0ddb6c82cd7aeff7d7521430bbbbed2aaa276d869a8eaa1122cd5a3b8f69e1376352 SHA512 e50daec0a6fc7df2317a1c90ed7713057b35e4c0aba626cc70a9d886aaf0c6ec3f820344d1e1e79b7895de41b6721dc209278395cdce61291bd03ada51c14613
diff --git a/dev-python/widgetsnbextension/widgetsnbextension-3.4.2.ebuild b/dev-python/widgetsnbextension/widgetsnbextension-3.4.2.ebuild
new file mode 100644 (file)
index 0000000..b8dcc91
--- /dev/null
@@ -0,0 +1,21 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{5,6,7} )
+PYTHON_REQ_USE="threads(+)"
+
+inherit distutils-r1
+
+DESCRIPTION="IPython HTML widgets for Jupyter"
+HOMEPAGE="http://ipython.org"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+RDEPEND="dev-python/notebook[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}"