use games_get_libdir
authorTristan Heaven <tristan@gentoo.org>
Fri, 6 Apr 2007 00:01:01 +0000 (00:01 +0000)
committerTristan Heaven <tristan@gentoo.org>
Fri, 6 Apr 2007 00:01:01 +0000 (00:01 +0000)
Package-Manager: portage-2.1.2.3

games-action/armagetronad/armagetronad-0.2.7.1-r1.ebuild
games-action/d1x/d1x-20040118.ebuild

index a5dc3c1dd5787da4f192632af7beb7904f6d0cee..cdf332dfe9dbd1735d5c1126868d615516398f81 100644 (file)
@@ -1,6 +1,6 @@
-# Copyright 1999-2006 Gentoo Foundation
+# Copyright 1999-2007 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-action/armagetronad/armagetronad-0.2.7.1-r1.ebuild,v 1.5 2006/10/31 04:39:48 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-action/armagetronad/armagetronad-0.2.7.1-r1.ebuild,v 1.6 2007/04/05 23:58:47 nyhm Exp $
 
 inherit eutils games
 
@@ -38,7 +38,7 @@ src_unpack() {
        cp "${FILESDIR}"/${PN}-ded "${FILESDIR}"/${PN} . || die
        sed -i \
                -e "s:@GAMES_SYSCONFDIR@:${GAMES_SYSCONFDIR}:" \
-               -e "s:@GAMES_LIBDIR@:${GAMES_LIBDIR}:" \
+               -e "s:@GAMES_LIBDIR@:$(games_get_libdir):" \
                -e "s:@GAMES_DATADIR@:${GAMES_DATADIR}:" \
                ${PN}-ded ${PN}
 }
@@ -56,7 +56,7 @@ src_install() {
        docinto html/net
        dohtml doc/net/*.html
        newicon tron.ico ${PN}.ico
-       exeinto "${GAMES_LIBDIR}/${PN}"
+       exeinto "$(games_get_libdir)/${PN}"
        if use dedicated ; then
                doexe src/tron/${PN}-dedicated || die "copying files"
        else
index 9862766cd7a2e05e0e0c2d821ffed1d06c987a44..ca7db30f672c812dd4eccc3bfe5430257d7c51f6 100644 (file)
@@ -1,6 +1,6 @@
 # Copyright 1999-2007 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-action/d1x/d1x-20040118.ebuild,v 1.9 2007/03/12 13:15:09 genone Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-action/d1x/d1x-20040118.ebuild,v 1.10 2007/04/06 00:01:01 nyhm Exp $
 
 inherit eutils games
 
@@ -77,7 +77,7 @@ src_unpack() {
        fi
 
        cd "\${HOME}/.d1x/"
-       exec "${GAMES_LIBDIR}"/${PN}/${binname} -missiondir "${GAMES_DATADIR}/d1x" "\$@"
+       exec "$(games_get_libdir)"/${PN}/${binname} -missiondir "${GAMES_DATADIR}/d1x" "\$@"
        EOS
 }
 
@@ -109,7 +109,7 @@ src_install() {
        doins d1x.ini || die
 
        # Install the binary executable
-       insinto "${GAMES_LIBDIR}/${PN}"
+       insinto "$(games_get_libdir)/${PN}"
        insopts -m0750
        doins "${binname}"