www-servers/nginx-unit: Bump to version 1.15.0
authorRalph Seichter <github@seichter.de>
Thu, 6 Feb 2020 20:36:23 +0000 (21:36 +0100)
committerJoonas Niilola <juippis@gentoo.org>
Fri, 7 Feb 2020 06:16:43 +0000 (08:16 +0200)
Upstream bugfix release. This ebuild adds support for PHP 7.4
and removes support for PHP 5.6 and 7.1.

Package-Manager: Portage-2.3.84, Repoman-2.3.20
Signed-off-by: Ralph Seichter <gentoo@seichter.de>
Closes: https://github.com/gentoo/gentoo/pull/14584
Signed-off-by: Joonas Niilola <juippis@gentoo.org>
www-servers/nginx-unit/Manifest
www-servers/nginx-unit/metadata.xml
www-servers/nginx-unit/nginx-unit-1.15.0.ebuild [new file with mode: 0644]

index 09116eb80fe6836f8b458187c9a1f08dcb29b3f6..655df639ef5a9264b07b13ff67e2148e78c1bbfb 100644 (file)
@@ -1,4 +1,5 @@
 DIST nginx-unit-1.12.0.tar.gz 681661 BLAKE2B 1e497172a37fdcd33d0ced5b97675bff42f4cadab2f9363316e667c90c8b4dc4b43f4b8d5cff9f547daa7e92d532550434907515134a5c958586f1822beea749 SHA512 a55a084ed6e1cd3f784bd81571772ca29ca9a0d19089c9bb74c88258d2e1ef872978219c47b6dc2610711ae1aa95ef68ddb77f45747a2eacdd9d92c6f8fee28b
 DIST nginx-unit-1.13.0.tar.gz 693159 BLAKE2B fd2e803188e66c16d5956f26e693c81273b1f3f69c9b68209f15bca6abd0e06b9fb9e03eb32ab640b8f601260b439abee1c4aa9cd03ed92fd26ab55893a6a6ab SHA512 cf33295604040963545b04f72f1a894431d4ee22a2c7b9560f18a694f110ee3bf243c90f65cfa4760a0009a5a7b132b75e1bb51439b19255e15148e8f4e9b9a7
 DIST nginx-unit-1.14.0.tar.gz 708603 BLAKE2B 482ab76a1eaef2943c0000c6dd2adf37aca285304b306e5b05d67e9cca30665269d11c1a585bd1a638d6811b8ee6370ef3cf682bebaf7165585cdaea51f3a5c8 SHA512 0cfe5364d427ff09d08c3b1b134827665f8bf70b8871f3c4506680e4c2d61249a53581122c42276b590f5eb077c398ae6a6c2fa46f24c680844b7d365f2ca66b
+DIST nginx-unit-1.15.0.tar.gz 712284 BLAKE2B 8db45644a22a4043de660ed0dcb94957e6e9f26ee1735a0a053128b0995cfb670d9c52d7d64ffa2292818cc7aed79071fdd753186f010e1bd0fae876f886adff SHA512 3be17ba5290d323283e962a3a5b9c244c3c45302848b62fdad2fd92129e330c8783b4f76273dedc7b010ed71bd6a4bf1cc4085a3425288b1e28dc532e1a1bf5a
 DIST nginx-unit-1.8.0.tar.gz 511226 BLAKE2B e396b27954840a5f1ad3a4cd9501a5e5fe769a754c51043da784a2c4596e6acc33089f495bf412a0db086e5c715a51292c7dece004a6512564421a431b6c339e SHA512 1d0ad05343ff70aff4c6e221a36c20df95fa2e2262ae5c69963a9bcb9ef883151e8a2fa9fef29f43ac5489aa5cbb3e9dfd10cf5e7f6d7a98742b490ebf3a0413
index ae56567e450aaf17c150ea34439232fb2f2c5ee1..c6f29a25070345245321e7ad837e147f534b7615 100644 (file)
@@ -21,6 +21,7 @@
                <flag name="php7-1">Support for PHP 7.1</flag>
                <flag name="php7-2">Support for PHP 7.2</flag>
                <flag name="php7-3">Support for PHP 7.3</flag>
+               <flag name="php7-4">Support for PHP 7.4</flag>
        </use>
        <upstream>
                <remote-id type="github">nginx/unit</remote-id>
diff --git a/www-servers/nginx-unit/nginx-unit-1.15.0.ebuild b/www-servers/nginx-unit/nginx-unit-1.15.0.ebuild
new file mode 100644 (file)
index 0000000..6dcccc6
--- /dev/null
@@ -0,0 +1,79 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=(python2_7 python3_{6,7,8})
+
+inherit flag-o-matic python-single-r1
+
+MY_P="unit-${PV}"
+DESCRIPTION="Dynamic web and application server"
+HOMEPAGE="https://unit.nginx.org"
+SRC_URI="https://unit.nginx.org/download/${MY_P}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+MY_USE="perl python ruby"
+MY_USE_PHP="php7-2 php7-3 php7-4"
+IUSE="${MY_USE} ${MY_USE_PHP} ssl"
+REQUIRED_USE="|| ( ${IUSE} )
+       python? ( ${PYTHON_REQUIRED_USE} )"
+
+DEPEND="perl? ( dev-lang/perl:= )
+       php7-2? ( dev-lang/php:7.2[embed] )
+       php7-3? ( dev-lang/php:7.3[embed] )
+       php7-4? ( dev-lang/php:7.4[embed] )
+       python? ( ${PYTHON_DEPS} )
+       ruby? ( dev-lang/ruby:* )
+       ssl? ( dev-libs/openssl:0 )"
+RDEPEND="${DEPEND}"
+S="${WORKDIR}/${MY_P}"
+
+pkg_setup() {
+       use python && python-single-r1_pkg_setup
+}
+
+src_prepare() {
+       eapply_user
+       sed -i '/^CFLAGS/d' auto/make || die
+}
+
+src_configure() {
+       local opt=(
+               --control=unix:/run/${PN}.sock
+               --log=/var/log/${PN}
+               --modules=$(get_libdir)/${PN}
+               --pid=/run/${PN}.pid
+               --prefix=/usr
+               --state=/var/lib/${PN}
+       )
+       use ssl && opt+=( --openssl )
+       export AR="$(tc-getAR)"
+       export CC="$(tc-getCC)"
+       ./configure ${opt[@]} --ld-opt="${LDFLAGS}" || die "Core configuration failed"
+       # Modules require position-independent code
+       append-cflags $(test-flags-CC -fPIC)
+       for flag in ${MY_USE} ; do
+               if use ${flag} ; then
+                       ./configure ${flag} || die "Module configuration failed: ${flag}"
+               fi
+       done
+       for flag in ${MY_USE_PHP} ; do
+               if use ${flag} ; then
+                       local php_slot="/usr/$(get_libdir)/${flag/-/.}"
+                       ./configure php \
+                               --module=${flag} \
+                               --config=${php_slot}/bin/php-config \
+                               --lib-path=${php_slot}/$(get_libdir) || die "Module configuration failed: ${flag}"
+               fi
+       done
+}
+
+src_install() {
+       default
+       diropts -m 0770
+       keepdir /var/lib/${PN}
+       newinitd "${FILESDIR}/${PN}.initd" ${PN}
+}