dev-libs/cppcodec: Update to EAPI 7, pin SLOT for deps
authorDavid Seifert <soap@gentoo.org>
Sat, 19 Jan 2019 14:20:40 +0000 (15:20 +0100)
committerDavid Seifert <soap@gentoo.org>
Sat, 19 Jan 2019 14:20:40 +0000 (15:20 +0100)
Package-Manager: Portage-2.3.56, Repoman-2.3.12
Signed-off-by: David Seifert <soap@gentoo.org>
dev-libs/cppcodec/cppcodec-0.2.ebuild
dev-libs/cppcodec/cppcodec-9999.ebuild

index fe7a12a7e61f727ca4bb923dd6990f0148760c88..ed1f2f4c8f3dfbf59557732eb5a0d4ab048c8581 100644 (file)
@@ -1,9 +1,8 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
-EAPI=6
+EAPI=7
 
-: ${CMAKE_MAKEFILE_GENERATOR:=ninja}
 inherit cmake-utils
 
 DESCRIPTION="C++11 library to encode/decode base64, base64url, base32, base32hex and hex"
@@ -25,11 +24,8 @@ SLOT="0"
 IUSE="test"
 RESTRICT="!test? ( test )"
 
-DEPEND="
-       test? (
-               virtual/pkgconfig
-               >=dev-cpp/catch-2.3.0
-       )"
+DEPEND="test? ( >=dev-cpp/catch-2.3.0:0 )"
+BDEPEND="test? ( virtual/pkgconfig )"
 
 src_configure() {
        local mycmakeargs=(
index 8fd88d739a88a105746635dcf6e78e7febdbfe7e..ed1f2f4c8f3dfbf59557732eb5a0d4ab048c8581 100644 (file)
@@ -1,9 +1,8 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
-EAPI=6
+EAPI=7
 
-: ${CMAKE_MAKEFILE_GENERATOR:=ninja}
 inherit cmake-utils
 
 DESCRIPTION="C++11 library to encode/decode base64, base64url, base32, base32hex and hex"
@@ -25,11 +24,8 @@ SLOT="0"
 IUSE="test"
 RESTRICT="!test? ( test )"
 
-DEPEND="
-       test? (
-               virtual/pkgconfig
-               >=dev-cpp/catch-2.2.0
-       )"
+DEPEND="test? ( >=dev-cpp/catch-2.3.0:0 )"
+BDEPEND="test? ( virtual/pkgconfig )"
 
 src_configure() {
        local mycmakeargs=(