dev-libs/libzip: Use fts-standalone on musl libc
authorA. Wilcox <AWilcox@Wilcox-Tech.com>
Sat, 25 Feb 2017 22:47:58 +0000 (16:47 -0600)
committerAndreas Sturmlechner <asturm@gentoo.org>
Fri, 17 Mar 2017 18:46:25 +0000 (19:46 +0100)
Gentoo-bug: 610936

Package-Manager: portage-2.3.1

dev-libs/libzip/files/libzip-1.1.3-fts.patch [new file with mode: 0644]
dev-libs/libzip/libzip-1.1.3-r1.ebuild [new file with mode: 0644]

diff --git a/dev-libs/libzip/files/libzip-1.1.3-fts.patch b/dev-libs/libzip/files/libzip-1.1.3-fts.patch
new file mode 100644 (file)
index 0000000..bd9bf23
--- /dev/null
@@ -0,0 +1,11 @@
+--- a/configure.ac     2016-05-28 10:35:31.000000000 +0100
++++ b/configure.ac     2017-02-25 23:34:22.309684397 +0100
+@@ -65,6 +65,8 @@
+     AC_DEFINE([HAVE___PROGNAME], [1], [Define if libc defines __progname])
+ fi
++AC_SEARCH_LIBS(fts_open, fts)
++
+ AC_CACHE_CHECK([whether we are building for a Win32 host], [ac_cv_win32_host],
+              AC_COMPILE_IFELSE([AC_LANG_SOURCE([[#ifdef _WIN32
+  choke me
diff --git a/dev-libs/libzip/libzip-1.1.3-r1.ebuild b/dev-libs/libzip/libzip-1.1.3-r1.ebuild
new file mode 100644 (file)
index 0000000..ecc3aa6
--- /dev/null
@@ -0,0 +1,35 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit autotools
+
+DESCRIPTION="Library for manipulating zip archives"
+HOMEPAGE="http://www.nih.at/libzip/"
+SRC_URI="http://www.nih.at/libzip/${P}.tar.xz"
+
+LICENSE="BSD"
+SLOT="0/4"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~x86-macos"
+IUSE="static-libs"
+
+RDEPEND="
+       sys-libs/zlib
+       elibc_musl? ( sys-libs/fts-standalone )
+"
+DEPEND="${RDEPEND}
+       app-arch/xz-utils
+"
+
+DOCS=( AUTHORS NEWS.md API-CHANGES THANKS )
+
+PATCHES=(
+       "${FILESDIR}/${PN}-1.1.3-headers.patch"
+       "${FILESDIR}/${PN}-1.1.3-fts.patch"
+)
+
+src_prepare() {
+       default
+       eautoreconf
+}