dev-python/imapclient: Remove redundant versions
authorMichał Górny <mgorny@gentoo.org>
Fri, 27 Mar 2020 15:28:59 +0000 (16:28 +0100)
committerMichał Górny <mgorny@gentoo.org>
Fri, 27 Mar 2020 15:28:59 +0000 (16:28 +0100)
Signed-off-by: Michał Górny <mgorny@gentoo.org>
dev-python/imapclient/Manifest
dev-python/imapclient/imapclient-0.13.ebuild [deleted file]

index a41559c4199ffb0142c42b3dcc7bdf259f4c38f1..f0c7713f86629b9d3437c87cf2c31dbdc24c97c0 100644 (file)
@@ -1,2 +1 @@
-DIST IMAPClient-0.13.tar.gz 102427 BLAKE2B f087b6e89c45810f359bed889345e6748ebf9ae90f6e3c4e013097a4e57d3f5ab0ec21906cfdccc03a344d92ccc442d58e38e687cd0761d86956047e89fedb03 SHA512 daebaf7f4180b6c9c6f4a486b313abfdd06f3ed8ece18a19bf46a50e56c2094e85de8a8e4efb8850566378eba016c10816611d03852caf637ee1d43f3c8a418f
 DIST imapclient-2.1.0.tar.gz 85925 BLAKE2B 9725be7988c4bec105fda73389241e39e6c006bccd8130125b280041d13becd6a71a1832763171daf25dfb4e7b4a7fc86c0a3afa93216c3dc4370b19348c0a5e SHA512 57e5824504f2667cf41ac4983130e16a5ea73ea37f29cdb16295eb725b56eda55db26a12e380acb579ef6b8540d38ae6badac5dd5b644d4419cbe9151f634e70
diff --git a/dev-python/imapclient/imapclient-0.13.ebuild b/dev-python/imapclient/imapclient-0.13.ebuild
deleted file mode 100644 (file)
index 2ca1822..0000000
+++ /dev/null
@@ -1,61 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-PYTHON_COMPAT=( python3_6 )
-
-inherit distutils-r1
-
-MY_PN="IMAPClient"
-MY_P="${MY_PN}-${PV}"
-
-DESCRIPTION="easy-to-use, pythonic, and complete IMAP client library"
-HOMEPAGE="http://imapclient.freshfoo.com/"
-SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="amd64 x86"
-IUSE="doc examples"
-
-RDEPEND="dev-python/six[${PYTHON_USEDEP}]"
-DEPEND="${RDEPEND}
-       dev-python/setuptools[${PYTHON_USEDEP}]"
-
-S=${WORKDIR}/${MY_P}
-
-python_prepare_all() {
-       # use system setuptools
-       sed -i '/use_setuptools/d' setup.py || die
-
-       # drop explicit mock version test dep
-       sed -i "/tests_require/s:'mock==.\+':'mock':" setup.py || die
-
-       # use system six library. patch proven less preferable to use of sed (< maintenance)
-       # but a copy of the working hunks from prior version works fine for now.
-       rm imapclient/six.py || die
-       epatch "${FILESDIR}"/0.12-tests.patch
-       sed -e 's:from .six:from six:g' \
-               -e 's:from . import six:import six:g' \
-               -i ${PN}/*.py || die
-
-       distutils-r1_python_prepare_all
-}
-
-python_test() {
-       "${PYTHON}" -m unittest discover || die "tests failed under ${EPYTHON}"
-}
-
-python_install() {
-       distutils-r1_python_install
-       # don't install examples and tests in module dir
-       rm -r "${D}"$(python_get_sitedir)/imapclient/{examples,test} || die
-}
-
-python_install_all() {
-#      local DOCS=( AUTHORS HACKING.rst NEWS.rst README.rst THANKS )
-       use doc && local HTML_DOCS=( doc/html/. )
-       distutils-r1_python_install_all
-       use examples && dodoc -r ${PN}/examples
-}