dev-ruby/bindata: add 2.4.4
authorHans de Graaff <graaff@gentoo.org>
Sat, 13 Jul 2019 06:04:01 +0000 (08:04 +0200)
committerHans de Graaff <graaff@gentoo.org>
Sat, 13 Jul 2019 06:13:30 +0000 (08:13 +0200)
Signed-off-by: Hans de Graaff <graaff@gentoo.org>
Package-Manager: Portage-2.3.66, Repoman-2.3.11

dev-ruby/bindata/Manifest
dev-ruby/bindata/bindata-2.4.4.ebuild [new file with mode: 0644]

index 871dbcc6c6752d5b5e4de1140bf86bbacaf524cd..fa5b7841c0d722e2bdc5b330bca7be5c61602eda 100644 (file)
@@ -1 +1,2 @@
 DIST bindata-2.4.1.gem 78848 BLAKE2B a497299aca02abe61c64fe946ef928ade75f58195bdafa1b5ac842c7dd272e0dd2e5da957b558492bb1dd1e47da7da1525c0d54f0e97e571c5db804e8b24ef7e SHA512 5bbbb38f7deb461c234801677baf30bf6d5300dd46f201ebcaef4cc4182354e1ed375fc1c341a13d6b3a1f579e25e4e53d8aeab0dd979a581131e2a984758243
+DIST bindata-2.4.4.gem 79872 BLAKE2B f22f8af6270cd7d790031d2ab53a80f2480ad687abd91803ce556495d1fe8f09e1c316ccfc5b35f2cf914e44e17121d3cc84baab19d51a5671b540429d6ff1f2 SHA512 c7af17ea3c7aec6360acfbe0b511700706daec24a4028c86eee441baaad39c259200ee66d33e6f73766c24ae9a8a3c00e5a0c140b4e12e0d526046cd81c6ce79
diff --git a/dev-ruby/bindata/bindata-2.4.4.ebuild b/dev-ruby/bindata/bindata-2.4.4.ebuild
new file mode 100644 (file)
index 0000000..e08c6e1
--- /dev/null
@@ -0,0 +1,24 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+USE_RUBY="ruby24 ruby25 ruby26"
+
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Parsing Binary Data in Ruby"
+HOMEPAGE="https://github.com/dmendel/bindata"
+
+LICENSE="BSD-2"
+SLOT="2"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE=""
+
+ruby_add_bdepend "test? ( dev-ruby/minitest:5 )"
+
+all_ruby_prepare() {
+       sed -i -e '/[Bb]undler/d' Rakefile || die
+       sed -i -e '/[Cc]overalls/d' test/test_helper.rb || die
+}