games-util/qjoypad: 4.3.1 version bump
authorAndreas Sturmlechner <asturm@gentoo.org>
Fri, 8 Nov 2019 21:08:45 +0000 (22:08 +0100)
committerAndreas Sturmlechner <asturm@gentoo.org>
Fri, 8 Nov 2019 21:09:56 +0000 (22:09 +0100)
Package-Manager: Portage-2.3.78, Repoman-2.3.17
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
games-util/qjoypad/Manifest
games-util/qjoypad/qjoypad-4.3.1.ebuild [new file with mode: 0644]

index 7598436048e0490562eff0554862315a13fced47..7fcec1eeef8962eda44794114761d96132d68091 100644 (file)
@@ -1 +1,2 @@
 DIST qjoypad-4.3.0.tar.gz 89134 BLAKE2B f035ac024176e352f2c0f88f0677cb4f30e643f64fd2f1214808c0273b0db8cf0a8b133e216b39fddf0ed9717c3e18955357e459ff30c494176ea7cf979b6943 SHA512 99febfc67fff149c476fffeed47eddd9e626e448afcb179eadc8dbe071da42ac692d153f3f43419c4280265527f5e84ede72cb4d59ba574819f7755e3d090e51
+DIST qjoypad-4.3.1.tar.gz 89122 BLAKE2B 6be6c855ee50f88e4afaa78e7f0d6ce7e529a0866142a59c8a1bf39315329c841b19670aad9ce0556e41b5d599ebb5e3adbc609a623f4908a6c7de2f1bfc64fc SHA512 f6c941c65c06266fb4bcc9e7d8a51c5c3a55f57ba8addfadf9d575f850cad428560c8b51e70faf9a40624088534f7e96d2b7f5747b48d05b25ffd31bad2e645a
diff --git a/games-util/qjoypad/qjoypad-4.3.1.ebuild b/games-util/qjoypad/qjoypad-4.3.1.ebuild
new file mode 100644 (file)
index 0000000..bbe3cb1
--- /dev/null
@@ -0,0 +1,44 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake-utils desktop
+
+DESCRIPTION="Translate gamepad/joystick input into key strokes/mouse actions in X"
+HOMEPAGE="https://github.com/panzi/qjoypad"
+SRC_URI="https://github.com/panzi/qjoypad/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+BDEPEND="
+       dev-qt/linguist-tools:5
+"
+RDEPEND="
+       dev-qt/qtcore:5
+       dev-qt/qtgui:5
+       dev-qt/qtwidgets:5
+       dev-qt/qtx11extras:5
+       virtual/libudev
+       x11-libs/libxcb
+       x11-libs/libXtst
+"
+DEPEND="${RDEPEND}
+       x11-base/xorg-proto
+"
+
+PATCHES=( "${FILESDIR}/${PN}-4.3.0-cmake.patch" )
+
+src_install() {
+       cmake-utils_src_install
+
+       local i
+       cd icons || die
+       for i in *.png; do
+               newicon ${i} ${i/gamepad/qjoypad}
+       done
+       make_desktop_entry ${PN} QJoypad ${PN}
+}