app-emacs/gnuserv: Fix backquotes patch.
authorUlrich Müller <ulm@gentoo.org>
Thu, 17 Oct 2019 13:39:42 +0000 (15:39 +0200)
committerUlrich Müller <ulm@gentoo.org>
Thu, 17 Oct 2019 13:49:11 +0000 (15:49 +0200)
This is mostly cosmetic, because the affected code in gnuserv-compat.el
won't be called in current Emacs versions. Therefore committing this
straight to stable.

Bump EAPI to 7.

Package-Manager: Portage-2.3.77, Repoman-2.3.17
Signed-off-by: Ulrich Müller <ulm@gentoo.org>
app-emacs/gnuserv/files/gnuserv-3.12.8-backquotes.patch
app-emacs/gnuserv/gnuserv-3.12.8-r5.ebuild [moved from app-emacs/gnuserv/gnuserv-3.12.8-r4.ebuild with 97% similarity]

index a16124821ddb117d98eea09ed211ef047e0a6273..fa31ac2e4017c6db921978fbd54ef917ee723fde 100644 (file)
@@ -7,10 +7,10 @@ Use new-style backquotes, to make it compile with Emacs 27.
        nil)
      (defmacro defcustom (var value doc &rest args)
 -      (` (defvar (, var) (, value) (, doc))))
-+      `(defvar (, var) (, value) (, doc)))
++      `(defvar ,var ,value ,doc))
      (defmacro defface (var value doc &rest args)
 -      (` (make-face (, var))))
-+      `(make-face (, var)))
++      `(make-face ,var))
      (defmacro define-widget (&rest args)
        nil)))
  
similarity index 97%
rename from app-emacs/gnuserv/gnuserv-3.12.8-r4.ebuild
rename to app-emacs/gnuserv/gnuserv-3.12.8-r5.ebuild
index b7852e0d2632a1ed2abe17148a6cec94aa71e122..94972c40cfd3127b7f6ae40f564918f69813421e 100644 (file)
@@ -1,7 +1,7 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
-EAPI=6
+EAPI=7
 
 inherit elisp multilib desktop xdg-utils