net-libs/gnutls: fix build failure
authorAlon Bar-Lev <alonbl@gentoo.org>
Mon, 14 Jan 2019 19:17:22 +0000 (21:17 +0200)
committerAlon Bar-Lev <alonbl@gentoo.org>
Mon, 14 Jan 2019 19:17:38 +0000 (21:17 +0200)
Closes: https://bugs.gentoo.org/show_bug.cgi?id=675424
Thanks: Toralf Förster
Signed-off-by: Alon Bar-Lev <alonbl@gentoo.org>
Package-Manager: Portage-2.3.51, Repoman-2.3.11

net-libs/gnutls/files/gnutls-3.6.5-build.patch [new file with mode: 0644]
net-libs/gnutls/gnutls-3.6.5.ebuild

diff --git a/net-libs/gnutls/files/gnutls-3.6.5-build.patch b/net-libs/gnutls/files/gnutls-3.6.5-build.patch
new file mode 100644 (file)
index 0000000..00c11da
--- /dev/null
@@ -0,0 +1,31 @@
+From b7fdb4125e4eebc5af2155b6d36cf17339a3abf5 Mon Sep 17 00:00:00 2001
+From: Dmitry Eremin-Solenikov <dbaryshkov@gmail.com>
+Date: Tue, 25 Dec 2018 14:44:11 +0300
+Subject: [PATCH] tests: cipher-openssl-compat: don't call
+ EVP_CIPHER_CTX_init()
+
+There is no need to call EVP_CIPHER_CTX_init() after
+EVP_CIPHER_CTX_new().
+
+Fixes #658
+
+Signed-off-by: Dmitry Eremin-Solenikov <dbaryshkov@gmail.com>
+---
+ tests/slow/cipher-openssl-compat.c | 1 -
+ 1 file changed, 1 deletion(-)
+
+diff --git a/tests/slow/cipher-openssl-compat.c b/tests/slow/cipher-openssl-compat.c
+index a4cb3522d..64adf25a4 100644
+--- a/tests/slow/cipher-openssl-compat.c
++++ b/tests/slow/cipher-openssl-compat.c
+@@ -106,7 +106,6 @@ static int cipher_test(const char *ocipher, gnutls_cipher_algorithm_t gcipher,
+ #if OPENSSL_VERSION_NUMBER >= 0x10100000L
+               if (gcipher == GNUTLS_CIPHER_AES_128_CCM
+                   || gcipher == GNUTLS_CIPHER_AES_256_CCM) {
+-                      assert(EVP_CIPHER_CTX_init(ctx)==1);
+                       assert(EVP_CipherInit_ex(ctx, evp_cipher, 0, 0, 0, 0) >
+                              0);
+-- 
+2.19.2
+
index 0e4f46b96b249a82da14a2d2112d22a8fd92fd7f..883584c16a7d75f7dfc0d6b1a433965388ddf3d4 100644 (file)
@@ -53,6 +53,10 @@ DOCS=(
 
 HTML_DOCS=()
 
+PATCHES=(
+       "${FILESDIR}/${P}-build.patch"
+)
+
 pkg_setup() {
        # bug#520818
        export TZ=UTC