dev-python/setuptools_scm: Version Bump
authorJustin Lecher <jlec@gentoo.org>
Sun, 16 Aug 2015 14:38:47 +0000 (16:38 +0200)
committerJustin Lecher <jlec@gentoo.org>
Sun, 16 Aug 2015 14:38:55 +0000 (16:38 +0200)
Package-Manager: portage-2.2.20.1
Signed-off-by: Justin Lecher <jlec@gentoo.org>
dev-python/setuptools_scm/Manifest
dev-python/setuptools_scm/setuptools_scm-1.7.0.ebuild [new file with mode: 0644]

index c40609edd40aaa366af867c7197e6210aca7686e..1ddc05afdbc9265aad5d3482d7a056674c1f1ea9 100644 (file)
@@ -1,2 +1,3 @@
 DIST setuptools_scm-1.5.4.tar.gz 15647 SHA256 756fb77b82c5e22818683b838c978537f4894f468ea074f0e8a99d8aaf689022 SHA512 c1e7c6b510761a3dcf3ebfed4988db924f9203c9f919891c94623f07935b101690ff2671ff3e153906a89f05d4002154e671196ba711597d4e3e7c8d0602289e WHIRLPOOL a02209c4c3c8ef6de63463ec163c018906de88abc5e1786b9506c4fc71dfdbe4b576cce94d19d653f1eb6f21f86292a645823b009107a07801056fb1f90a79b0
 DIST setuptools_scm-1.5.5.tar.gz 17442 SHA256 63f56843b9cc18743c843e43d54fd78ab091cb82d01f5acb64655743e8002134 SHA512 39516db6164dc0d6179922fd79b012950c0684c8f6d4dbf71c2fcae661d1a54ef745c48c8d521ed3906c4f74d91b79fe4a94b5e27ab6a84701964494057c2494 WHIRLPOOL 929e5c38aaef9c247a451382842bf16faf44528858981af7c29133d5b3f4693414b85d076ade33c033dfbadb5803bf1b95fa5d8fa942725af2c3b01534d72a72
+DIST setuptools_scm-1.7.0.tar.gz 18754 SHA256 f2f69c782b4f549003edf5b75b356b37f40a4e880b615996c5d9c117913d6f9c SHA512 58fb39dff1fe7731d8f8fb9a383d4df41ad9271590c13e64d75bf9e5d390f553414a47b3223747e2c6d9407af44eff84365bce162251f0c0324bfb216f44c1a8 WHIRLPOOL 3555650b8d40df3b43e61240c0c7c09b46d7fb735c9cc64cf50da7fc3b9c6c66f237b69f1eb7bc66bfc4592daed824f1b25e2db507245a946ea6dafd028ec0fe
diff --git a/dev-python/setuptools_scm/setuptools_scm-1.7.0.ebuild b/dev-python/setuptools_scm/setuptools_scm-1.7.0.ebuild
new file mode 100644 (file)
index 0000000..0d9a43c
--- /dev/null
@@ -0,0 +1,25 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 python3_{3,4} pypy pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="package to manage versions by scm tags via setuptools"
+HOMEPAGE="https://github.com/pypa/setuptools_scm"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE="test"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+       test? ( dev-python/pytest[${PYTHON_USEDEP}] )"
+
+python_test() {
+       py.test || die "tests failed under ${EPYTHON}"
+}