net-analyzer/zabbix: Bump to 2.2.13 for #574858
authorPatrick Lauer <patrick@gentoo.org>
Sun, 12 Jun 2016 18:18:00 +0000 (20:18 +0200)
committerPatrick Lauer <patrick@gentoo.org>
Sun, 12 Jun 2016 18:32:37 +0000 (20:32 +0200)
Package-Manager: portage-2.3.0_rc1

net-analyzer/zabbix/Manifest
net-analyzer/zabbix/zabbix-2.2.13.ebuild [new file with mode: 0644]

index 731627a7a76aceb8138d2ae0d838d45eb4a31a69..2796227472188db53b8098533b4eb7cb4a0180a4 100644 (file)
@@ -1,4 +1,5 @@
 DIST zabbix-2.2.11.tar.gz 15147477 SHA256 9ad7bd71985dc316ee2a614bba2b1dd108d2a930c0a5cc5a8f75eb45a7a7e1ba SHA512 7447d3207bf67fdda67c1e56636ae114df7776a2ba4df4f9f260eef6a65e37d770ed73d6edd6438a9a783da1fc9bfede2d98acdc51fa6c7a130565efe8ae5b2d WHIRLPOOL e2b1f2ed019651d127a40f656117c9acccc8dcb1b9a8c0f9a773368de6d430d0716b5c50c42358992c9c2567c59cf0ec02bffea123ee4ac873be262aef0f2f6f
+DIST zabbix-2.2.13.tar.gz 15478414 SHA256 0a272ad4de22368f9a77864e0a9fa566f76c872814e81845e16d4d24cd5452f4 SHA512 dc9a20069376de2221577f2833f003dd243f09e583a673038787dab413c0affa1a85abdef567d7ea015c2ff88d97481570cb3732f5d72f45d4e7f509654f93eb WHIRLPOOL 3f7385068fa65b693bfb280686242512dcc1a9a4d3df9af56319c17f1075c9ebf4dfa54aab18b6b5e645055fd8efcfd847fca3e0fe2e6041acc5f1342d0538b0
 DIST zabbix-2.2.5.tar.gz 14960556 SHA256 1e33f54d4accc5b6a0dccf4a308d27dc82de245567dffef823f9add9fa7d81b5 SHA512 0e229a2502f1332775db2107556b5e62267bcdf05dc483957960f563877ed970aef7ed465123576849413305e54309d83eeb75dd1f522c93cf09cd4b75265514 WHIRLPOOL 0a6b81f4e23ad8c8247b5356aa31bc4dfbd364642a647b9dff3216a0141cd2287b75731f396d26083aa412669a7efdb6f24fcb8592b4773c4a21d02b2f369681
 DIST zabbix-2.2.9.tar.gz 15032149 SHA256 7c8c319b34beb978e4b7be8c93e084485f93fe028dd9dbc6b674a7498d324439 SHA512 8400f875546140a7393ac6598a02e95645ac63ece1d958e7752737d0c0fff25e70923f2dd1ea29a9e73640b159da8a5286d9b1c31fbb3f090acbd07606c6113d WHIRLPOOL cb68a2c1467c83e8c2e2662af3995d7d90a00408009df2d9fe0b0d0d81191521b3f6e1624240150f68419252324e0d6e5653a3f19ed3b88adeb2719277172fb6
 DIST zabbix-2.4.5.tar.gz 14851092 SHA256 4e2cf1e4893a45d83379a05e2debabddf16beab324c93e84adc0bb57716fb957 SHA512 bdcba684b3d1cdb9eb5e1f9b370ef450201de8dbd9fe1619ef2b2437de6c34762dc041fa873976c4af0a2af229eec450aa58b1663feb75b6345d303484d35ead WHIRLPOOL 775e98b85152268b19cde553ff8bc7e86c0f6c5b873e85a0faca3edb5b51fe7d02267e52b3dccb0f08847bf11c6d0ba6b2d9f1e6bd472c882a2fac4326a83e10
diff --git a/net-analyzer/zabbix/zabbix-2.2.13.ebuild b/net-analyzer/zabbix/zabbix-2.2.13.ebuild
new file mode 100644 (file)
index 0000000..0bbbf88
--- /dev/null
@@ -0,0 +1,342 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="6"
+
+# needed to make webapp-config dep optional
+WEBAPP_OPTIONAL="yes"
+inherit flag-o-matic webapp java-pkg-opt-2 user systemd toolchain-funcs
+
+DESCRIPTION="ZABBIX is software for monitoring of your applications, network and servers"
+HOMEPAGE="http://www.zabbix.com/"
+MY_P=${P/_/}
+MY_PV=${PV/_/}
+SRC_URI="http://prdownloads.sourceforge.net/zabbix/${MY_P}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+WEBAPP_MANUAL_SLOT="yes"
+KEYWORDS="~amd64 ~x86"
+IUSE="+agent java curl frontend ipv6 xmpp ldap libxml2 mysql openipmi oracle postgres proxy server ssh snmp sqlite odbc static"
+REQUIRED_USE="|| ( agent frontend proxy server )
+       proxy? ( ^^ ( mysql oracle postgres sqlite odbc ) )
+       server? ( ^^ ( mysql oracle postgres sqlite odbc ) )
+       static? ( !oracle !snmp )"
+
+COMMON_DEPEND="snmp? ( net-analyzer/net-snmp )
+       ldap? (
+               net-nds/openldap
+               =dev-libs/cyrus-sasl-2*
+               net-libs/gnutls
+       )
+       mysql? ( >=virtual/mysql-5.0.3 )
+       sqlite? ( >=dev-db/sqlite-3.3.5 )
+       postgres? ( dev-db/postgresql:* )
+       oracle? ( >=dev-db/oracle-instantclient-basic-10.0.0.0 )
+       xmpp? ( dev-libs/iksemel )
+       libxml2? ( dev-libs/libxml2 )
+       curl? ( net-misc/curl )
+       openipmi? ( sys-libs/openipmi )
+       ssh? ( net-libs/libssh2 )
+       java? ( virtual/jdk:* )
+       odbc? ( dev-db/unixODBC )"
+
+RDEPEND="${COMMON_DEPEND}
+       proxy? ( net-analyzer/fping )
+       server? ( net-analyzer/fping
+               app-admin/webapp-config )
+       java?   (
+               >=virtual/jre-1.4
+               dev-java/slf4j-api
+       )
+       frontend? (
+               >=dev-lang/php-5.3.0[bcmath,ctype,sockets,gd,truetype,xml,session,xmlreader,xmlwriter,nls,sysvipc,unicode]
+               || ( dev-lang/php[apache2] dev-lang/php[cgi] dev-lang/php[fpm] )
+               mysql? ( dev-lang/php[mysqli] )
+               odbc? ( dev-lang/php[odbc] )
+               oracle? ( dev-lang/php[oci8-instant-client] )
+               postgres? ( dev-lang/php[postgres] )
+               sqlite? ( dev-lang/php[sqlite] )
+               media-libs/gd[png]
+               app-admin/webapp-config )"
+DEPEND="${COMMON_DEPEND}
+       static? (
+               ldap? (
+                       net-nds/openldap[static-libs]
+                       =dev-libs/cyrus-sasl-2*[static-libs]
+                       net-libs/gnutls[static-libs]
+               )
+       mysql? ( >=virtual/mysql-5.0.3[static-libs] )
+       sqlite? ( >=dev-db/sqlite-3.3.5[static-libs] )
+       postgres? ( dev-db/postgresql:*[static-libs] )
+       libxml2? ( dev-libs/libxml2[static-libs] )
+       curl? ( net-misc/curl[static-libs] )
+       ssh? ( net-libs/libssh2[static-libs] )
+       odbc? ( dev-db/unixODBC[static-libs] )
+       )
+       virtual/pkgconfig"
+
+S=${WORKDIR}/${MY_P}
+
+ZABBIXJAVA_BASE="opt/zabbix_java"
+
+pkg_setup() {
+       if use oracle; then
+               if [ -z "${ORACLE_HOME}" ]; then
+                       eerror
+                       eerror "The environment variable ORACLE_HOME must be set"
+                       eerror "and point to the correct location."
+                       eerror "It looks like you don't have Oracle installed."
+                       eerror
+                       die "Environment variable ORACLE_HOME is not set"
+               fi
+               if has_version 'dev-db/oracle-instantclient-basic'; then
+                       ewarn
+                       ewarn "Please ensure you have a full install of the Oracle client."
+                       ewarn "dev-db/oracle-instantclient* is NOT sufficient."
+                       ewarn
+               fi
+       fi
+
+       if use frontend; then
+               webapp_pkg_setup
+       fi
+
+       enewgroup zabbix
+       enewuser zabbix -1 -1 /var/lib/zabbix/home zabbix
+}
+
+java_prepare() {
+       cd "${S}/src/zabbix_java/lib"
+       rm -v *.jar || die
+
+       java-pkg_jar-from slf4j-api
+}
+
+src_prepare() {
+       default
+}
+
+src_configure() {
+       econf \
+               $(use_enable server) \
+               $(use_enable proxy) \
+               $(use_enable agent) \
+               $(use_enable ipv6) \
+               $(use_enable static) \
+               $(use_enable java) \
+               $(use_with ldap) \
+               $(use_with snmp net-snmp) \
+               $(use_with mysql) \
+               $(use_with postgres postgresql) \
+               $(use_with oracle) \
+               $(use_with sqlite sqlite3) \
+               $(use_with xmpp jabber) \
+               $(use_with curl libcurl) \
+               $(use_with openipmi openipmi) \
+               $(use_with ssh ssh2) \
+               $(use_with libxml2) \
+               $(use_with odbc unixodbc) \
+               || die "econf failed"
+}
+
+src_compile() {
+       if [ -f Makefile ] || [ -f GNUmakefile ] || [ -f makefile ]; then
+               emake AR="$(tc-getAR)" RANLIB="$(tc-getRANLIB)" || die "emake failed"
+       fi
+}
+
+src_install() {
+       dodir \
+               /etc/zabbix \
+               /var/lib/zabbix \
+               /var/lib/zabbix/home \
+               /var/lib/zabbix/scripts \
+               /var/lib/zabbix/alertscripts \
+               /var/lib/zabbix/externalscripts \
+               /var/log/zabbix
+
+       keepdir \
+               /etc/zabbix \
+               /var/lib/zabbix \
+               /var/lib/zabbix/home \
+               /var/lib/zabbix/scripts \
+               /var/lib/zabbix/alertscripts \
+               /var/lib/zabbix/externalscripts \
+               /var/log/zabbix
+
+       if use server; then
+               insinto /etc/zabbix
+               doins "${FILESDIR}/2.2"/zabbix_server.conf
+               doinitd "${FILESDIR}/2.2"/init.d/zabbix-server
+               dosbin src/zabbix_server/zabbix_server
+               fowners zabbix:zabbix /etc/zabbix/zabbix_server.conf
+               fperms 0640 /etc/zabbix/zabbix_server.conf
+               dodir /usr/share/zabbix
+               /bin/cp -R "${S}/database/" "${D}"/usr/share/zabbix/
+               systemd_dounit "${FILESDIR}/zabbix-server.service"
+               systemd_newtmpfilesd "${FILESDIR}/zabbix-server.tmpfiles" zabbix-server.conf
+       fi
+
+       if use proxy; then
+               doinitd \
+                       "${FILESDIR}/2.2"/init.d/zabbix-proxy
+               dosbin \
+                       src/zabbix_proxy/zabbix_proxy
+               insinto /etc/zabbix
+               doins \
+                       "${FILESDIR}/2.2"/zabbix_proxy.conf
+               dodir /usr/share/zabbix
+               /bin/cp -R "${S}/database/" "${D}"/usr/share/zabbix/
+               systemd_dounit "${FILESDIR}/zabbix-proxy.service"
+               systemd_newtmpfilesd "${FILESDIR}/zabbix-proxy.tmpfiles" zabbix-proxy.conf
+       fi
+
+       if use agent; then
+               insinto /etc/zabbix
+               doins \
+                       "${FILESDIR}/2.2"/zabbix_agent.conf \
+                       "${FILESDIR}/2.2"/zabbix_agentd.conf
+               doinitd "${FILESDIR}/2.2"/init.d/zabbix-agentd
+               dosbin \
+                       src/zabbix_agent/zabbix_agent \
+                       src/zabbix_agent/zabbix_agentd
+               dobin \
+                       src/zabbix_sender/zabbix_sender \
+                       src/zabbix_get/zabbix_get
+               fowners zabbix:zabbix \
+                       /etc/zabbix/zabbix_agent.conf \
+                       /etc/zabbix/zabbix_agentd.conf
+               fperms 0640 \
+                       /etc/zabbix/zabbix_agent.conf \
+                       /etc/zabbix/zabbix_agentd.conf
+               systemd_dounit "${FILESDIR}/zabbix-agentd.service"
+               systemd_newtmpfilesd "${FILESDIR}/zabbix-agentd.tmpfiles" zabbix-agentd.conf
+       fi
+
+       fowners zabbix:zabbix \
+               /etc/zabbix \
+               /var/lib/zabbix \
+               /var/lib/zabbix/home \
+               /var/lib/zabbix/scripts \
+               /var/lib/zabbix/alertscripts \
+               /var/lib/zabbix/externalscripts \
+               /var/log/zabbix
+       fperms 0750 \
+               /etc/zabbix \
+               /var/lib/zabbix \
+               /var/lib/zabbix/home \
+               /var/lib/zabbix/scripts \
+               /var/lib/zabbix/alertscripts \
+               /var/lib/zabbix/externalscripts \
+               /var/log/zabbix
+
+       dodoc README INSTALL NEWS ChangeLog \
+               conf/zabbix_agent.conf \
+               conf/zabbix_agentd.conf \
+               conf/zabbix_proxy.conf \
+               conf/zabbix_agentd/userparameter_examples.conf \
+               conf/zabbix_agentd/userparameter_mysql.conf \
+               conf/zabbix_server.conf
+
+       if use frontend; then
+               webapp_src_preinst
+               cp -R frontends/php/* "${D}/${MY_HTDOCSDIR}"
+               webapp_configfile \
+                       "${MY_HTDOCSDIR}"/include/db.inc.php \
+                       "${MY_HTDOCSDIR}"/include/config.inc.php
+               webapp_src_install
+       fi
+
+       if use java; then
+          dodir \
+               /${ZABBIXJAVA_BASE} \
+               /${ZABBIXJAVA_BASE}/bin \
+               /${ZABBIXJAVA_BASE}/lib
+          keepdir /${ZABBIXJAVA_BASE}
+          exeinto /${ZABBIXJAVA_BASE}/bin
+          doexe src/zabbix_java/bin/zabbix-java-gateway-${MY_PV}.jar
+          exeinto /${ZABBIXJAVA_BASE}/lib
+          doexe \
+               src/zabbix_java/lib/logback-classic-0.9.27.jar \
+               src/zabbix_java/lib/logback-console.xml \
+               src/zabbix_java/lib/logback-core-0.9.27.jar \
+               src/zabbix_java/lib/logback.xml \
+               src/zabbix_java/lib/android-json-4.3_r3.1.jar \
+               src/zabbix_java/lib/slf4j-api-1.6.1.jar
+          exeinto /${ZABBIXJAVA_BASE}/
+          doexe \
+               src/zabbix_java/settings.sh \
+               src/zabbix_java/startup.sh \
+               src/zabbix_java/shutdown.sh
+          fowners -R zabbix:zabbix /${ZABBIXJAVA_BASE}
+       fi
+}
+
+pkg_postinst() {
+       if use server || use proxy ; then
+               elog
+               elog "You may need to configure your database for Zabbix,"
+               elog "if you have not already done so. "
+               elog
+
+               zabbix_homedir=$(egethome zabbix)
+               if [ -n "${zabbix_homedir}" ] && \
+                  [ "${zabbix_homedir}" != "/var/lib/zabbix/home" ]; then
+                       ewarn
+                       ewarn "The user 'zabbix' should have his homedir changed"
+                       ewarn "to /var/lib/zabbix/home if you want to use"
+                       ewarn "custom alert scripts."
+                       ewarn
+                       ewarn "A real homedir might be needed for configfiles"
+                       ewarn "for custom alert scripts (e.g. ~/.sendxmpprc when"
+                       ewarn "using sendxmpp for Jabber alerts)."
+                       ewarn
+                       ewarn "To change the homedir use:"
+                       ewarn "  usermod -d /var/lib/zabbix/home zabbix"
+                       ewarn
+               fi
+       fi
+
+       if use server; then
+               elog
+               elog "For distributed monitoring you have to run:"
+               elog
+               elog "zabbix_server -n <nodeid>"
+               elog
+               elog "This will convert database data for use with Node ID"
+               elog "and also adds a local node."
+               elog
+       fi
+
+       elog "--"
+       elog
+       elog "You may need to add these lines to /etc/services:"
+       elog
+       elog "zabbix-agent     10050/tcp Zabbix Agent"
+       elog "zabbix-agent     10050/udp Zabbix Agent"
+       elog "zabbix-trapper   10051/tcp Zabbix Trapper"
+       elog "zabbix-trapper   10051/udp Zabbix Trapper"
+       elog
+
+       if use server || use proxy ; then
+               # check for fping
+               fping_perms=$(stat -c %a /usr/sbin/fping 2>/dev/null)
+               case "${fping_perms}" in
+                       4[157][157][157])
+                               ;;
+                       *)
+                               ewarn
+                               ewarn "If you want to use the checks 'icmpping' and 'icmppingsec',"
+                               ewarn "you have to make /usr/sbin/fping setuid root and executable"
+                               ewarn "by everyone. Run the following command to fix it:"
+                               ewarn
+                               ewarn "  chmod u=rwsx,g=rx,o=rx /usr/sbin/fping"
+                               ewarn
+                               ewarn "Please be aware that this might impose a security risk,"
+                               ewarn "depending on the code quality of fping."
+                               ewarn
+                               ;;
+               esac
+       fi
+}