New eselect module for switching LAPACK implementations.
authorDonnie Berkholz <dberkholz@gentoo.org>
Sun, 18 Jun 2006 21:06:09 +0000 (21:06 +0000)
committerDonnie Berkholz <dberkholz@gentoo.org>
Sun, 18 Jun 2006 21:06:09 +0000 (21:06 +0000)
Package-Manager: portage-2.1.1_pre1-r1

app-admin/eselect-lapack/ChangeLog [new file with mode: 0644]
app-admin/eselect-lapack/eselect-lapack-0.1.ebuild [new file with mode: 0644]
app-admin/eselect-lapack/files/digest-eselect-lapack-0.1 [new file with mode: 0644]
app-admin/eselect-lapack/files/lapack.eselect-0.1 [new file with mode: 0644]
app-admin/eselect-lapack/files/lapack.eselect.5 [new file with mode: 0644]
app-admin/eselect-lapack/metadata.xml [new file with mode: 0644]

diff --git a/app-admin/eselect-lapack/ChangeLog b/app-admin/eselect-lapack/ChangeLog
new file mode 100644 (file)
index 0000000..eb2c52b
--- /dev/null
@@ -0,0 +1,11 @@
+# ChangeLog for app-admin/eselect-lapack
+# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-admin/eselect-lapack/ChangeLog,v 1.1 2006/06/18 21:06:09 spyderous Exp $
+
+*eselect-lapack-0.1 (18 Jun 2006)
+
+  18 Jun 2006; Donnie Berkholz <spyderous@gentoo.org>;
+  +files/lapack.eselect-0.1, +files/lapack.eselect.5, +metadata.xml,
+  +eselect-lapack-0.1.ebuild:
+  New eselect module for switching LAPACK implementations.
+
diff --git a/app-admin/eselect-lapack/eselect-lapack-0.1.ebuild b/app-admin/eselect-lapack/eselect-lapack-0.1.ebuild
new file mode 100644 (file)
index 0000000..1ecda64
--- /dev/null
@@ -0,0 +1,28 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-admin/eselect-lapack/eselect-lapack-0.1.ebuild,v 1.1 2006/06/18 21:06:09 spyderous Exp $
+
+inherit eutils
+
+DESCRIPTION="LAPACK module for eselect"
+HOMEPAGE="http://www.gentoo.org/proj/en/eselect/"
+SRC_URI=""
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~ppc ~x86"
+
+IUSE=""
+# Need skel.bash lib
+#RDEPEND=">=app-admin/eselect-1.0.3"
+RDEPEND="app-admin/eselect"
+DEPEND="${RDEPEND}"
+
+src_install() {
+       local MODULEDIR="/usr/share/eselect/modules"
+       local MODULE="lapack"
+       dodir ${MODULEDIR}
+       insinto ${MODULEDIR}
+       newins ${FILESDIR}/${MODULE}.eselect-${PVR} ${MODULE}.eselect
+       doman ${FILESDIR}/lapack.eselect.5
+}
diff --git a/app-admin/eselect-lapack/files/digest-eselect-lapack-0.1 b/app-admin/eselect-lapack/files/digest-eselect-lapack-0.1
new file mode 100644 (file)
index 0000000..8b13789
--- /dev/null
@@ -0,0 +1 @@
+
diff --git a/app-admin/eselect-lapack/files/lapack.eselect-0.1 b/app-admin/eselect-lapack/files/lapack.eselect-0.1
new file mode 100644 (file)
index 0000000..3b6db28
--- /dev/null
@@ -0,0 +1,15 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id: lapack.eselect-0.1,v 1.1 2006/06/18 21:06:09 spyderous Exp $
+
+inherit skel
+
+MODULE="LAPACK"
+IFACE="lapack"
+
+DESCRIPTION="Manage installed $MODULE implementations"
+MAINTAINER="spyderous@gentoo.org"
+SVN_DATE='$Date: 2006/06/18 21:06:09 $'
+VERSION=$(svn_date_to_version "${SVN_DATE}" )
+
+# vim: set ft=eselect :
diff --git a/app-admin/eselect-lapack/files/lapack.eselect.5 b/app-admin/eselect-lapack/files/lapack.eselect.5
new file mode 100644 (file)
index 0000000..5614794
--- /dev/null
@@ -0,0 +1,67 @@
+.TH "ESELECT" "5" "June 2006" "Gentoo Linux" "eselect"
+.SH "NAME"
+lapack.eselect \- The LAPACK management module for Gentoo's eselect
+.SH "SYNOPSIS"
+\fBeselect lapack\fR [\fBhelp\fR|\fBusage\fR]
+.br 
+\fBeselect lapack\fR \fBlist\fR [\fIoptions\fR]
+.br 
+\fBeselect lapack\fR \fBadd\fR
+.br 
+\fBeselect lapack\fR \fBset\fR \fIimplementation\fR [\fIoptions\fR]
+.br 
+\fBeselect lapack\fR \fBshow\fR [\fIoptions\fR]
+
+.SH "DESCRIPTION"
+\fBeselect\fR is Gentoo's configuration and management tool. It features
+modules that care for the individual administrative tasks.
+.SH "ACTION: LIST"
+\fBeselect lapack list\fR [\fIoptions\fR]
+.br 
+Displays an ordered list of installed LAPACK implementations. It distinguishes between versions with different
+Application Binary Interfaces (e.g. x86/AMD64). Furthermore, it also distinguishes
+between interfaces to high-level programming languages. Each line holds
+a number and the implementation's name. An asterisk next to one of the list
+elements denotes an active implementation.
+
+phi / # eselect lapack list
+.br 
+Installed LAPACK for libdir \fBlib\fR
+.br 
+  [1]   atlas *
+  [2]   reference
+
+Possible \fIoptions\fR to the \fBlist\fR action are restrictions to
+handle only certain ABI\-specific library directories. For example,
+\fBeselect lapack list lib64\fR
+
+lists only LAPACK implementations found in \fB/usr/lib64\fR.
+
+.SH "ACTION: SHOW"
+\fBeselect lapack show\fR [\fIoptions\fR]
+.br 
+Shows your system's currently active LAPACK implementations.
+
+phi / # eselect lapack show
+.br 
+lib: atlas
+.br
+lib64: reference
+
+The same \fIoptions\fR that apply to the \fBlist\fR action can be used
+with the \fBshow\fR action to restrict it to given ABIs.
+.SH "ACTION: SET"
+\fBeselect lapack set\fR \fIimplementation\fR [\fIoptions\fR]
+.br 
+Sets your system's currently active LAPACK implementations to \fIimplementation\fR. 
+The same \fIoptions\fR that apply to the \fBlist\fR action can be used
+with the \fBset\fR action to restrict it to given ABIs.
+
+phi / # eselect lapack set atlas
+.SH "AUTHOR"
+Danny van Dyk <kugelfang@gentoo.org>
+.br
+Donnie Berkholz <spyderous@gentoo.org>
+.SH "REVISION"
+$Id: lapack.eselect.5,v 1.1 2006/06/18 21:06:09 spyderous Exp $
diff --git a/app-admin/eselect-lapack/metadata.xml b/app-admin/eselect-lapack/metadata.xml
new file mode 100644 (file)
index 0000000..211b8bd
--- /dev/null
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>sci</herd>
+<maintainer>
+<email>spyderous@gentoo.org</email>
+<name>Donnie Berkholz</name>
+</maintainer>
+</pkgmetadata>