mail-client/alpine: fix compilation with gcc-10
authorRobert Siebeck <gentoo.2019@r123.de>
Mon, 11 May 2020 17:09:43 +0000 (19:09 +0200)
committerAaron Bauman <bman@gentoo.org>
Thu, 14 May 2020 22:19:21 +0000 (18:19 -0400)
Closes: https://bugs.gentoo.org/721618
Signed-off-by: Robert Siebeck <gentoo.2019@r123.de>
Closes: https://github.com/gentoo/gentoo/pull/15753
Signed-off-by: Aaron Bauman <bman@gentoo.org>
mail-client/alpine/alpine-2.22-r1.ebuild
mail-client/alpine/files/alpine-2.22-fno-common.patch [new file with mode: 0644]

index 2d77170f9850e85b686a9f4cc2cec6256e4c28cb..95787b03996c412f4d5dcb85451a18d2976835ef 100644 (file)
@@ -31,6 +31,7 @@ RDEPEND="${DEPEND}
 
 PATCHES=(
        "${FILESDIR}/${P}-cc.patch"
+       "${FILESDIR}/${P}-fno-common.patch"
 )
 
 src_prepare() {
diff --git a/mail-client/alpine/files/alpine-2.22-fno-common.patch b/mail-client/alpine/files/alpine-2.22-fno-common.patch
new file mode 100644 (file)
index 0000000..0ef289e
--- /dev/null
@@ -0,0 +1,19 @@
+--- a/pith/smkeys.c
++++ b/pith/smkeys.c
+@@ -34,6 +34,7 @@ static char rcsid[] = "$Id: smkeys.c 1266 2009-07-14 18:39:12Z hubert@u.washingt
+ #include "../pith/util.h"
+ #include "../pith/mailindx.h"
+ #include "../pith/readfile.h"
++#include "../pith/options.h"
+ #include "smkeys.h"
+ #ifdef APPLEKEYCHAIN
+@@ -50,8 +51,6 @@ static int       mem_add_extra_cacerts(char *contents, X509_LOOKUP *lookup);
+ int            compare_certs_by_name(const void *data1, const void *data2);
+ int            password_policy_check(char *);
+-int  (*pith_smime_enter_password)(char *, char *, size_t);
+-
+ /* test if password passes a predetermined policy.
+  * return value: 0 - does not pass; 1 - it passes 
+  */