app-text/xmldiff: tidy ebuild
authorJoonas Niilola <juippis@gentoo.org>
Sun, 5 Apr 2020 07:13:03 +0000 (10:13 +0300)
committerJoonas Niilola <juippis@gentoo.org>
Sun, 5 Apr 2020 07:17:56 +0000 (10:17 +0300)
Signed-off-by: Joonas Niilola <juippis@gentoo.org>
app-text/xmldiff/xmldiff-2.3.ebuild

index 71535547856310ec397a5c1436c17b1fb7320d51..2b4aa9c673442df2595a34c9fd91aa46f79fa88e 100644 (file)
@@ -8,8 +8,6 @@ PYTHON_COMPAT=( python3_{6,7} )
 DISTUTILS_USE_SETUPTOOLS="rdepend"
 inherit distutils-r1
 
-distutils_enable_tests unittest
-
 DESCRIPTION="A tool that figures out the differences between two similar XML files"
 HOMEPAGE="https://github.com/Shoobx/xmldiff"
 SRC_URI="https://github.com/Shoobx/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
@@ -17,10 +15,10 @@ SRC_URI="https://github.com/Shoobx/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
 LICENSE="MIT"
 SLOT="0"
 KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~sparc ~x86 ~x86-linux"
-IUSE=""
 
-RDEPEND="dev-python/setuptools
-       dev-python/lxml
-       dev-python/six"
+RDEPEND="dev-python/lxml[${PYTHON_USEDEP}]
+       dev-python/six[${PYTHON_USEDEP}]"
+
+distutils_enable_tests unittest
 
 DOCS=( CHANGES.rst README.rst )