profiles/arch/hppa: Mask USE=libsecret for dev-vcs/git.
authorJeroen Roovers <jer@gentoo.org>
Sun, 26 Feb 2017 11:58:13 +0000 (12:58 +0100)
committerJeroen Roovers <jer@gentoo.org>
Sun, 26 Feb 2017 11:58:36 +0000 (12:58 +0100)
net-misc/apt-cacher-ng/Manifest
net-misc/apt-cacher-ng/apt-cacher-ng-1.ebuild [deleted file]
profiles/arch/hppa/package.use.mask

index a4655819a357f5c5a1c39389645a80f9d8bc3dc8..dbea216f78b8adaee5047fdc1c2855dde82447bc 100644 (file)
@@ -1,2 +1 @@
-DIST apt-cacher-ng_1.orig.tar.xz 312120 SHA256 f8e6fee778b2e2fa37c99b1a398d1d7fe352a719e30f4c4a21323ce0558fa9d9 SHA512 56de49df851acde32624a3a7ade9adc9d0a7a7ed4995f50992fcedddf2e6a04bc6503869f104986aeb8dadc851cc0dd7c3c57d04e29c2300fc44b0bf111f4a58 WHIRLPOOL 3a82eac4bbda2cbc205ee7b7558c1c196fbbde9d4c156fed62fe3335654cc140c7c294b642c22470b9e19e118efd1e4a7d9038d9f42e760a1f96c4974d7371a3
 DIST apt-cacher-ng_2.orig.tar.xz 313360 SHA256 eeab24d96ceb544b4c57dd1ac749af9e2ad92dbf864056688bd9c62d02186c2e SHA512 ad409b4ffc39af4037be003c8f73048e191bfed36e3d63dcb061fdc456b3d18c3e0ec82d8af5f9272c3e33564ec3060a567733e123c892841cbb8bc7d557fd1b WHIRLPOOL 44940dd3b494d395dae18c93d4553775d9df487c7c5b4c2f8a643df91a4e30fe5d1724f9d54b3ff74f189ea877d35a7974076fd0260ce0f5ebe6291572e93805
diff --git a/net-misc/apt-cacher-ng/apt-cacher-ng-1.ebuild b/net-misc/apt-cacher-ng/apt-cacher-ng-1.ebuild
deleted file mode 100644 (file)
index 369eb9b..0000000
+++ /dev/null
@@ -1,118 +0,0 @@
-# Copyright 1999-2016 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=5
-inherit cmake-utils eutils toolchain-funcs user
-
-DESCRIPTION="Yet another caching HTTP proxy for Debian/Ubuntu software packages"
-HOMEPAGE="
-       http://www.unix-ag.uni-kl.de/~bloch/acng/
-       http://packages.qa.debian.org/a/apt-cacher-ng.html
-"
-LICENSE="BSD-4 ZLIB public-domain"
-SLOT="0"
-SRC_URI="mirror://debian/pool/main/a/${PN}/${PN}_${PV}.orig.tar.xz"
-
-KEYWORDS="~amd64 ~x86"
-IUSE="doc fuse systemd tcpd"
-
-COMMON_DEPEND="
-       app-arch/bzip2
-       app-arch/xz-utils
-       dev-libs/openssl:*
-       sys-libs/zlib
-       systemd? (
-               sys-apps/systemd
-       )
-"
-DEPEND="
-       ${COMMON_DEPEND}
-       dev-util/cmake
-       >sys-devel/gcc-4.8
-       virtual/pkgconfig
-"
-RDEPEND="
-       ${COMMON_DEPEND}
-       dev-lang/perl
-       fuse? ( sys-fs/fuse )
-       tcpd? ( sys-apps/tcp-wrappers )
-"
-
-S=${WORKDIR}/${P/_}
-
-pkg_pretend() {
-       if [[ $(gcc-major-version) -lt 4 ]]; then
-               die "GCC 4.8 or greater is required but you have $(gcc-major-version).$(gcc-minor-version)"
-       elif [[ $(gcc-major-version) = 4 ]] && [[ $(gcc-minor-version) -lt 8 ]]; then
-               die "GCC 4.8 or greater is required but you have $(gcc-major-version).$(gcc-minor-version)"
-       fi
-}
-
-pkg_setup() {
-       # add new user & group for daemon
-       enewgroup ${PN}
-       enewuser ${PN} -1 -1 -1 ${PN}
-}
-
-src_configure(){
-       mycmakeargs=( "-DCMAKE_INSTALL_PREFIX=/usr" )
-       if use fuse; then
-               mycmakeargs+=( "-DHAVE_FUSE_25=yes" )
-       else
-               mycmakeargs+=( "-DHAVE_FUSE_25=no" )
-       fi
-       if use tcpd; then
-               mycmakeargs=( "-DHAVE_LIBWRAP=yes" )
-       else
-               mycmakeargs=( "-DHAVE_LIBWRAP=no" )
-       fi
-
-       cmake-utils_src_configure
-}
-
-src_install() {
-       pushd ${CMAKE_BUILD_DIR}
-       dosbin ${PN}
-       if use fuse; then
-               dobin acngfs
-       fi
-       popd
-
-       newinitd "${FILESDIR}"/initd-r1 ${PN}
-       newconfd "${FILESDIR}"/confd ${PN}
-
-       insinto /etc/logrotate.d
-       newins "${FILESDIR}"/logrotate ${PN}
-
-       doman doc/man/${PN}*
-       if use fuse; then
-               doman doc/man/acngfs*
-       fi
-
-       # Documentation
-       dodoc doc/README TODO VERSION INSTALL ChangeLog
-       if use doc; then
-               dodoc doc/*.pdf
-               dohtml doc/html/*
-               docinto examples/conf
-               dodoc conf/*
-       fi
-
-       # perl daily cron script
-       dosbin scripts/expire-caller.pl
-       exeinto /etc/cron.daily
-       newexe "${FILESDIR}"/cron.daily ${PN}
-
-       # default configuration
-       insinto /etc/${PN}
-       newins "${CMAKE_BUILD_DIR}"/conf/acng.conf ${PN}.conf
-       doins $( echo conf/* | sed 's|conf/acng.conf.in||g' )
-
-       keepdir /var/log/${PN}
-       # Some directories must exists
-       keepdir /var/log/${PN}
-       fowners -R ${PN}:${PN} \
-               /etc/${PN} \
-               /var/log/${PN}
-}
index 558f9658d14724d9f461393ed75f926ed4904d93..6cd620ffd410ec40306b95ad424596e150363780 100644 (file)
@@ -4,6 +4,10 @@
 
 # DON'T TOUCH THIS FILE. Instead, file a keyword request bug and CC <hppa@gentoo.org>.
 
+# Jeroen Roovers <jer@gentoo.org> (26 Feb 2017)
+# app-crypt/libsecret is not keyworded for HPPA
+dev-vcs/git libsecret
+
 # Jeroen Roovers <jer@gentoo.org> (4 Feb 2017)
 # media-libs/libilbc has not been ported to HPPA
 # media-libs/zimg triggers a toolchain issue (bug #597152)