x11-libs/libSM: Version bump to 1.2.3
authorMatt Turner <mattst88@gentoo.org>
Wed, 10 Oct 2018 17:00:54 +0000 (10:00 -0700)
committerMatt Turner <mattst88@gentoo.org>
Wed, 10 Oct 2018 17:01:09 +0000 (10:01 -0700)
Signed-off-by: Matt Turner <mattst88@gentoo.org>
Package-Manager: Portage-2.3.49, Repoman-2.3.11

x11-libs/libSM/Manifest
x11-libs/libSM/libSM-1.2.3.ebuild [new file with mode: 0644]

index 69257029b0d5ebc1ffc18170572c68b1c7775230..a61301e3c2d558c61dbd8a6ecd5780c696ce1928 100644 (file)
@@ -1 +1,2 @@
 DIST libSM-1.2.2.tar.bz2 348908 BLAKE2B f3d6d40bfb3058000fd13e9f5ed8daa6628ef197d737e9186e66a517d4c0d4238fa65d0f922b9e6b2839a6f37344c64a560b126911679315cb3824c814d474c7 SHA512 dfb91dcc7200fce8d0a62953ae4b81fcb00d525674bbcc6dfcaa23ecb35e1213ceb07cc51f590072dce2107909903160d9f3636a0434fe2a605b1e9a9bd0a6ca
+DIST libSM-1.2.3.tar.bz2 362595 BLAKE2B 20b7327cd16e066bd2a81eae60f52cab7499dd92d65786d0e5726faa64c2055376749562ff2158777f83711e1517b90b2dc94670892b787889b3950c0a975b68 SHA512 74c42e27029db78475e62025b4711dbac5e22d2f8e8a24be98a1c31b03c0fc4afe859928f851800ea0b76854f12147900dc4f27bbfd3d8ea45daaaf24b70a903
diff --git a/x11-libs/libSM/libSM-1.2.3.ebuild b/x11-libs/libSM/libSM-1.2.3.ebuild
new file mode 100644 (file)
index 0000000..f122e06
--- /dev/null
@@ -0,0 +1,57 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+XORG_DOC=doc
+XORG_MULTILIB=yes
+inherit xorg-2
+
+DESCRIPTION="X.Org Session Management library"
+
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris ~x86-winnt"
+IUSE="doc ipv6 +uuid"
+
+RDEPEND="x11-base/xorg-proto
+       >=x11-libs/libICE-1.0.8-r1[${MULTILIB_USEDEP}]
+       x11-libs/xtrans
+       !elibc_FreeBSD? ( !elibc_SunOS? ( !elibc_Darwin? (
+               uuid? ( >=sys-apps/util-linux-2.24.1-r3[${MULTILIB_USEDEP}] )
+       ) ) )"
+DEPEND="${RDEPEND}"
+
+src_configure() {
+       local withuuid=$(use_with uuid libuuid)
+
+       # do not use uuid even if available in libc (like on FreeBSD)
+       use uuid || export ac_cv_func_uuid_create=no
+
+       if use uuid ; then
+               case ${CHOST} in
+                       *-solaris*|*-darwin*)
+                               if [[ ! -d ${EROOT}usr/include/uuid ]] &&
+                                       [[ -d ${ROOT}usr/include/uuid ]]
+                               then
+                                       # Solaris and Darwin have uuid provided by the host
+                                       # system.  Since util-linux's version is based on this
+                                       # version, and on Darwin actually breaks host headers when
+                                       # installed, we can "pretend" for libSM we have libuuid
+                                       # installed, while in fact we don't
+                                       withuuid="--without-libuuid"
+                                       export HAVE_LIBUUID=yes
+                                       export LIBUUID_CFLAGS="-I${ROOT}usr/include/uuid"
+                                       # Darwin has uuid in libSystem
+                                       [[ ${CHOST} == *-solaris* ]] && export LIBUUID_LIBS="-luuid"
+                               fi
+                               ;;
+               esac
+       fi
+       XORG_CONFIGURE_OPTIONS=(
+               $(use_enable ipv6)
+               $(use_enable doc docs)
+               $(use_with doc xmlto)
+               ${withuuid}
+               --without-fop
+       )
+       xorg-2_src_configure
+}