dev-python/python-distutils-extra: Remove old
authorMichał Górny <mgorny@gentoo.org>
Mon, 11 May 2020 17:35:37 +0000 (19:35 +0200)
committerMichał Górny <mgorny@gentoo.org>
Mon, 11 May 2020 17:35:37 +0000 (19:35 +0200)
Signed-off-by: Michał Górny <mgorny@gentoo.org>
dev-python/python-distutils-extra/Manifest
dev-python/python-distutils-extra/python-distutils-extra-2.42-r1.ebuild [deleted file]

index b23c1e120cd4eedf2db1d66e7dcf83170340dcc7..dfcf028535dcd016bc3000c728af13f8330c8cd7 100644 (file)
@@ -1,2 +1 @@
 DIST python-distutils-extra-2.44.tar.bz2 37687 BLAKE2B 3d7e3ad277440bfb6fbade8b890b95aad37589700b69a26ec9a5c30e97491871bc8c8f82b540131859d2ce82cebd3758f29ca510abe28046ffcaa0e7240fad3e SHA512 517222b4e34efba730db53ffeee8b8c8d96bd9d1b6044e6ca84c0f2c1d5c0e044240b899d460c50295615c94c513f7e57db3e34e5db6588a01ec92a73999f822
-DIST python-distutils-extra_2.42.tar.xz 37996 BLAKE2B dee4cc950bb34027b60dcf58e173bae502a7090062e3c2218fd2ec562d6350f5872ed5c0865b89f1463bd35be0f365f23e05bb0220f70a944181af40df42ee60 SHA512 ff0df0a25a29504bec89970dbbf24d0b618e9f2d5d07a037f67778b86c92e880eafee86dd102b4ada4f280abd3102de9f4a4e47dbc68c1eaaa05fb492cbbae29
diff --git a/dev-python/python-distutils-extra/python-distutils-extra-2.42-r1.ebuild b/dev-python/python-distutils-extra/python-distutils-extra-2.42-r1.ebuild
deleted file mode 100644 (file)
index 183471d..0000000
+++ /dev/null
@@ -1,50 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-DISTUTILS_USE_SETUPTOOLS="rdepend"
-PYTHON_COMPAT=( python{2_7,3_6,3_7,3_8} pypy3 )
-
-inherit distutils-r1
-
-DESCRIPTION="Gettext support, themed icons and scrollkeeper-based documentation in distutils"
-HOMEPAGE="https://launchpad.net/python-distutils-extra"
-SRC_URI="mirror://ubuntu/pool/universe/p/${PN}/${PN}_${PV}.tar.xz"
-
-LICENSE="GPL-2+"
-SLOT="0"
-KEYWORDS="amd64 ~arm ~arm64 ppc x86"
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-DEPEND="test? ( dev-python/pytest[${PYTHON_USEDEP}] )"
-
-DOCS=( doc/{README,FAQ} )
-
-python_prepare_all() {
-       # This line is run when the file is imported
-       # https://bugs.launchpad.net/python-distutils-extra/+bug/1657919
-       sed -i '/^unittest.main()$/d' test/auto.py || die
-
-       distutils-r1_python_prepare_all
-}
-
-python_test() {
-       # 5 tests fail with disabled byte-compilation (they rely on exact
-       # output from python).
-       # The other 4 are broken.
-       pytest -vv -k "not (test_pot_manual or test_pot_auto_explicit or \
-               test_pot_auto or test_modules or test_packages) and not \
-               (test_desktop or test_po or test_policykit or \
-               test_requires_provides)" test/auto.py || \
-               die "tests failed with ${EPYTHON}"
-}
-
-python_install_all() {
-       distutils-r1_python_install_all
-
-       docinto examples
-       dodoc doc/{setup.cfg.example,setup.py.example}
-       docompress -x /usr/share/doc/${PF}/examples
-}