sys-boot/grub: bump to 2.04
authorMike Gilbert <floppym@gentoo.org>
Mon, 8 Jul 2019 23:35:00 +0000 (19:35 -0400)
committerMike Gilbert <floppym@gentoo.org>
Mon, 8 Jul 2019 23:36:25 +0000 (19:36 -0400)
Package-Manager: Portage-2.3.68, Repoman-2.3.16_p2
Signed-off-by: Mike Gilbert <floppym@gentoo.org>
sys-boot/grub/Manifest
sys-boot/grub/grub-2.04.ebuild [new file with mode: 0644]

index 2ebc46a4173494c96227cf3260ee6d4dc7ffba2e..ce3bb74bbd862449e08f3ffc89d4b79d71d7ca99 100644 (file)
@@ -1,5 +1,6 @@
 DIST dejavu-sans-ttf-2.37.zip 417746 BLAKE2B c8904f3cd5a49370a7dc10e456684c88aeae998a99090bf4d0a5baa4f36cc8fb8f70586cf6d610a5ffeee97261d28c80f55bbe9dcfc3ed796d5c2d60e79adb58 SHA512 ede5899daa1984c5aa8cacb1c850eb53f189dddef3d9bb78bf9774d8976b7c0d6eb0bcf86237cd7d11f5b36cf5b5058d42cd94d3bd76f2bd0931c7ceb1271fae
 DIST grub-2.02.tar.xz 6113260 BLAKE2B 7c5ec61a8dc5a00e9cdc91c489f0d2ee37cd7e673eef8e8e26bbc18c5ec28829f563b9298874fb96d45a5d523ce366e936649c21ebda7462afda0cc328b970ce SHA512 cc6eb0a42b5c8df2f671cc128ff725afb3ff1f8832a196022e433cf0d3b75decfca2316d0aa5fabea75747d55e88f3d021dd93508563f8ca80fd7b9e7fe1f088
+DIST grub-2.04.tar.xz 6393864 BLAKE2B 413ffb9aaeae1ee3128032914ca426a1a5adb3737895dfe563fdde5a7e0386ac2dbc2f7ddfc4e0a67b3ad90494985d6886c20054b038701feb743e67e2eed9d0 SHA512 9c15c42d0cf5d61446b752194e3b628bb04be0fe6ea0240ab62b3d753784712744846e1f7c3651d8e0968d22012e6d713c38c44936d4004ded3ca4d4007babbb
 DIST grub-2.04~rc1.tar.xz 6422420 BLAKE2B cf189fea32badba00051734d4e67954009bae016a6b8a366ce41a2ac8ddf8792e2b63262c0a80f1fa5771394ebc76b090f50eac1ccd9f81d594feb8cc15ab400 SHA512 c0bee6a7aced0408d7477fdb8b6fdd3ec48f80f0ecc4e7602d76f9a37081fe08e405faa030b4e4f181f45793641b13f398fe0bed121058ad8729f9a8908703d3
 DIST unifont-12.0.01.pcf.gz 1360857 BLAKE2B ab87e58aee2295e52dc49b7bb131793ad775abbf49f4b64758045a9b5158e75afd01a8425b56e6f6d0ba288a733bf426df363c1ecc78daddec516c33d461bc3b SHA512 9d34a005dd10f212e43075beb71eb39b9cc3403ae1cddec7d79af91b3a3a1beb4a3696075cc94563c8402efe2ad05de552ace77a24da09f1c0b7f95e99b056a3
 DIST unifont-12.1.02.pcf.gz 1335424 BLAKE2B 97080312468e3f3c8aa6f49cef08f5622641e8c9c035f3ede1e09d8d98de4e78d3b23c8aba2e8070eb46cbebd2d55e8568e467d7f15f35aa8fc8db792b7e5f14 SHA512 b280b2db7cf5f480b0668c331130dede2c0cc87d5e02e44566b77787113d0f6604d0105522858288f2ac6b8e77df7a2d9878725013a6c778dc5bfb183156e2f0
diff --git a/sys-boot/grub/grub-2.04.ebuild b/sys-boot/grub/grub-2.04.ebuild
new file mode 100644 (file)
index 0000000..567c292
--- /dev/null
@@ -0,0 +1,296 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+if [[ ${PV} == 9999  ]]; then
+       GRUB_AUTORECONF=1
+       GRUB_BOOTSTRAP=1
+fi
+
+if [[ -n ${GRUB_AUTOGEN} || -n ${GRUB_BOOTSTRAP} ]]; then
+       PYTHON_COMPAT=( python{2_7,3_{5,6,7}} )
+       inherit python-any-r1
+fi
+
+if [[ -n ${GRUB_AUTORECONF} ]]; then
+       WANT_LIBTOOL=none
+       inherit autotools
+fi
+
+inherit bash-completion-r1 flag-o-matic multibuild pax-utils toolchain-funcs
+
+if [[ ${PV} != 9999 ]]; then
+       if [[ ${PV} == *_alpha* || ${PV} == *_beta* || ${PV} == *_rc* ]]; then
+               # The quote style is to work with <=bash-4.2 and >=bash-4.3 #503860
+               MY_P=${P/_/'~'}
+               SRC_URI="mirror://gnu-alpha/${PN}/${MY_P}.tar.xz"
+               S=${WORKDIR}/${MY_P}
+       else
+               SRC_URI="mirror://gnu/${PN}/${P}.tar.xz"
+               S=${WORKDIR}/${P%_*}
+       fi
+       KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86"
+else
+       inherit git-r3
+       EGIT_REPO_URI="https://git.savannah.gnu.org/git/grub.git"
+fi
+
+PATCHES=(
+       "${FILESDIR}"/gfxpayload.patch
+       "${FILESDIR}"/grub-2.02_beta2-KERNEL_GLOBS.patch
+)
+
+DEJAVU=dejavu-sans-ttf-2.37
+UNIFONT=unifont-12.1.02
+SRC_URI+=" fonts? ( mirror://gnu/unifont/${UNIFONT}/${UNIFONT}.pcf.gz )
+       themes? ( mirror://sourceforge/dejavu/${DEJAVU}.zip )"
+
+DESCRIPTION="GNU GRUB boot loader"
+HOMEPAGE="https://www.gnu.org/software/grub/"
+
+# Includes licenses for dejavu and unifont
+LICENSE="GPL-3 fonts? ( GPL-2-with-font-exception ) themes? ( BitstreamVera )"
+SLOT="2/${PVR}"
+IUSE="device-mapper doc efiemu +fonts mount nls sdl test +themes truetype libzfs"
+
+GRUB_ALL_PLATFORMS=( coreboot efi-32 efi-64 emu ieee1275 loongson multiboot qemu qemu-mips pc uboot xen xen-32 )
+IUSE+=" ${GRUB_ALL_PLATFORMS[@]/#/grub_platforms_}"
+
+REQUIRED_USE="
+       grub_platforms_coreboot? ( fonts )
+       grub_platforms_qemu? ( fonts )
+       grub_platforms_ieee1275? ( fonts )
+       grub_platforms_loongson? ( fonts )
+"
+
+BDEPEND="
+       ${PYTHON_DEPS}
+       app-misc/pax-utils
+       sys-devel/flex
+       sys-devel/bison
+       sys-apps/help2man
+       sys-apps/texinfo
+       fonts? (
+               media-libs/freetype:2
+               virtual/pkgconfig
+       )
+       test? (
+               app-admin/genromfs
+               app-arch/cpio
+               app-arch/lzop
+               app-emulation/qemu
+               dev-libs/libisoburn
+               sys-apps/miscfiles
+               sys-block/parted
+               sys-fs/squashfs-tools
+       )
+       themes? (
+               app-arch/unzip
+               media-libs/freetype:2
+               virtual/pkgconfig
+       )
+       truetype? ( virtual/pkgconfig )
+"
+DEPEND="
+       app-arch/xz-utils
+       >=sys-libs/ncurses-5.2-r5:0=
+       sdl? ( media-libs/libsdl )
+       device-mapper? ( >=sys-fs/lvm2-2.02.45 )
+       libzfs? ( sys-fs/zfs )
+       mount? ( sys-fs/fuse:0 )
+       truetype? ( media-libs/freetype:2= )
+       ppc? ( >=sys-apps/ibm-powerpc-utils-1.3.5 )
+       ppc64? ( >=sys-apps/ibm-powerpc-utils-1.3.5 )
+       grub_platforms_xen? ( app-emulation/xen-tools:= )
+       grub_platforms_xen-32? ( app-emulation/xen-tools:= )
+"
+RDEPEND="${DEPEND}
+       kernel_linux? (
+               grub_platforms_efi-32? ( sys-boot/efibootmgr )
+               grub_platforms_efi-64? ( sys-boot/efibootmgr )
+       )
+       !sys-boot/grub:0 !sys-boot/grub-static
+       nls? ( sys-devel/gettext )
+"
+
+RESTRICT="!test? ( test )"
+
+QA_EXECSTACK="usr/bin/grub-emu* usr/lib/grub/*"
+QA_PRESTRIPPED="usr/lib/grub/.*"
+QA_MULTILIB_PATHS="usr/lib/grub/.*"
+QA_WX_LOAD="usr/lib/grub/*"
+
+src_unpack() {
+       if [[ ${PV} == 9999 ]]; then
+               git-r3_src_unpack
+               pushd "${P}" >/dev/null || die
+               local GNULIB_URI="https://git.savannah.gnu.org/git/gnulib.git"
+               local GNULIB_REVISION=$(source bootstrap.conf >/dev/null; echo "${GNULIB_REVISION}")
+               git-r3_fetch "${GNULIB_URI}" "${GNULIB_REVISION}"
+               git-r3_checkout "${GNULIB_URI}" gnulib
+               popd >/dev/null || die
+       fi
+       default
+}
+
+src_prepare() {
+       default
+
+       sed -i -e /autoreconf/d autogen.sh || die
+
+       # Nothing in Gentoo packages 'american-english' in the exact path
+       # wanted for the test, but all that is needed is a compressible text
+       # file, and we do have 'words' from miscfiles in the same path.
+       sed -i \
+               -e '/CFILESSRC.*=/s,american-english,words,' \
+               tests/util/grub-fs-tester.in \
+               || die
+
+       if [[ -n ${GRUB_AUTOGEN} || -n ${GRUB_BOOTSTRAP} ]]; then
+               python_setup
+       fi
+
+       if [[ -n ${GRUB_BOOTSTRAP} ]]; then
+               eautopoint --force
+               AUTOPOINT=: AUTORECONF=: ./bootstrap || die
+       elif [[ -n ${GRUB_AUTOGEN} ]]; then
+               ./autogen.sh || die
+       fi
+
+       if [[ -n ${GRUB_AUTORECONF} ]]; then
+               eautoreconf
+       fi
+}
+
+grub_do() {
+       multibuild_foreach_variant run_in_build_dir "$@"
+}
+
+grub_do_once() {
+       multibuild_for_best_variant run_in_build_dir "$@"
+}
+
+grub_configure() {
+       local platform
+
+       case ${MULTIBUILD_VARIANT} in
+               efi*) platform=efi ;;
+               xen*) platform=xen ;;
+               guessed) ;;
+               *) platform=${MULTIBUILD_VARIANT} ;;
+       esac
+
+       case ${MULTIBUILD_VARIANT} in
+               *-32)
+                       if [[ ${CTARGET:-${CHOST}} == x86_64* ]]; then
+                               local CTARGET=i386
+                       fi ;;
+               *-64)
+                       if [[ ${CTARGET:-${CHOST}} == i?86* ]]; then
+                               local CTARGET=x86_64
+                               local -x TARGET_CFLAGS="-Os -march=x86-64 ${TARGET_CFLAGS}"
+                               local -x TARGET_CPPFLAGS="-march=x86-64 ${TARGET_CPPFLAGS}"
+                       fi ;;
+       esac
+
+       local myeconfargs=(
+               --disable-werror
+               --program-prefix=
+               --libdir="${EPREFIX}"/usr/lib
+               --htmldir="${EPREFIX}"/usr/share/doc/${PF}/html
+               $(use_enable device-mapper)
+               $(use_enable mount grub-mount)
+               $(use_enable nls)
+               $(use_enable themes grub-themes)
+               $(use_enable truetype grub-mkfont)
+               $(use_enable libzfs)
+               $(use_enable sdl grub-emu-sdl)
+               ${platform:+--with-platform=}${platform}
+
+               # Let configure detect this where supported
+               $(usex efiemu '' '--disable-efiemu')
+       )
+
+       if use fonts; then
+               ln -rs "${WORKDIR}/${UNIFONT}.pcf" unifont.pcf || die
+       fi
+
+       if use themes; then
+               ln -rs "${WORKDIR}/${DEJAVU}/ttf/DejaVuSans.ttf" DejaVuSans.ttf || die
+       fi
+
+       local ECONF_SOURCE="${S}"
+       econf "${myeconfargs[@]}"
+}
+
+src_configure() {
+       # Bug 508758.
+       replace-flags -O3 -O2
+
+       # We don't want to leak flags onto boot code.
+       export HOST_CCASFLAGS=${CCASFLAGS}
+       export HOST_CFLAGS=${CFLAGS}
+       export HOST_CPPFLAGS=${CPPFLAGS}
+       export HOST_LDFLAGS=${LDFLAGS}
+       unset CCASFLAGS CFLAGS CPPFLAGS LDFLAGS
+
+       tc-ld-disable-gold #439082 #466536 #526348
+       export TARGET_LDFLAGS="${TARGET_LDFLAGS} ${LDFLAGS}"
+       unset LDFLAGS
+
+       tc-export CC NM OBJCOPY RANLIB STRIP
+       tc-export BUILD_CC # Bug 485592
+
+       MULTIBUILD_VARIANTS=()
+       local p
+       for p in "${GRUB_ALL_PLATFORMS[@]}"; do
+               use "grub_platforms_${p}" && MULTIBUILD_VARIANTS+=( "${p}" )
+       done
+       [[ ${#MULTIBUILD_VARIANTS[@]} -eq 0 ]] && MULTIBUILD_VARIANTS=( guessed )
+       grub_do grub_configure
+}
+
+src_compile() {
+       # Sandbox bug 404013.
+       use libzfs && addpredict /etc/dfs:/dev/zfs
+
+       grub_do emake
+       use doc && grub_do_once emake -C docs html
+}
+
+src_test() {
+       # The qemu dependency is a bit complex.
+       # You will need to adjust QEMU_SOFTMMU_TARGETS to match the cpu/platform.
+       grub_do emake check
+}
+
+src_install() {
+       grub_do emake install DESTDIR="${D}" bashcompletiondir="$(get_bashcompdir)"
+       use doc && grub_do_once emake -C docs install-html DESTDIR="${D}"
+
+       einstalldocs
+
+       insinto /etc/default
+       newins "${FILESDIR}"/grub.default-3 grub
+
+       dostrip -x /usr/lib/grub
+}
+
+pkg_postinst() {
+       elog "For information on how to configure GRUB2 please refer to the guide:"
+       elog "    https://wiki.gentoo.org/wiki/GRUB2_Quick_Start"
+
+       if has_version 'sys-boot/grub:0'; then
+               elog "A migration guide for GRUB Legacy users is available:"
+               elog "    https://wiki.gentoo.org/wiki/GRUB2_Migration"
+       fi
+
+       if [[ -z ${REPLACING_VERSIONS} ]]; then
+               elog
+               elog "You may consider installing the following optional packages:"
+               optfeature "Detect other operating systems (grub-mkconfig)" sys-boot/os-prober
+               optfeature "Create rescue media (grub-mkrescue)" dev-libs/libisoburn
+               optfeature "Enable RAID device detection" sys-fs/mdadm
+       fi
+}