dev-libs/liblinear: fix missing quoting, #561826
authorMichał Górny <mgorny@gentoo.org>
Tue, 29 Sep 2015 16:13:23 +0000 (18:13 +0200)
committerMichał Górny <mgorny@gentoo.org>
Tue, 29 Sep 2015 16:13:23 +0000 (18:13 +0200)
Add missing quoting around make parameters. Thanks to Ben Kohler for the
solution.

Fixes: https://bugs.gentoo.org/show_bug.cgi?id=561826

Package-Manager: portage-2.2.20

dev-libs/liblinear/liblinear-210-r1.ebuild

index 250995b54042e97b44ce208ffb449a5628cacc94..1e7b089fbe613802ff2e8faa440f83f58c0f6e9f 100644 (file)
@@ -35,13 +35,13 @@ src_prepare() {
 
 src_compile() {
        emake \
-               CC=$(tc-getCC) \
-               CXX=$(tc-getCXX) \
+               CC="$(tc-getCC)" \
+               CXX="$(tc-getCXX)" \
                CFLAGS="${CFLAGS} -fPIC" \
                CXXFLAGS="${CXXFLAGS} -fPIC" \
                AR="$(tc-getAR) rcv" \
                RANLIB="$(tc-getRANLIB)" \
-               LIBS=$($(tc-getPKG_CONFIG) --libs blas) \
+               LIBS="$($(tc-getPKG_CONFIG) --libs blas)" \
                lib all
 }