dev-python/m2crypto: add prefix support
authorGuilherme Amadio <amadio@gentoo.org>
Mon, 28 Aug 2017 17:26:09 +0000 (19:26 +0200)
committerGuilherme Amadio <amadio@gentoo.org>
Mon, 28 Aug 2017 17:26:40 +0000 (19:26 +0200)
Package-Manager: Portage-2.3.8, Repoman-2.3.3

dev-python/m2crypto/m2crypto-0.26.0.ebuild

index f6ebb3ee90169680758def4c7a4dd6fcd2dd146c..55a09e5116039a143d212d22969ad107e881ff12 100644 (file)
@@ -16,7 +16,8 @@ SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_PN}-${PV}.tar.gz"
 
 LICENSE="BSD"
 SLOT="0"
-KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc64"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc64 ~amd64-linux ~x86-linux ~x64-macos ~x86-macos"
+
 IUSE="libressl"
 
 RDEPEND="
@@ -34,6 +35,10 @@ S="${WORKDIR}/${MY_PN}-${PV}"
 # Tests access network, and fail randomly. Bug #431458.
 RESTRICT=test
 
+python_compile() {
+       distutils-r1_python_compile --openssl="${EPREFIX}"/usr
+}
+
 python_test() {
        esetup.py test
 }