dev-perl/Crypt-DH: EAPI6 + Tests
authorKent Fredric <kentnl@gentoo.org>
Wed, 18 Oct 2017 23:33:00 +0000 (12:33 +1300)
committerKent Fredric <kentnl@gentoo.org>
Thu, 19 Oct 2017 00:06:15 +0000 (13:06 +1300)
- EAPI6
- Tests enabled

Package-Manager: Portage-2.3.8, Repoman-2.3.3

dev-perl/Crypt-DH/Crypt-DH-0.70.0-r2.ebuild [new file with mode: 0644]

diff --git a/dev-perl/Crypt-DH/Crypt-DH-0.70.0-r2.ebuild b/dev-perl/Crypt-DH/Crypt-DH-0.70.0-r2.ebuild
new file mode 100644 (file)
index 0000000..1535df4
--- /dev/null
@@ -0,0 +1,28 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DIST_AUTHOR=MITHALDU
+DIST_VERSION=0.07
+inherit perl-module
+
+DESCRIPTION="Diffie-Hellman key exchange system"
+
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~mips ~x86"
+IUSE=""
+
+RDEPEND="
+       dev-libs/gmp
+       dev-perl/Math-BigInt-GMP
+       >=virtual/perl-Math-BigInt-1.60
+       dev-perl/Crypt-Random
+"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+       sed -i -e 's/use inc::Module::Install;/use lib q[.]; use inc::Module::Install;/' Makefile.PL ||
+               die "Can't patch Makefile.PL for 5.26 dot-in-inc"
+       perl-module_src_prepare
+}