Remove unused imports found by pylint.
authorArfrever Frehtes Taifersar Arahesis <Arfrever@Gentoo.Org>
Sun, 29 Aug 2010 21:27:15 +0000 (23:27 +0200)
committerArfrever Frehtes Taifersar Arahesis <Arfrever@Gentoo.Org>
Sun, 29 Aug 2010 21:27:15 +0000 (23:27 +0200)
35 files changed:
pym/_emerge/AbstractEbuildProcess.py
pym/_emerge/AtomArg.py
pym/_emerge/BinpkgVerifier.py
pym/_emerge/Blocker.py
pym/_emerge/EbuildBuild.py
pym/_emerge/EbuildFetcher.py
pym/_emerge/EbuildSpawnProcess.py
pym/_emerge/PackageUninstall.py
pym/_emerge/PollScheduler.py
pym/_emerge/RootConfig.py
pym/_emerge/Scheduler.py
pym/_emerge/actions.py
pym/_emerge/clear_caches.py
pym/_emerge/create_world_atom.py
pym/_emerge/resolver/circular_dependency.py
pym/portage/_selinux.py
pym/portage/cache/metadata_overlay.py
pym/portage/cache/sqlite.py
pym/portage/checksum.py
pym/portage/data.py
pym/portage/dbapi/porttree.py
pym/portage/dbapi/vartree.py
pym/portage/dep/dep_check.py
pym/portage/elog/filtering.py
pym/portage/package/ebuild/doebuild.py
pym/portage/package/ebuild/fetch.py
pym/portage/process.py
pym/portage/sets/base.py
pym/portage/tests/dep/test_dep_getusedeps.py
pym/portage/tests/ebuild/test_pty_eof.py
pym/portage/tests/resolver/test_required_use.py
pym/portage/tests/resolver/test_use_dep_defaults.py
pym/portage/tests/util/test_grabdict.py
pym/portage/versions.py
pym/repoman/utilities.py

index ecd44f5afac80caf569acb463dc9471045e40846..bbbb281368be92a8dc6adf818be46c5d0b06475b 100644 (file)
@@ -1,7 +1,6 @@
 # Copyright 1999-2010 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
 
-import codecs
 import stat
 import textwrap
 from _emerge.SpawnProcess import SpawnProcess
@@ -15,9 +14,8 @@ from portage import os
 from portage import StringIO
 from portage import _encodings
 from portage import _unicode_decode
-from portage import _unicode_encode
 from portage.util._pty import _create_pty_or_pipe
-from portage.util import apply_secpass_permissions, writemsg_stdout
+from portage.util import apply_secpass_permissions
 
 class AbstractEbuildProcess(SpawnProcess):
 
index 244ea28e742229a90eb5f1531227c564a1404083..871e2b71da22c404ada3d92b29f9b78c352ea583 100644 (file)
@@ -1,14 +1,8 @@
-# Copyright 1999-2009 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
 
 from _emerge.DependencyArg import DependencyArg
-try:
-       import portage
-except ImportError:
-       from os import path as osp
-       import sys
-       sys.path.insert(0, osp.join(osp.dirname(osp.dirname(osp.realpath(__file__))), "pym"))
-       import portage
+
 class AtomArg(DependencyArg):
        def __init__(self, atom=None, **kwargs):
                DependencyArg.__init__(self, **kwargs)
index 198091da48439869e241ac44a7287f6d8e804349..ab319136145631b8ca435bad9f390027454601f7 100644 (file)
@@ -1,4 +1,4 @@
-# Copyright 1999-2009 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
 
 from _emerge.AsynchronousTask import AsynchronousTask
@@ -8,10 +8,7 @@ import portage
 from portage import os
 from portage import _encodings
 from portage import _unicode_decode
-from portage import _unicode_encode
-from portage import StringIO
 from portage.package.ebuild.fetch import _checksum_failure_temp_file
-import codecs
 
 class BinpkgVerifier(AsynchronousTask):
        __slots__ = ("logfile", "pkg", "scheduler")
index 04b6bb1d489f28f14e8b67a1b2bb4a157f99c538..5c335b066a9b3a34607b8498ac9f53bc8eb8dc1f 100644 (file)
@@ -1,14 +1,8 @@
-# Copyright 1999-2009 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
 
 from _emerge.Task import Task
-try:
-       import portage
-except ImportError:
-       from os import path as osp
-       import sys
-       sys.path.insert(0, osp.join(osp.dirname(osp.dirname(osp.realpath(__file__))), "pym"))
-       import portage
+
 class Blocker(Task):
 
        __hash__ = Task.__hash__
index 5c108fee4d6a21a7cadb6031f7ae50794485ba7a..f058cae12c3af926f46488389d0024182147d92d 100644 (file)
@@ -13,9 +13,6 @@ from _emerge.MiscFunctionsProcess import MiscFunctionsProcess
 from portage.util import writemsg
 import portage
 from portage import os
-from portage import _encodings
-from portage import _unicode_encode
-import codecs
 from portage.output import colorize
 from portage.package.ebuild.digestcheck import digestcheck
 from portage.package.ebuild.doebuild import _check_temp_dir
index 63e423771cdd3ee145ddcadbe6d1637281af7150..bbae6a6a1ff4a91efa72e4fb94814ce3ee2b0d5a 100644 (file)
@@ -10,7 +10,6 @@ from portage import _unicode_encode
 from portage import _unicode_decode
 import codecs
 from portage.elog.messages import eerror
-from portage.util import writemsg_stdout
 from portage.util._pty import _create_pty_or_pipe
 
 class EbuildFetcher(SpawnProcess):
index dd12b74e98f1417fd30269de1d49540a545bc62f..e1f682a664c2071d03394eba6546a2c7f7615286 100644 (file)
@@ -2,8 +2,6 @@
 # Distributed under the terms of the GNU General Public License v2
 
 from _emerge.AbstractEbuildProcess import AbstractEbuildProcess
-import portage
-from portage import os
 
 class EbuildSpawnProcess(AbstractEbuildProcess):
        """
index e806bc154213c5038f95a73b0ecb083b4b7229fd..5e8850b180f65d0c06bdc099480625ed3498555c 100644 (file)
@@ -1,12 +1,9 @@
-# Copyright 1999-2009 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
 
-import codecs
 import logging
 import portage
 from portage import os
-from portage import _encodings
-from portage import _unicode_encode
 from _emerge.AsynchronousTask import AsynchronousTask
 from _emerge.unmerge import unmerge
 from _emerge.UninstallFailure import UninstallFailure
index 2c9eb2a8c97714c66c6b8e59027c3be5e72314b0..f536de0fbea7538f129c08297ba5f6f412ce0c3a 100644 (file)
@@ -8,7 +8,6 @@ import time
 
 from portage import _encodings
 from portage import _unicode_encode
-from portage import os
 from portage.util import writemsg_level
 
 from _emerge.SlotObject import SlotObject
index 2898c2e0de549334c8866e4eb5a2643a2cc3bf84..110f116943f185a96d792417453deef25ccab243 100644 (file)
@@ -1,8 +1,6 @@
-# Copyright 1999-2009 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
 
-from _emerge.PackageVirtualDbapi import PackageVirtualDbapi
-
 class RootConfig(object):
        """This is used internally by depgraph to track information about a
        particular $ROOT."""
index 3bfc74124b6810d4a5aea59727078e7dde40e049..7db16088d5f408c4d6916f975cda534638d647d5 100644 (file)
@@ -3,7 +3,6 @@
 
 from __future__ import print_function
 
-import codecs
 import gzip
 import logging
 import shutil
@@ -18,7 +17,6 @@ import portage
 from portage import StringIO
 from portage import os
 from portage import _encodings
-from portage import _unicode_decode
 from portage import _unicode_encode
 from portage.cache.mappings import slot_dict_class
 from portage.const import LIBC_PACKAGE_ATOM
index 1f00cb3a6f119a4c6e9670e3437f73325ac4bceb..815032d14f7d9c9913318a14eca385831f1d8a8a 100644 (file)
@@ -25,7 +25,7 @@ from itertools import chain
 import portage
 from portage import os
 from portage import digraph
-from portage import _unicode_decode, _unicode_encode
+from portage import _unicode_decode
 from portage.cache.cache_errors import CacheError
 from portage.const import GLOBAL_CONFIG_PATH, NEWS_LIB_PATH
 from portage.dbapi.dep_expand import dep_expand
index 30371f03fd27d2b818f04bf6c88b9af992dbacc7..5999f281a4a5d28ac4a1816f74d8ebda49a59120 100644 (file)
@@ -1,8 +1,7 @@
-# Copyright 1999-2009 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
 
 import gc
-import portage
 from portage.util.listdir import dircache
 
 def clear_caches(trees):
index 146cc4ccbc517bcd5ffb700429e5f7c43f1a027a..54964186c37b8ce54b8b7c2b4042b99600f87d1e 100644 (file)
@@ -1,8 +1,6 @@
-# Copyright 1999-2009 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
 
-import portage
-
 def create_world_atom(pkg, args_set, root_config):
        """Create a new atom for the world file if one does not exist.  If the
        argument atom is precise enough to identify a specific slot then a slot
index 0ecdbbe8c0a51f970303c9ae896e63342bd0088c..78c5bebc7b2e36ee86209d1e2b1ca0416faac4b2 100644 (file)
@@ -5,7 +5,6 @@ from __future__ import print_function
 
 from itertools import chain
 
-from portage.util import writemsg
 from portage.dep import use_reduce, extract_affecting_use, check_required_use, get_required_use_flags
 from portage.output import colorize
 from _emerge.DepPrioritySatisfiedRange import DepPrioritySatisfiedRange
index e14324e551e7214e51f169f1efd0bf3dc040373d..cad5be8cc8efaadefe9887c23e0264e3c2cea1cc 100644 (file)
@@ -1,4 +1,4 @@
-# Copyright 1999-2009 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
 
 # Don't use the unicode-wrapped os and shutil modules here since
@@ -13,7 +13,6 @@ from portage import _unicode_encode
 from portage.localization import _
 
 import selinux
-from selinux import is_selinux_enabled
 
 def copyfile(src, dest):
        src = _unicode_encode(src, encoding=_encodings['fs'], errors='strict')
index a4053372b8d977242ef8b00c08515d7089b8674a..cfa0051e6647fe2956203da083ad3734f3a3513d 100644 (file)
@@ -1,7 +1,6 @@
-# Copyright 1999-2009 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
 
-import time
 from portage.cache import template
 from portage.cache.cache_errors import CacheCorruption
 from portage.cache.flat_hash import database as db_rw
index cd118f51555fafc88ef3d5c4d44edc6f68774ea3..2e13be320efe350cc3605b48bd27c3856f0be777 100644 (file)
@@ -1,4 +1,4 @@
-# Copyright 1999-2009 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
 
 import sys
@@ -6,7 +6,6 @@ from portage.cache import fs_template
 from portage.cache import cache_errors
 from portage import os
 from portage import _unicode_decode
-from portage.cache.template import reconstruct_eclasses
 from portage.util import writemsg
 from portage.localization import _
 try:
index e460e7ac773542ee5d1090e88a7e49f4fa169f8b..f640fd9f1d9e4e6058c4f1f5dffdbf8d29d74a5f 100644 (file)
@@ -1,9 +1,9 @@
 # checksum.py -- core Portage functionality
-# Copyright 1998-2004 Gentoo Foundation
+# Copyright 1998-2010 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
 
 import portage
-from portage.const import PRIVATE_PATH,PRELINK_BINARY,HASHING_BLOCKSIZE
+from portage.const import PRELINK_BINARY,HASHING_BLOCKSIZE
 from portage.localization import _
 from portage import os
 from portage import _encodings
index fd464378dc55b1ae546f500294c13903bacde7ff..c38fa17bc6b9ee97e3df2f29043d970544290964 100644 (file)
@@ -1,8 +1,8 @@
 # data.py -- Calculated/Discovered Data Values
-# Copyright 1998-2009 Gentoo Foundation
+# Copyright 1998-2010 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
 
-import os, sys, pwd, grp, platform
+import os, pwd, grp, platform
 
 import portage
 portage.proxy.lazyimport.lazyimport(globals(),
index 1780b43395bae9dbc6412d6aaf3daf336f526e50..ed6b761b64a8a9fd395dfb91495b83604d933d76 100644 (file)
@@ -1,4 +1,4 @@
-# Copyright 1998-2009 Gentoo Foundation
+# Copyright 1998-2010 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
 
 __all__ = [
@@ -32,7 +32,6 @@ from portage import eclass_cache, auxdbkeys, \
        _eapi_is_deprecated
 from portage import os
 from portage import _encodings
-from portage import _unicode_decode
 from portage import _unicode_encode
 from portage import OrderedDict
 from _emerge.EbuildMetadataPhase import EbuildMetadataPhase
index 34dc147181044de6f70821d758ac573c6eba723d..592fce96122c04f2722729a645753198b4ca8160 100644 (file)
@@ -54,7 +54,7 @@ from _emerge.MiscFunctionsProcess import MiscFunctionsProcess
 
 import codecs
 import gc
-import re, shutil, stat, errno, copy, subprocess
+import re, shutil, stat, errno, subprocess
 import logging
 import os as _os
 import stat
index 07a38d0c5b0294ea2c89ddc37bece0e44bb87caa..cdedf7920c6833af250b5718860f0f34eb57ad30 100644 (file)
@@ -7,8 +7,6 @@ import logging
 
 import portage
 from portage.dep import Atom, match_from_list, use_reduce
-from portage.eapi import eapi_has_strong_blocks, eapi_has_use_deps, eapi_has_slot_deps, \
-       eapi_has_use_dep_defaults
 from portage.exception import InvalidDependString, ParseError
 from portage.localization import _
 from portage.util import writemsg, writemsg_level
index 2e154242b84ee48a5f61c3703e28006e75ff54b1..82181a4cb0035d1d32c8c3ad2035186d44533977 100644 (file)
@@ -1,9 +1,7 @@
 # elog/messages.py - elog core functions
-# Copyright 2006-2007 Gentoo Foundation
+# Copyright 2006-2010 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
 
-from portage.const import EBUILD_PHASES
-
 def filter_loglevels(logentries, loglevels):
        # remove unwanted entries from all logentries
        rValue = {}
index 9fa6476e0085e5632747c72125dcda76fb9de0a6..cc1f60d861b2247c85815ac468f72a23a68909fa 100644 (file)
@@ -4,7 +4,6 @@
 __all__ = ['doebuild', 'doebuild_environment', 'spawn', 'spawnebuild']
 
 import codecs
-import errno
 import gzip
 from itertools import chain
 import logging
@@ -43,7 +42,7 @@ from portage.eapi import eapi_exports_KV, eapi_exports_replace_vars, \
 from portage.elog import elog_process
 from portage.elog.messages import eerror, eqawarn
 from portage.exception import DigestException, FileNotFound, \
-       IncorrectParameter, InvalidAtom, InvalidDependString, PermissionDenied, \
+       IncorrectParameter, InvalidDependString, PermissionDenied, \
        UnsupportedAPIException
 from portage.localization import _
 from portage.manifest import Manifest
index 86d4db96d8126b3b68767f517f877e9c50ad1732..06cb90801d3acae92db8077c0b7c3f6d852b60d7 100644 (file)
@@ -28,7 +28,7 @@ from portage import OrderedDict, os, selinux, _encodings, \
        _shell_quote, _unicode_encode
 from portage.checksum import perform_md5, verify_all
 from portage.const import BASH_BINARY, CUSTOM_MIRRORS_FILE, \
-       EBUILD_SH_BINARY, GLOBAL_CONFIG_PATH
+       GLOBAL_CONFIG_PATH
 from portage.data import portage_gid, portage_uid, secpass, userpriv_groups
 from portage.exception import FileNotFound, OperationNotPermitted, \
        PermissionDenied, PortageException, TryAgain
index 66ec1edd05d6ad89a4cb265ae1d27d534e9c1c8d..2787e08844ed33a73299384cea727374d52946a2 100644 (file)
@@ -1,5 +1,5 @@
 # portage.py -- core Portage functionality
-# Copyright 1998-2009 Gentoo Foundation
+# Copyright 1998-2010 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
 
 
@@ -10,7 +10,6 @@ import traceback
 
 from portage import os
 from portage import _encodings
-from portage import _unicode_decode
 from portage import _unicode_encode
 import portage
 portage.proxy.lazyimport.lazyimport(globals(),
index f3cf37359457432b67b200b84635fe3dfa855e23..cd9c08d32b761ae865ddbda0b43de470487ae37d 100644 (file)
@@ -1,10 +1,10 @@
-# Copyright 2007 Gentoo Foundation
+# Copyright 2007-2010 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
 
 import sys
 from portage.dep import Atom, ExtendedAtomDict, best_match_to_list, match_from_list
 from portage.exception import InvalidAtom
-from portage.versions import catsplit, cpv_getkey
+from portage.versions import cpv_getkey
 
 if sys.hexversion >= 0x3000000:
        basestring = str
index 05977b157338acb077c2373023aba2741b52a828..d2494f7b361e05487e1fc567752facbc77a08644 100644 (file)
@@ -1,11 +1,10 @@
 # test_dep_getusedeps.py -- Portage Unit Testing Functionality
-# Copyright 2007 Gentoo Foundation
+# Copyright 2007-2010 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
 
 from portage.tests import TestCase
 from portage.dep import dep_getusedeps
 
-import sys
 from portage.tests import test_cps, test_slots, test_versions, test_usedeps
 
 class DepGetUseDeps(TestCase):
index a910f98b54ef33f51e2c9b143ca57e858162871f..042227b672648c05099460c66ddad7180a118d19 100644 (file)
@@ -1,7 +1,6 @@
-# Copyright 2009 Gentoo Foundation
+# Copyright 2009-2010 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
 
-import portage
 from portage.tests import TestCase
 from portage.util._pty import _can_test_pty_eof, _test_pty_eof
 
index 8996ea05e0bba51515804c8bb388d63acec37bab..6835b33c7ba5ee52b3998688b9822034546cc5fe 100644 (file)
@@ -2,7 +2,7 @@
 # Distributed under the terms of the GNU General Public License v2
 
 from portage.tests import TestCase
-from portage.tests.resolver.ResolverPlayground import ResolverPlayground, ResolverPlaygroundTestCase
+#from portage.tests.resolver.ResolverPlayground import ResolverPlayground, ResolverPlaygroundTestCase
 
 class RequiredUSETestCase(TestCase):
 
index 8f41e40c85ab4d366e46e1646f3aaa552290b4ba..0ddcd38368fc1f2568df68ff00d524e6e5899bbe 100644 (file)
@@ -2,7 +2,7 @@
 # Distributed under the terms of the GNU General Public License v2
 
 from portage.tests import TestCase
-from portage.tests.resolver.ResolverPlayground import ResolverPlayground, ResolverPlaygroundTestCase
+#from portage.tests.resolver.ResolverPlayground import ResolverPlayground, ResolverPlaygroundTestCase
 
 class UseDepDefaultsTestCase(TestCase):
 
index 3bf7190545d72be52d28ffae00d436dab9bef566..e62a75dcce4651aa6919d07aff7784bf03d59c35 100644 (file)
@@ -1,9 +1,9 @@
 # test_grabDict.py -- Portage Unit Testing Functionality
-# Copyright 2006 Gentoo Foundation
+# Copyright 2006-2010 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
 
 from portage.tests import TestCase
-from portage.util import grabdict
+#from portage.util import grabdict
 
 class GrabDictTestCase(TestCase):
        
index 1db421a7e9837a910d8c4759d401469d60fe1ceb..e40866ef6954b3808099ec1c4eb6691d964dfa82 100644 (file)
@@ -1,5 +1,5 @@
 # versions.py -- core Portage functionality
-# Copyright 1998-2006 Gentoo Foundation
+# Copyright 1998-2010 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
 
 __all__ = [
@@ -11,6 +11,7 @@ __all__ = [
 import re
 import warnings
 
+from portage.localization import _
 
 # \w is [a-zA-Z0-9_]
 
@@ -36,9 +37,6 @@ suffix_regexp = re.compile("^(alpha|beta|rc|pre|p)(\\d*)$")
 suffix_value = {"pre": -2, "p": 0, "alpha": -4, "beta": -3, "rc": -1}
 endversion_keys = ["pre", "p", "alpha", "beta", "rc"]
 
-from portage.exception import InvalidData
-from portage.localization import _
-
 def ververify(myver, silent=1):
        if ver_regexp.match(myver):
                return 1
index a6c24d862701eb13ec842581882b054cda319609..e957c84b26b73118f3ddeb69de91abe0c0dc4694 100644 (file)
@@ -23,7 +23,6 @@ __all__ = [
 import codecs
 import errno
 import logging
-import re
 import sys
 from portage import os
 from portage import subprocess_getstatusoutput