app-text/cherrytree: bump to 0.39.2
authorYury Martynov <email@linxon.ru>
Wed, 18 Mar 2020 10:52:32 +0000 (13:52 +0300)
committerJoonas Niilola <juippis@gentoo.org>
Thu, 9 Apr 2020 08:54:52 +0000 (11:54 +0300)
Bug: https://bugs.gentoo.org/708094
Package-Manager: Portage-2.3.89, Repoman-2.3.20
Signed-off-by: Yury Martynov <email@linxon.ru>
Closes: https://github.com/gentoo/gentoo/pull/15235
Signed-off-by: Joonas Niilola <juippis@gentoo.org>
app-text/cherrytree/Manifest
app-text/cherrytree/cherrytree-0.39.2.ebuild [new file with mode: 0644]

index 171b610299ab2c73f3763f982ae4f4e2b74f303a..9b9b8ef3fbf474299cf2ebe4e7e92dd7bc311eb4 100644 (file)
@@ -1,2 +1,3 @@
 DIST cherrytree-0.37.0.tar.gz 8888703 BLAKE2B 737c0c247c581086e23e4c3e5fba0b18459788b385078ec8092af8b7352d77c8b273c939f702178d0ae59c8633bf996a7a7e5223e22da703ced3c8bf1d7cbde3 SHA512 a1aaf92657c58c70430a45adaa771050b43476bc2a33dc929b108842d5ef46aa83c4fa4cfe8c4f54a9a3656fc0d30046fae34cbac5aa9fe3f32aa539058636f5
 DIST cherrytree-0.38.9.tar.gz 9928805 BLAKE2B 4de4187ae7e650090d82de5e8b1b7f85c4af6dbb2c9b2bc67f10b074db4c08c4b4593c4769708bfaf584958eefe083a3626f7e9c4d7736bc53d143528c754e09 SHA512 40c1c26fa1a6868b447d31625c14b10cf712185289cf97b71881c253d2f72c58f51b974a1615fca5b532099c4741c56f8419df2d02e4ca821b2a1b909152e56b
+DIST cherrytree-0.39.2.tar.gz 10044337 BLAKE2B 352b6b709e62487015eccf817c4aec799586f64b9e07e38f1eab5e1491b36d8e2ae2f62f55f32248ca1f5cc0c0f610282493de2f3d4cf4e128ecb66acb895668 SHA512 46a02753f02f17e9696e21510ad93222843734a8be271e3a20d7a038856ad99ff2c8316d559e56567e877e419324fe3b254882bb1578a3c8d85c902169cb0e26
diff --git a/app-text/cherrytree/cherrytree-0.39.2.ebuild b/app-text/cherrytree/cherrytree-0.39.2.ebuild
new file mode 100644 (file)
index 0000000..0c4f473
--- /dev/null
@@ -0,0 +1,96 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8} )
+
+inherit autotools desktop python-any-r1 xdg-utils
+
+DESCRIPTION="A hierarchical note taking application"
+HOMEPAGE="https://www.giuspen.com/cherrytree"
+SRC_URI="https://github.com/giuspen/cherrytree/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="nls test"
+
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+       dev-cpp/gtkmm:3.0
+       dev-cpp/gtksourceviewmm:3.0
+       dev-cpp/libxmlpp:2.6
+       dev-cpp/pangomm
+       dev-db/sqlite:3
+       dev-libs/libxml2:2"
+DEPEND="${RDEPEND}"
+BDEPEND="${PYTHON_DEPS}
+       dev-util/intltool
+       virtual/pkgconfig
+       nls? ( sys-devel/gettext )
+       test? ( dev-util/cpputest )"
+
+S="${S}/future"
+
+pkg_setup() {
+       python-any-r1_pkg_setup
+}
+
+src_prepare() {
+       default
+
+       python_fix_shebang "${S}"
+
+       sed -i \
+               -e "s|\(CT_VERSION.*{\)\(.*\)\(};\)$|\1\"${PV}\"\3|" \
+               src/ct/ct_const.cc || die
+
+       if ! use test; then
+               sed -i \
+                       -e '/^PKG_CHECK_MODULES/s|\(\[.*\)cpputest\(.*\]\)|\1\2|' \
+                       configure.ac || die
+       fi
+
+       eautoreconf
+}
+
+src_configure() {
+       econf $(use_enable nls)
+}
+
+src_install() {
+       default
+       pushd ../ >/dev/null || die
+
+       insinto /usr/share/mime/packages
+       doins linux/cherrytree.xml
+
+       insinto /usr/share/mime-info
+       doins linux/cherrytree.{mime,keys}
+
+       insinto /usr/share/metainfo
+       doins linux/cherrytree.appdata.xml
+
+       insinto /usr/share/application-registry
+       doins linux/cherrytree.applications
+
+       doicon -s scalable future/icons/cherrytree.svg
+       domenu linux/cherrytree.desktop
+       doman linux/cherrytree.1
+
+       popd >/dev/null || die
+}
+
+pkg_postinst() {
+       xdg_icon_cache_update
+       xdg_mimeinfo_database_update
+       xdg_desktop_database_update
+}
+
+pkg_postrm() {
+       xdg_icon_cache_update
+       xdg_mimeinfo_database_update
+       xdg_desktop_database_update
+}