net-misc/AQtion: Fix build against a non-running kernel
authorPatrick McLean <patrick.mclean@sony.com>
Mon, 23 Sep 2019 20:44:26 +0000 (13:44 -0700)
committerPatrick McLean <chutzpah@gentoo.org>
Mon, 23 Sep 2019 20:44:26 +0000 (13:44 -0700)
Copyright: Sony Interactive Entertainment Inc.
Package-Manager: Portage-2.3.76, Repoman-2.3.17
Signed-off-by: Patrick McLean <chutzpah@gentoo.org>
net-misc/AQtion/AQtion-2.2.7.ebuild

index 157bb239defbe8341453f70529f522dfda2f8edd..052ff5de6cb2f2821dbca576e051cff22c8fa4df 100644 (file)
@@ -43,7 +43,11 @@ src_prepare() {
        fi
 }
 
+src_compile() {
+       KDIR="${KERNEL_DIR}" linux-mod_src_compile
+}
+
 src_install() {
-       linux-mod_src_install
+       KDIR="${KERNEL_DIR}" linux-mod_src_install
        dodoc "${DOCS[@]}"
 }