dev-python/python-bugzilla: Modernize, py3.8
authorMichał Górny <mgorny@gentoo.org>
Thu, 19 Mar 2020 10:43:40 +0000 (11:43 +0100)
committerMichał Górny <mgorny@gentoo.org>
Thu, 19 Mar 2020 13:25:26 +0000 (14:25 +0100)
Signed-off-by: Michał Górny <mgorny@gentoo.org>
dev-python/python-bugzilla/python-bugzilla-2.1.0.ebuild

index 3ee2bd198d4418362364347b4de2c6f6962339f9..a8ba9b873d82722e3a6affad71382d8a7dc3fccb 100644 (file)
@@ -1,9 +1,9 @@
 # Copyright 1999-2020 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
-EAPI=6
+EAPI=7
 
-PYTHON_COMPAT=( python3_{6,7} )
+PYTHON_COMPAT=( python3_{6,7,8} )
 
 inherit distutils-r1
 
@@ -20,10 +20,5 @@ SLOT="0"
 RDEPEND="
        || ( dev-python/python-magic[${PYTHON_USEDEP}] sys-apps/file[python,${PYTHON_USEDEP}] )
        dev-python/requests[${PYTHON_USEDEP}]"
-DEPEND="${RDEPEND}
-       dev-python/setuptools[${PYTHON_USEDEP}]
-"
 
-python_test() {
-       "${EPYTHON}" ./setup.py test || die "Tests fail with ${EPYTHON}"
-}
+distutils_enable_tests setup.py