dev-java/touchgraph-graphlayout: EAPI 5 bump.
authorPatrice Clement <monsieurp@gentoo.org>
Fri, 2 Oct 2015 23:08:06 +0000 (23:08 +0000)
committerPatrice Clement <monsieurp@gentoo.org>
Fri, 2 Oct 2015 23:12:17 +0000 (23:12 +0000)
Package-Manager: portage-2.2.18
Signed-off-by: Patrice Clement <monsieurp@gentoo.org>
dev-java/touchgraph-graphlayout/touchgraph-graphlayout-1.22-r1.ebuild [new file with mode: 0644]

diff --git a/dev-java/touchgraph-graphlayout/touchgraph-graphlayout-1.22-r1.ebuild b/dev-java/touchgraph-graphlayout/touchgraph-graphlayout-1.22-r1.ebuild
new file mode 100644 (file)
index 0000000..230a7e9
--- /dev/null
@@ -0,0 +1,31 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+JAVA_PKG_IUSE="doc source"
+
+inherit java-pkg-2 java-pkg-simple
+
+MY_PN="TGGraphLayout"
+
+DESCRIPTION="TouchGraph provides a set of interfaces for graph visualization"
+HOMEPAGE="http://touchgraph.sourceforge.net"
+SRC_URI="mirror://sourceforge/touchgraph/TGGL_${PV//./}_jre11.zip"
+LICENSE="Apache-1.1"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE=""
+
+DEPEND=">=virtual/jdk-1.6"
+RDEPEND=">=virtual/jre-1.6"
+
+S="${WORKDIR}/${MY_PN}"
+
+JAVA_SRC_DIR="com"
+
+src_install() {
+       java-pkg-simple_src_install
+       dodoc "TGGL ReleaseNotes.txt"
+}