net-analyzer/echoping: Do not copy ltmain.sh (bug #562230 by Toralf Förster).
authorJeroen Roovers <jer@gentoo.org>
Sun, 4 Oct 2015 18:38:40 +0000 (20:38 +0200)
committerJeroen Roovers <jer@gentoo.org>
Sun, 4 Oct 2015 18:38:57 +0000 (20:38 +0200)
Package-Manager: portage-2.2.22

net-analyzer/echoping/Manifest
net-analyzer/echoping/echoping-6.0.2-r2.ebuild [deleted file]
net-analyzer/echoping/echoping-6.0.2_p434-r1.ebuild
net-analyzer/echoping/echoping-6.0.2_p434.ebuild
net-analyzer/echoping/files/echoping-6.0.2-fix_implicit_declarations.patch [deleted file]
net-analyzer/echoping/files/echoping-6.0.2-gnutls.patch [deleted file]

index a5a95da72e36b22001feae0040294aad63b9faee..25fef687199ce6af9803ceb5c02290caea3310d1 100644 (file)
@@ -1,2 +1 @@
-DIST echoping-6.0.2.tar.gz 1660983 SHA256 1dfa4c45bf461b2379ff91773ed7136176e2abac9e85c26bc9654942b5155eac SHA512 ca9a38c3be9da283e73a7a1b13ab003dca6a2ee317e2961325f3e6803f132ae2f5e4206d946564915c573f21f9c3e9641d61f6b3ae5806bbaa92c2f30f1e5e22 WHIRLPOOL 9140d20d82ed1c38df91d8905fb678c1ca717af518b374c3379db285662d55e70c8da5bb227c4f47a4c34f649c686037636c024a38d1109cd939f6974b274e15
 DIST echoping-6.0.2_p434.tar.gz 74568 SHA256 152a4a9d2a3962fa8cb95eeb29b5d22a7039d4408f5ba22286259856f095baf7 SHA512 1b4f5f1ea6ba000c558cab3b8e86758d6c539d8cd237620000d837b468861a177ac733441c885eb8ec1c35b49baa33a82e34e3f8b14b05429a075b72233d5799 WHIRLPOOL cae10459766311ded4f6459e519461fb91de7dd9429679927c3955a5a9b09b9b9a9706947b3a5c1495805367c91cf2035d3154a3ff180241782deec304eb8aaf
diff --git a/net-analyzer/echoping/echoping-6.0.2-r2.ebuild b/net-analyzer/echoping/echoping-6.0.2-r2.ebuild
deleted file mode 100644 (file)
index 58c1021..0000000
+++ /dev/null
@@ -1,60 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI="4"
-
-inherit eutils autotools
-
-DESCRIPTION="Small program to test performances of remote servers"
-HOMEPAGE="http://echoping.sourceforge.net/"
-SRC_URI="mirror://sourceforge/echoping/${P}.tar.gz"
-LICENSE="GPL-2"
-
-SLOT="0"
-KEYWORDS="amd64 ~hppa x86"
-IUSE="gnutls http icp idn priority smtp ssl tos postgres ldap"
-RESTRICT="test"
-
-RDEPEND="idn? ( net-dns/libidn )
-       postgres? ( dev-db/postgresql )
-       ldap? ( net-nds/openldap )
-       ssl? (
-               gnutls? ( >=net-libs/gnutls-1.0.17 )
-               !gnutls? ( >=dev-libs/openssl-0.9.7d )
-       )"
-DEPEND="${RDEPEND}
-       >=sys-devel/libtool-2"
-
-REQUIRED_USE="gnutls? ( ssl )"
-
-DOCS=( README AUTHORS ChangeLog DETAILS NEWS TODO )
-
-src_prepare() {
-       # bug 279525:
-       epatch "${FILESDIR}/${P}-gnutls.patch"
-
-       epatch "${FILESDIR}/${P}-fix_implicit_declarations.patch"
-
-       rm -f ltmain.sh
-       cp /usr/share/libtool/config/ltmain.sh .
-       local i
-       for i in . plugins/ plugins/*/; do
-               pushd "${i}" > /dev/null
-               eautoreconf
-               popd > /dev/null
-       done
-}
-
-src_configure() {
-       econf \
-               --config-cache \
-               --disable-ttcp \
-               $(use_enable http)  \
-               $(use_enable icp) \
-               $(use_with idn libidn) \
-               $(use_enable smtp) \
-               $(use_enable tos) \
-               $(use_enable priority) \
-               $(usex gnutls $(use_with gnutls) $(use_with ssl))
-}
index f96eb281badf19d50070eac4b1106ab115c5b802..f0c6bf4d1c70e217431cf168a03be0ae157df3d5 100644 (file)
@@ -32,7 +32,6 @@ DOCS=( README AUTHORS ChangeLog DETAILS NEWS TODO )
 src_prepare() {
        epatch "${FILESDIR}"/${PN}-6.0.2_p434-fix_implicit_declarations.patch
 
-       cp /usr/share/libtool/config/ltmain.sh .
        eautoreconf
 }
 
index 5a5cb1b8e203b69d97d5265b014d4da0df384cf3..4245e74c127b6140236222da6cde97d486562985 100644 (file)
@@ -32,7 +32,6 @@ DOCS=( README AUTHORS ChangeLog DETAILS NEWS TODO )
 src_prepare() {
        epatch "${FILESDIR}"/${PN}-6.0.2_p434-fix_implicit_declarations.patch
 
-       cp /usr/share/libtool/config/ltmain.sh .
        eautoreconf
 }
 
diff --git a/net-analyzer/echoping/files/echoping-6.0.2-fix_implicit_declarations.patch b/net-analyzer/echoping/files/echoping-6.0.2-fix_implicit_declarations.patch
deleted file mode 100644 (file)
index 1b0bce8..0000000
+++ /dev/null
@@ -1,20 +0,0 @@
---- echoping.h
-+++ echoping.h 2009-09-15 00:55:43.000000000 +0200
-@@ -198,6 +198,7 @@
- #endif
- /* util.c */
- char *random_string ();
-+char *to_upper();
- void tvsub ();
- void tvadd ();
- void tvavg ();
---- plugins/ldap/ldap.c
-+++ plugins/ldap/ldap.c
-@@ -9,6 +9,7 @@
- #include "../../config.h"
- #include "config.h"
- #endif
-+#define LDAP_DEPRECATED 1
- #include <ldap.h>
- const char     *request = NULL;
diff --git a/net-analyzer/echoping/files/echoping-6.0.2-gnutls.patch b/net-analyzer/echoping/files/echoping-6.0.2-gnutls.patch
deleted file mode 100644 (file)
index b5be2d9..0000000
+++ /dev/null
@@ -1,41 +0,0 @@
-Date: 2009-06-30 14:26
-Sender: bortz 
-
-The patch by ametzler seems indeed to work (thanks to him). I've committed
-it (r426) and will make a new release soon.
-
-http://sourceforge.net/tracker/index.php?func=detail&aid=2811861&group_id=4581&atid=104581
-
-
---- trunk/SRC/configure.ac     2009/06/30 14:18:15     425
-+++ trunk/SRC/configure.ac     2009/06/30 14:19:07     426
-@@ -92,14 +92,21 @@
- AC_ARG_WITH(gnutls,
-  [  --with-gnutls[=DIR]   SSL/TLS crypt support (needs GNU TLS), the argument DIR should not be necessary],dnl
-  [if test "$withval" != "no"; then
--   AC_DEFINE(GNUTLS,,[Crypto (TLS) support])
--   GNUTLS=1
--   CPPFLAGS="${CPPFLAGS} `libgnutls-config --cflags`"
--   LDFLAGS="${LDFLAGS} `libgnutls-config --libs`"
--   if test "$withval" != "yes"; then
--      GNUTLSROOT=$withval
--      LDFLAGS="${LDFLAGS} -L$GNUTLSROOT/lib"
--        CPPFLAGS="${CPPFLAGS} -I$GNUTLSROOT/include"  
-+  if test "$withval" = "yes"; then
-+      PKG_CHECK_MODULES([LIBGNUTLS], [gnutls >= 1.0.0],
-+      [
-+      echo "GnuTLS found"
-+      AC_DEFINE(GNUTLS,,[Crypto (TLS) support])
-+      GNUTLS=1
-+      CFLAGS="$CFLAGS $LIBGNUTLS_CFLAGS"
-+      LIBS="$LIBS $LIBGNUTLS_LIBS"
-+      ],)
-+      else
-+      AC_DEFINE(GNUTLS,,[Crypto (TLS) support])
-+      GNUTLS=1
-+      GNUTLSROOT=$withval
-+      LDFLAGS="${LDFLAGS} -L$GNUTLSROOT/lib -lgnutls"
-+      CPPFLAGS="${CPPFLAGS} -I$GNUTLSROOT/include"
-    fi
-  fi],
-  dnl Default: disable it