x11-libs/libnotify: Bump to version 0.7.8
authorLars Wendler <polynomial-c@gentoo.org>
Mon, 15 Apr 2019 21:18:43 +0000 (23:18 +0200)
committerLars Wendler <polynomial-c@gentoo.org>
Mon, 15 Apr 2019 21:18:57 +0000 (23:18 +0200)
Package-Manager: Portage-2.3.62, Repoman-2.3.12
Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
x11-libs/libnotify/Manifest
x11-libs/libnotify/libnotify-0.7.8.ebuild [new file with mode: 0644]

index 4e7791ed538d0fc754b51b7fb8f6b47d58215e89..9efb114369cb892464fd7b39ea0f1f2f2207c650 100644 (file)
@@ -1 +1,2 @@
 DIST libnotify-0.7.7.tar.xz 285356 BLAKE2B ace0eedb1beecfbb89726960e441821d64f5ac456dfc6294b051479078726aed6fbacbd1e8cb17578933adbc4c94711b0d69a292778ba4bce096552a5197722b SHA512 133874114407bf12267ef609f5941657181760bc7cf115c5973b1810cb72bf55072b621c143e32be1e7e8b49f244851925d14bc3f9f26457747b8a8695ee9954
+DIST libnotify-0.7.8.tar.xz 108436 BLAKE2B 0a73eabe58faca55e16774cda6f649ab3187bd73a1f87b538d5098f390571a6a34078883dbd2447731d6e4cae315d8286e9e8acc06e85590c8b05a693a83e7f7 SHA512 9973d7a1af5dd7cfbaa0d0d2c9e72a40df9d814967fde47e95763a69690cc4ed32ecf713d75f91f3dff99a693eff9dab963be124e0530ebf231d517a44e75e94
diff --git a/x11-libs/libnotify/libnotify-0.7.8.ebuild b/x11-libs/libnotify/libnotify-0.7.8.ebuild
new file mode 100644 (file)
index 0000000..ff9add8
--- /dev/null
@@ -0,0 +1,58 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit gnome.org meson multilib-minimal xdg-utils
+
+DESCRIPTION="A library for sending desktop notifications"
+HOMEPAGE="https://gitlab.gnome.org/GNOME/libnotify"
+
+LICENSE="LGPL-2.1+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~x86-solaris"
+IUSE="+introspection test"
+
+RDEPEND="
+       app-eselect/eselect-notify-send
+       >=dev-libs/glib-2.26:2[${MULTILIB_USEDEP}]
+       x11-libs/gdk-pixbuf:2[${MULTILIB_USEDEP}]
+       introspection? ( >=dev-libs/gobject-introspection-1.32:= )
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+       >=dev-libs/gobject-introspection-common-1.32
+       dev-util/glib-utils
+       virtual/pkgconfig
+       test? ( x11-libs/gtk+:3[${MULTILIB_USEDEP}] )
+"
+PDEPEND="virtual/notification-daemon"
+
+src_prepare() {
+       default
+       xdg_environment_reset
+}
+
+multilib_src_configure() {
+       local emesonargs=(
+               -Dtests="$(usex test true false)"
+               -Dintrospection="$(multilib_native_usex introspection enabled disabled)"
+               -Dgtk_doc=false
+               -Ddocbook_docs=disabled
+       )
+       meson_src_configure
+}
+
+multilib_src_install() {
+       meson_src_install
+
+       mv "${ED}"/usr/bin/{,libnotify-}notify-send || die #379941
+}
+
+pkg_postinst() {
+       eselect notify-send update ifunset
+}
+
+pkg_postrm() {
+       eselect notify-send update ifunset
+}