app-text/gspell: Version bump to 1.8.2
authorMatt Turner <mattst88@gentoo.org>
Fri, 20 Sep 2019 05:45:01 +0000 (22:45 -0700)
committerMatt Turner <mattst88@gentoo.org>
Mon, 21 Oct 2019 19:51:03 +0000 (12:51 -0700)
* sys-devel/gettext dependency raised to 0.19.6

Signed-off-by: Matt Turner <mattst88@gentoo.org>
app-text/gspell/Manifest
app-text/gspell/gspell-1.8.2.ebuild [new file with mode: 0644]

index e517025f3b5d0085e53a9484db0d317f8be62df3..24f1d62f054683015d0762689dbda4208dac41ee 100644 (file)
@@ -1,2 +1,3 @@
 DIST gspell-1.6.1.tar.xz 416704 BLAKE2B 2a180bc52d3f09813d8de362e5bf900f831663c09530c8a9b993baf55f852a3939447a71c9c9dc0caafba7e8b74a2a5aad4443cf248eb87da4e15e0481e74262 SHA512 f1ffbd0d23d9743bcf924c25b3a3d7bf93c6a5e4ea5e362fb7300f657d8c1d0117e847f3dec29de377947f850e003b24a3231e88e99b313c955dd94ce358c23e
 DIST gspell-1.8.1.tar.xz 419268 BLAKE2B f32c9c518c23f8f560d65eb6fb122703561cc09e385eefa99d0761e8aa5b5bf3a8cec3cab7071043134314262979de56d08ee2929973b7968016b123e53d8f16 SHA512 ae94f46c7bdcdeefa0279cd4ac3c50e53b63092016e298ef6b502c40c2574a2135c503ab322f5a3a7b8b4422fdec291a6ed0c937683a8c0f32d7ad474cc1569b
+DIST gspell-1.8.2.tar.xz 421936 BLAKE2B 5fdff772e716c1f062002d7371064dbbaf6eb43e77cef03b8fca7ea71a91eac82ca54a5463c0f785153a15ceb65ad06aeecc069196765cb78e5dfaff5d81fec6 SHA512 220bdec2b8229e848960e5e31bda1209dedac232637d3e6d4931ca2552054fbdf3f576d52f3d5a7ac734e6e626f2fcc7cefd0bff906b29ba9930cef791906c32
diff --git a/app-text/gspell/gspell-1.8.2.ebuild b/app-text/gspell/gspell-1.8.2.ebuild
new file mode 100644 (file)
index 0000000..19aaa90
--- /dev/null
@@ -0,0 +1,48 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+VALA_USE_DEPEND="vapigen"
+
+inherit gnome2 vala virtualx
+
+DESCRIPTION="Spell check library for GTK+ applications"
+HOMEPAGE="https://wiki.gnome.org/Projects/gspell"
+
+LICENSE="LGPL-2.1+"
+SLOT="0/1" # subslot = libgspell-1 soname version
+KEYWORDS="~alpha ~amd64 ~arm ~ppc ~ppc64 ~sparc ~x86 ~amd64-fbsd"
+
+IUSE="+introspection vala"
+REQUIRED_USE="vala? ( introspection )"
+
+RDEPEND="
+       app-text/iso-codes
+       >=app-text/enchant-2.1.3
+       >=dev-libs/glib-2.44:2
+       >=x11-libs/gtk+-3.20:3[introspection?]
+       introspection? ( >=dev-libs/gobject-introspection-1.42.0:= )
+       vala? ( $(vala_depend) )
+"
+DEPEND="${RDEPEND}
+       dev-libs/libxml2:2
+       dev-util/glib-utils
+       >=dev-util/gtk-doc-am-1.25
+       >=sys-devel/gettext-0.19.6
+       virtual/pkgconfig
+"
+
+src_prepare() {
+       use vala && vala_src_prepare
+       gnome2_src_prepare
+}
+
+src_configure() {
+       gnome2_src_configure \
+               $(use_enable introspection) \
+               $(use_enable vala)
+}
+
+src_test() {
+       virtx emake check
+}