dev-perl/DBD-MariaDB: Minor improvements in configure
authorKent Fredric <kentnl@gentoo.org>
Wed, 10 Jul 2019 14:07:49 +0000 (02:07 +1200)
committerKent Fredric <kentnl@gentoo.org>
Wed, 10 Jul 2019 14:07:49 +0000 (02:07 +1200)
- Simplify handling provider for backend
- Auto-chomp EROOT for future compat with EAPI7

Package-Manager: Portage-2.3.66, Repoman-2.3.16
Signed-off-by: Kent Fredric <kentnl@gentoo.org>
dev-perl/DBD-MariaDB/DBD-MariaDB-1.210.0.ebuild

index f87dcb390c34e20a166fe77d59463a95f3f59ae5..c9433204e7dc9afd41aa85dbb7fd3a075de55660 100644 (file)
@@ -47,19 +47,15 @@ PERL_RM_FILES=(
 )
 
 src_configure() {
-
+       local impl
+       impl=$(usex mariadb mariadb mysql)
        if use test; then
                myconf="${myconf} --testdb=test \
                        --testhost=localhost \
                        --testuser=test \
                        --testpassword=test"
        fi
-       if use mysql; then
-               myconf+=" --mysql_config=${EROOT}usr/bin/mysql_config"
-       fi
-       if use mariadb; then
-               myconf+=" --mariadb_config=${EROOT}usr/bin/mariadb_config"
-       fi
+       myconf+=" --${impl}_config=${EROOT%/}/usr/bin/${impl}_config"
        perl-module_src_configure
 }