x11-misc/vdpauinfo: Version 1.4
authorJeroen Roovers <jer@gentoo.org>
Wed, 15 Apr 2020 07:29:08 +0000 (09:29 +0200)
committerJeroen Roovers <jer@gentoo.org>
Wed, 15 Apr 2020 07:34:12 +0000 (09:34 +0200)
Package-Manager: Portage-2.3.99, Repoman-2.3.22
Signed-off-by: Jeroen Roovers <jer@gentoo.org>
x11-misc/vdpauinfo/Manifest
x11-misc/vdpauinfo/vdpauinfo-1.4.ebuild [new file with mode: 0644]
x11-misc/vdpauinfo/vdpauinfo-99999.ebuild

index 0f195167723e309cc06d98c08f117942089a39e5..49412210ea630d52b97ec9d20317ea635e26e58c 100644 (file)
@@ -1 +1,2 @@
 DIST vdpauinfo-1.3.tar.gz 12159 BLAKE2B 41dc31ef2f45272221e2eea969d7801cc9c8bfd693e64f7d157b17645da654b7f50d780df698736b3e2ea9c55c7d3b6e7ce75f96aacd50bbaa4032dfc753a43f SHA512 2271053c17d389ea600742ffe14e863921f18e504e07cb5db33c98745d2f71aece908408bca0161b3c2fa9cd67de8c741c132a774a4fd9443c7124168a4da79f
+DIST vdpauinfo-1.4.tar.bz2 11811 BLAKE2B bf0c268505b8eafb9da7c799518296498f2c04bde33443101625c4a80cfde6418428d3969e9ac0f4222a6985b53f3bd4dff688fc03af29de7576f3af3605e07c SHA512 7227205f35d5ad9bc64537d4e47e1924e7efbcd1185420f5f575eadff23f2932484db9c39c377282ed88fa7fd43d436064b10961082ccbf66c49dac72b4129a3
diff --git a/x11-misc/vdpauinfo/vdpauinfo-1.4.ebuild b/x11-misc/vdpauinfo/vdpauinfo-1.4.ebuild
new file mode 100644 (file)
index 0000000..39610aa
--- /dev/null
@@ -0,0 +1,28 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit autotools
+
+DESCRIPTION="Displays info about your card's VDPAU support"
+HOMEPAGE="https://www.freedesktop.org/wiki/Software/VDPAU"
+SRC_URI="https://gitlab.freedesktop.org/vdpau/${PN}/-/archive/${PV}/${P}.tar.bz2"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+       >=x11-libs/libvdpau-1.4
+       x11-libs/libX11
+"
+DEPEND="
+       ${RDEPEND}
+       virtual/pkgconfig
+       x11-base/xorg-proto
+"
+
+src_prepare() {
+       default
+       eautoreconf
+}
index 7f4ca7b3d7bb5c9682e8cb81a2c4c146e7f774e4..1c399e6d20577879182f0ccb46a3f7f0cebd37f4 100644 (file)
@@ -13,8 +13,8 @@ SLOT="0"
 KEYWORDS=""
 
 RDEPEND="
+       >=x11-libs/libvdpau-1.4
        x11-libs/libX11
-       >=x11-libs/libvdpau-1.3
 "
 DEPEND="
        ${RDEPEND}