Fix for segv bug #148094 thanks to Sergio Rubio for needed patch
authorMarkus Ullmann <jokey@gentoo.org>
Tue, 10 Oct 2006 13:20:22 +0000 (13:20 +0000)
committerMarkus Ullmann <jokey@gentoo.org>
Tue, 10 Oct 2006 13:20:22 +0000 (13:20 +0000)
Package-Manager: portage-2.1.2_pre2-r6

net-analyzer/packit/ChangeLog
net-analyzer/packit/files/digest-packit-1.0-r1 [new file with mode: 0644]
net-analyzer/packit/files/packit-1.0-noopt.patch [new file with mode: 0644]
net-analyzer/packit/files/packit-1.0-nostrip.patch [new file with mode: 0644]
net-analyzer/packit/packit-1.0-r1.ebuild [new file with mode: 0644]

index 5401e96731acb841585042a45a43a5648995931a..8fbb738d13a42667a065ef54be6a27ce6b674f6b 100644 (file)
@@ -1,6 +1,13 @@
 # ChangeLog for net-analyzer/packit
 # Copyright 2000-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/packit/ChangeLog,v 1.20 2006/02/15 23:45:21 jokey Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/packit/ChangeLog,v 1.21 2006/10/10 13:20:22 jokey Exp $
+
+*packit-1.0-r1 (10 Oct 2006)
+
+  10 Oct 2006; Markus Ullmann <jokey@gentoo.org>
+  +files/packit-1.0-noopt.patch, +files/packit-1.0-nostrip.patch,
+  -packit-1.0.ebuild, +packit-1.0-r1.ebuild:
+  Fix for segv bug #148094 thanks to Sergio Rubio for needed patch
 
   15 Feb 2006; Markus Ullmann <jokey@gentoo.org> packit-1.0.ebuild:
   Removing virtual/libpcap wrt bug #117898
diff --git a/net-analyzer/packit/files/digest-packit-1.0-r1 b/net-analyzer/packit/files/digest-packit-1.0-r1
new file mode 100644 (file)
index 0000000..9bfab63
--- /dev/null
@@ -0,0 +1,3 @@
+MD5 270594ff97f6c203131136208bb4d2ca packit-1.0.tgz 138367
+RMD160 02b2ec56ccac5f8d755c0d84f1360b1cea698fce packit-1.0.tgz 138367
+SHA256 dd03023a03b3c98819f4da5c23426d103ed3f457562e2afda2eb3ebc419ad8fa packit-1.0.tgz 138367
diff --git a/net-analyzer/packit/files/packit-1.0-noopt.patch b/net-analyzer/packit/files/packit-1.0-noopt.patch
new file mode 100644 (file)
index 0000000..0c28881
--- /dev/null
@@ -0,0 +1,11 @@
+diff -uNr packit-1.0.orig/src/main.c packit-1.0/src/main.c
+--- packit-1.0.orig/src/main.c 2003-11-29 17:55:20.000000000 +0100
++++ packit-1.0/src/main.c      2006-09-22 02:02:21.000000000 +0200
+@@ -201,6 +201,7 @@
+ #ifdef DEBUG
+     fprintf(stdout, "DEBUG: parse_inject\n");
+ #endif
++    if (!opts) print_usage();
+     while((opt = getopt(argc, argv, opts)) != -1)
+     {
diff --git a/net-analyzer/packit/files/packit-1.0-nostrip.patch b/net-analyzer/packit/files/packit-1.0-nostrip.patch
new file mode 100644 (file)
index 0000000..bbf3ad1
--- /dev/null
@@ -0,0 +1,10 @@
+--- ./src/Makefile.in.orig     2006-10-10 15:16:03.000000000 +0200
++++ ./src/Makefile.in  2006-10-10 15:17:22.000000000 +0200
+@@ -450,7 +450,6 @@
+ all:
+-      strip @BINS@
+       cp @BINS@ $(top_srcdir)
+ clean:
diff --git a/net-analyzer/packit/packit-1.0-r1.ebuild b/net-analyzer/packit/packit-1.0-r1.ebuild
new file mode 100644 (file)
index 0000000..845d1f1
--- /dev/null
@@ -0,0 +1,30 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/packit/packit-1.0-r1.ebuild,v 1.1 2006/10/10 13:20:22 jokey Exp $
+
+inherit eutils
+
+DESCRIPTION="network auditing tool that allows you to monitor, manipulate, and inject customized IPv4 traffic"
+HOMEPAGE="http://www.packetfactory.net/projects/packit/"
+SRC_URI="http://www.packetfactory.net/projects/packit/downloads/${P}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc-macos x86"
+IUSE=""
+
+DEPEND=">=net-libs/libnet-1.1.2
+       net-libs/libpcap"
+
+src_unpack(){
+       unpack ${A}
+       cd "${S}"
+       sed -i 's:net/bpf.h:pcap-bpf.h:g' "${S}"/src/{globals.h,main.h}
+       epatch "${FILESDIR}/packit-1.0-noopt.patch"
+       epatch "${FILESDIR}/packit-1.0-nostrip.patch"
+}
+
+src_install() {
+       emake DESTDIR="${D}" install || die
+       dodoc VERSION docs/*
+}