dev-haskell/tasty: tweak against unbounded-delays-0.1.1.0
authorSergei Trofimovich <slyfox@gentoo.org>
Sun, 15 Dec 2019 12:30:04 +0000 (12:30 +0000)
committerSergei Trofimovich <slyfox@gentoo.org>
Sun, 15 Dec 2019 12:50:17 +0000 (12:50 +0000)
The patch fixes the following build failure:

```
Test/Tasty/Run.hs:80:6: error:
    Ambiguous occurrence ‘Timeout’
    It could refer to either ‘Control.Concurrent.Timeout.Timeout’,
                             imported from ‘Control.Concurrent.Timeout’ at Test/Tasty/Run.hs:18:1-33
                          or ‘Test.Tasty.Options.Core.Timeout’,
                             imported from ‘Test.Tasty.Options.Core’ at Test/Tasty/Run.hs:29:1-30
                             (and originally defined
                                at Test/Tasty/Options/Core.hs:(54,1)-(60,27))
```

Reported-by: Toralf Förster
Closes: https://bugs.gentoo.org/702906
Package-Manager: Portage-2.3.81, Repoman-2.3.20
Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
dev-haskell/tasty/files/tasty-0.11.0.4-unbounded-delays.patch [new file with mode: 0644]
dev-haskell/tasty/tasty-0.11.0.4.ebuild

diff --git a/dev-haskell/tasty/files/tasty-0.11.0.4-unbounded-delays.patch b/dev-haskell/tasty/files/tasty-0.11.0.4-unbounded-delays.patch
new file mode 100644 (file)
index 0000000..ad265fd
--- /dev/null
@@ -0,0 +1,26 @@
+https://bugs.gentoo.org/702906
+
+From 74e87fff6a4a830dc64d59f4baa1a5f6759c007c Mon Sep 17 00:00:00 2001
+From: Roman Cheplyaka <roma@ro-che.info>
+Date: Fri, 5 May 2017 08:54:28 +0300
+Subject: [PATCH] Fix compatibility with the latest unbounded-delays
+
+Fixes #166
+---
+ core/Test/Tasty/Run.hs | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+--- a/Test/Tasty/Run.hs
++++ b/Test/Tasty/Run.hs
+@@ -15,7 +15,7 @@ import Control.Monad.State
+ import Control.Monad.Writer
+ import Control.Monad.Reader
+ import Control.Concurrent.STM
+-import Control.Concurrent.Timeout
++import Control.Concurrent.Timeout (timeout)
+ import Control.Concurrent.Async
+ import Control.Exception as E
+ import Control.Applicative
+-- 
+2.24.1
+
index 9c138e80dd26b29a84741b00e92e432f559125d1..4de53058744cdff275d53d130f3d41f86f800bb3 100644 (file)
@@ -17,6 +17,8 @@ SLOT="0/${PV}"
 KEYWORDS="amd64 x86"
 IUSE=""
 
+PATCHES=("${FILESDIR}"/${P}-unbounded-delays.patch)
+
 RDEPEND=">=dev-haskell/ansi-terminal-0.6.2:=[profile?]
        >=dev-haskell/async-2.0:=[profile?]
        >=dev-haskell/clock-0.4.4.0:=[profile?]