app-arch/bzip2: Fix soname of library in 1.0.7 and 1.0.8.
authorArfrever Frehtes Taifersar Arahesis <Arfrever@Apache.Org>
Sat, 11 Apr 2020 07:35:36 +0000 (07:35 +0000)
committerLars Wendler <polynomial-c@gentoo.org>
Sat, 11 Apr 2020 11:08:36 +0000 (13:08 +0200)
Change soname of library from "libbz2.so.1.0" to "libbz2.so.1".
Soname "libbz2.so.1" is also used by previous version (1.0.6) and by
new build systems (both Meson and CMake) available in next version.

Closes: https://bugs.gentoo.org/695178
Signed-off-by: Arfrever Frehtes Taifersar Arahesis <Arfrever@Apache.Org>
Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
app-arch/bzip2/bzip2-1.0.7-r1.ebuild [moved from app-arch/bzip2/bzip2-1.0.7.ebuild with 100% similarity]
app-arch/bzip2/bzip2-1.0.8-r1.ebuild [moved from app-arch/bzip2/bzip2-1.0.8.ebuild with 100% similarity]
app-arch/bzip2/files/bzip2-1.0.7-out-of-tree-build.patch
app-arch/bzip2/files/bzip2-1.0.7-saneso.patch
app-arch/bzip2/files/bzip2-1.0.8-out-of-tree-build.patch
app-arch/bzip2/files/bzip2-1.0.8-saneso.patch

index 977d9b3cd3091b71cf0fcbb1bf3e7cefb6269a08..64cca58eac348cfd514a02a097028d1c8b6dfb2b 100644 (file)
@@ -49,7 +49,7 @@
 @@ -36,24 +36,10 @@
  
  all: $(OBJS)
-       $(CC) $(LDFLAGS) -shared -Wl,-soname -Wl,libbz2.so.1.0 -o libbz2.so.1.0.7 $(OBJS)
+       $(CC) $(LDFLAGS) -shared -Wl,-soname -Wl,libbz2.so.1 -o libbz2.so.1.0.7 $(OBJS)
 -      $(CC) $(LDFLAGS) $(CFLAGS) -o bzip2-shared bzip2.c libbz2.so.1.0.7
 -      rm -f libbz2.so.1.0
 -      ln -s libbz2.so.1.0.7 libbz2.so.1.0
index 5ab0cb52d050c436d6423091acb1a5c43934455b..d63226684f6674fd9e9f929c3c33afc4980ee538 100644 (file)
@@ -6,7 +6,7 @@
  all: $(OBJS)
 -      $(CC) -shared -Wl,-soname -Wl,libbz2.so.1.0 -o libbz2.so.1.0.7 $(OBJS)
 -      $(CC) $(CFLAGS) -o bzip2-shared bzip2.c libbz2.so.1.0.7
-+      $(CC) $(LDFLAGS) -shared -Wl,-soname -Wl,libbz2.so.1.0 -o libbz2.so.1.0.7 $(OBJS)
++      $(CC) $(LDFLAGS) -shared -Wl,-soname -Wl,libbz2.so.1 -o libbz2.so.1.0.7 $(OBJS)
 +      $(CC) $(LDFLAGS) $(CFLAGS) -o bzip2-shared bzip2.c libbz2.so.1.0.7
        rm -f libbz2.so.1.0
        ln -s libbz2.so.1.0.7 libbz2.so.1.0
index 4a641fdb2e815990ac1021538a1143a0971d308a..04818265b7e29573ba16ae1292df23cdc560c71d 100644 (file)
@@ -49,7 +49,7 @@
 @@ -36,24 +36,10 @@
  
  all: $(OBJS)
-       $(CC) $(LDFLAGS) -shared -Wl,-soname -Wl,libbz2.so.1.0 -o libbz2.so.1.0.8 $(OBJS)
+       $(CC) $(LDFLAGS) -shared -Wl,-soname -Wl,libbz2.so.1 -o libbz2.so.1.0.8 $(OBJS)
 -      $(CC) $(LDFLAGS) $(CFLAGS) -o bzip2-shared bzip2.c libbz2.so.1.0.8
 -      rm -f libbz2.so.1.0
 -      ln -s libbz2.so.1.0.8 libbz2.so.1.0
index 08430831baad97eb706d806a957c7d37a95fa383..63409f5a8576aa3d27d2bf6c3cc480212688b97e 100644 (file)
@@ -6,7 +6,7 @@
  all: $(OBJS)
 -      $(CC) -shared -Wl,-soname -Wl,libbz2.so.1.0 -o libbz2.so.1.0.8 $(OBJS)
 -      $(CC) $(CFLAGS) -o bzip2-shared bzip2.c libbz2.so.1.0.8
-+      $(CC) $(LDFLAGS) -shared -Wl,-soname -Wl,libbz2.so.1.0 -o libbz2.so.1.0.8 $(OBJS)
++      $(CC) $(LDFLAGS) -shared -Wl,-soname -Wl,libbz2.so.1 -o libbz2.so.1.0.8 $(OBJS)
 +      $(CC) $(LDFLAGS) $(CFLAGS) -o bzip2-shared bzip2.c libbz2.so.1.0.8
        rm -f libbz2.so.1.0
        ln -s libbz2.so.1.0.8 libbz2.so.1.0