dev-lang/python: Redo patchset for 3.7.6
authorMichał Górny <mgorny@gentoo.org>
Sun, 29 Dec 2019 09:31:27 +0000 (10:31 +0100)
committerMichał Górny <mgorny@gentoo.org>
Sun, 29 Dec 2019 10:11:03 +0000 (11:11 +0100)
Rebase patches against v3.7.6 and move hashlib patch inside.

Signed-off-by: Michał Górny <mgorny@gentoo.org>
dev-lang/python/Manifest
dev-lang/python/python-3.7.6.ebuild

index be892a24b966b15b1d048b5e93236245c3efd977..7165b0d55c12fa71631bb8b817c90a44cc4c270c 100644 (file)
@@ -12,4 +12,5 @@ DIST python-gentoo-patches-2.7.17.tar.xz 13476 BLAKE2B 788688e2941d2d6d4f7681688
 DIST python-gentoo-patches-3.5.4-0.tar.xz 11704 BLAKE2B 4a7d71feff18c7c8c109bed10748348484d314183c3de3ec950d5ca5ce7048bb322c470f3f5bff2d63eb7f2ed99c0fe75c621df050273d9d118681b28926061d SHA512 d395a87695f700598026038d6929ea5038abd7d494294037a4dfa02d5262203dbbaa6ae258a5a7f35ff5542f6266dcf69cc0b9c3df2a047cd2f6699a87e182ec
 DIST python-gentoo-patches-3.6.8.tar.xz 11224 BLAKE2B 5fe38282bcf28df18e0bd37756c880ae191ea738dc92f1cf83f682cfdc52525b9c44287dc99191a73d75c90672ab501b56adf49515b35ff1fdee88c8dc07b175 SHA512 89e700663db25d6d78eee1d4bfdab686c5341a794062f3a63df3485ac0b58deb4b4885d24701f3ae138d06ca783be92e310e1100c6d633910c33732f3cb0d7df
 DIST python-gentoo-patches-3.7.4-1.tar.xz 10100 BLAKE2B 63e8fada89b64b59ba083745626a1e8a07bec0cf93b7b6ab405c33a0f2932cbe497a331c52895a07f10434b230c438f27c9582efecdd57f3bad15d9aa604d157 SHA512 11b0e811a9890a1235c85426061b35f9964eba64cac0536f4c9e0498b1cc66eb005f14aed34eead735b43e91c2b5babced60e3310f5329231a1706871b95b547
+DIST python-gentoo-patches-3.7.6.tar.xz 10084 BLAKE2B 220869e85bdaf9c21b1b05e13803bdb6ecc22ac0f69da77e57fd7c1cd93ef45ec43401b62732842e1bb3467feb6d65c8204120e2741e9eb6f4cab673fd3a8d62 SHA512 4c04b0cf7da55fa7973ab178e3ac2c59bc2142924bdced5954c058053280b6c663d7c39912286d10fe0e82ca30af6a0dd6a56fa85433f836217ca3dcbb284def
 DIST python-gentoo-patches-3.8.1.tar.xz 10148 BLAKE2B d0674de768611405120bcd2e80a553d9a3325e5dc8360eee3223f89acc97a9aff6260d2610ae16a85777463f5987d93cf3428d42adcdd46867eeaa67471e9941 SHA512 bc38012821c9773cc0821d9ef7dcb8170e97fe87161c8c99b7500323e6f1c6c224d11152ff394bea5af42bb879ef18e1b89d6a16e9ab06a2c3512b5e2381cb08
index 26ce7fb0b0513ac54e2ec1b80ff316b8e10d480b..df19e80b7cb0471d4c644edf694c4b761d7c8267 100644 (file)
@@ -8,12 +8,12 @@ inherit autotools flag-o-matic pax-utils python-utils-r1 toolchain-funcs
 
 MY_P="Python-${PV}"
 PYVER=$(ver_cut 1-2)
-PATCHSET_VERSION="3.7.4-1"
+PATCHSET="python-gentoo-patches-3.7.6"
 
 DESCRIPTION="An interpreted, interactive, object-oriented programming language"
 HOMEPAGE="https://www.python.org/"
 SRC_URI="https://www.python.org/ftp/python/${PV}/${MY_P}.tar.xz
-       https://dev.gentoo.org/~floppym/python/python-gentoo-patches-${PATCHSET_VERSION}.tar.xz"
+       https://dev.gentoo.org/~mgorny/dist/python/${PATCHSET}.tar.xz"
 S="${WORKDIR}/${MY_P}"
 
 LICENSE="PSF-2"
@@ -64,8 +64,7 @@ src_prepare() {
        rm -fr Modules/zlib || die
 
        local PATCHES=(
-               "${FILESDIR}/python-3.7.5-hashlib.patch"
-               "${WORKDIR}/patches"
+               "${WORKDIR}/${PATCHSET}"
        )
 
        default