sys-apps/help2man: Bump to version 1.47.13
authorLars Wendler <polynomial-c@gentoo.org>
Sun, 15 Mar 2020 20:18:27 +0000 (21:18 +0100)
committerLars Wendler <polynomial-c@gentoo.org>
Mon, 16 Mar 2020 07:30:40 +0000 (08:30 +0100)
Package-Manager: Portage-2.3.94, Repoman-2.3.21
Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
sys-apps/help2man/Manifest
sys-apps/help2man/help2man-1.47.13.ebuild [new file with mode: 0644]

index 2d74e1e0dfb872641f5e2425c2e311f5f07d2b49..b240d59e4a8d600cbf94e1ec96eb64a20669a012 100644 (file)
@@ -1,3 +1,4 @@
 DIST help2man-1.47.10.tar.xz 202176 BLAKE2B 57c19072b1fb696b8ae1fc269d4c44672e692b45f1afe91871621dbed008298154d94813711b8ab89a9ad2e9fffa5ba1e738a613e5e50681b0abea4bfcc92677 SHA512 071383f38fb5264137200439a460e70298fc23d88069a96f150bf50a4e2a08d1d5d29555053b0ea36c809eec8484c4432b55d7d0bddd68f33b07b1abb97556ff
 DIST help2man-1.47.11.tar.xz 202312 BLAKE2B 6baba7fb28f2b28aba8a05eb5df0a8596918767cf43d730052e0bae9293a4a27f207136c22cad246ca7220fb639fabce3bb135edf4e84f866f1ea9b0af26f41d SHA512 786a6bd4336c591cfeb0b4f2dc1429f6545e36514e7b238453c91368b8f531c46db2be025f02dc52e6dd8b971d6edbb4ff1a8e1b519f9253a3957ad7157790be
 DIST help2man-1.47.12.tar.xz 202252 BLAKE2B 6a474d62999b2fe6750a0ec7662b9b33546d82ce72edd628f41008243cd3467cad783516d5ad06edb37f471a2aaefd837bd9957a7fd10b6e3c3b6dd33398b79b SHA512 fb71e48e4a7a0f4316148295ea539b667a131149f4467da0f3e283389c9d9f2a5f1e9124ca8d64d6c3250d332a713d4e8de204ca9e7088840e74f316fa5221be
+DIST help2man-1.47.13.tar.xz 202480 BLAKE2B 0c9e854a29ab563b7bc86d4873b2669c82bbd9226d3940ddf60fcbf8bfc48197013c7cde5b55e47e6463d26e1b3512a24bb9591a77009f47992b2a3df9bde198 SHA512 7bf4c75a42c103dd8413a94505f383c6e2b215f9a4cc506e11935acc7f108caad01a5fa489ee157ebef5fa02299145592f65cc828fc016417af557382975d57a
diff --git a/sys-apps/help2man/help2man-1.47.13.ebuild b/sys-apps/help2man/help2man-1.47.13.ebuild
new file mode 100644 (file)
index 0000000..a2e138b
--- /dev/null
@@ -0,0 +1,41 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="GNU utility to convert program --help output to a man page"
+HOMEPAGE="https://www.gnu.org/software/help2man/"
+SRC_URI="mirror://gnu/${PN}/${P}.tar.xz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sh ~sparc ~x86 ~ppc-aix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="nls"
+
+RDEPEND="dev-lang/perl
+       nls? ( dev-perl/Locale-gettext )"
+DEPEND="${RDEPEND}"
+
+DOCS=( debian/changelog NEWS README THANKS ) #385753
+
+PATCHES=(
+       "${FILESDIR}"/${PN}-1.46.1-linguas.patch
+)
+
+src_prepare() {
+       if [[ ${CHOST} == *-darwin* ]] ; then
+               sed -i \
+                       -e 's/-shared/-bundle/' \
+                       Makefile.in || die
+       fi
+       default
+}
+
+src_configure() {
+       # Disable gettext requirement as the release includes the gmo files #555018
+       local myeconfargs=(
+               ac_cv_path_MSGFMT=$(type -P false)
+               $(use_enable nls)
+       )
+       econf "${myeconfargs[@]}"
+}