dev-cpp/libbinio: Remove eutils
authorDavid Seifert <soap@gentoo.org>
Sun, 22 Jan 2017 17:27:13 +0000 (18:27 +0100)
committerDavid Seifert <soap@gentoo.org>
Sun, 22 Jan 2017 18:30:19 +0000 (19:30 +0100)
Package-Manager: Portage-2.3.3, Repoman-2.3.1

dev-cpp/libbinio/libbinio-1.4-r1.ebuild

index e4695da3705f7d99d0c9d0ee85869cac54884ec8..841c18987845d49b12b29353ba372b23a3c2f72d 100644 (file)
@@ -1,9 +1,8 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
 # $Id$
 
 EAPI=6
-inherit eutils
 
 DESCRIPTION="Binary I/O stream class library"
 HOMEPAGE="http://libbinio.sourceforge.net/"
@@ -14,11 +13,8 @@ SLOT="0"
 KEYWORDS="~alpha ~amd64 ~arm ~hppa ~mips ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
 IUSE="static-libs"
 
-DOCS=( AUTHORS NEWS README )
-
-DEPEND="
-       sys-apps/texinfo
-"
+RDEPEND=""
+DEPEND="sys-apps/texinfo"
 
 PATCHES=(
        "${FILESDIR}"/${P}-cstdio.patch
@@ -31,5 +27,7 @@ src_configure() {
 
 src_install() {
        default
-       prune_libtool_files
+
+       # package provides .pc files
+       find "${D}" -name '*.la' -delete || die
 }