lxqt-base/liblxqt: add version 0.15.0
authorJimi Huotari <chiitoo@gentoo.org>
Mon, 27 Apr 2020 16:59:58 +0000 (19:59 +0300)
committerAndreas Sturmlechner <asturm@gentoo.org>
Wed, 20 May 2020 23:28:26 +0000 (01:28 +0200)
New USE="backlight" allows for toggling backlight control
features, and as such, the 'polkit' dependency is now
optional.

Package-Manager: Portage-2.3.99, Repoman-2.3.22
Signed-off-by: Jimi Huotari <chiitoo@gentoo.org>
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
lxqt-base/liblxqt/Manifest
lxqt-base/liblxqt/liblxqt-0.15.0.ebuild [new file with mode: 0644]
lxqt-base/liblxqt/metadata.xml

index 8f42d6c883d1c3ac5d9fd40b46a522778c456485..7bc2362781f61b63f0f7db3dce1b656e8eba78bc 100644 (file)
@@ -1 +1,2 @@
 DIST liblxqt-0.14.1.tar.xz 81704 BLAKE2B 9aa190fce337068d02962af90c1847acd51a63c44019c9ccdc729dea00d52cd65826e50850e913306f5e6f0a20d1e25b4f90cd09ebb9012c2c3337aaeaa3665f SHA512 28ce5e924d136f9907f84e40d4823c412df071009a9d5da4e061ce969d7575b21210d5178103f9bfc73baa87ccafc87dcb6e29a737467ca1a459c1fd3c1071ba
+DIST liblxqt-0.15.0.tar.xz 80624 BLAKE2B 0f5b1fede9460dddd2a506e4945ad81c8e7121e74178833664b838c3acd88451a3c17e8e4db2e6a34e14ef0638760fee36273abb4c6d3f93014d402d069633c3 SHA512 6693be070fe641d590e3187abb2797ea470af5101efc4e9aed88a12cb28cc31aff60b6086cf717cd778353b50164d2365d88968a96a7fa00f6bc53e6855ddf7f
diff --git a/lxqt-base/liblxqt/liblxqt-0.15.0.ebuild b/lxqt-base/liblxqt/liblxqt-0.15.0.ebuild
new file mode 100644 (file)
index 0000000..70e3a18
--- /dev/null
@@ -0,0 +1,49 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake
+
+DESCRIPTION="Common base library for the LXQt desktop environment"
+HOMEPAGE="https://lxqt.github.io/"
+
+if [[ ${PV} = *9999* ]]; then
+       inherit git-r3
+       EGIT_REPO_URI="https://github.com/lxqt/${PN}.git"
+else
+       SRC_URI="https://github.com/lxqt/${PN}/releases/download/${PV}/${P}.tar.xz"
+       KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
+fi
+
+LICENSE="LGPL-2.1+ BSD"
+SLOT="0/$(ver_cut 1-2)"
+IUSE="+backlight"
+
+BDEPEND="
+       dev-qt/linguist-tools:5
+       >=dev-util/lxqt-build-tools-0.7.0
+"
+DEPEND="
+       >=dev-libs/libqtxdg-3.5.0
+       dev-qt/qtcore:5
+       dev-qt/qtdbus:5
+       dev-qt/qtgui:5
+       dev-qt/qtwidgets:5
+       dev-qt/qtx11extras:5
+       dev-qt/qtxml:5
+       kde-frameworks/kwindowsystem:5[X]
+       x11-libs/libX11
+       x11-libs/libXScrnSaver
+       backlight? ( sys-auth/polkit-qt )
+"
+RDEPEND="${DEPEND}
+       !lxqt-base/lxqt-l10n
+"
+
+src_configure() {
+       local mycmakeargs=(
+               -DBUILD_BACKLIGHT_LINUX_BACKEND=$(usex backlight)
+       )
+       cmake_src_configure
+}
index 68951bb1bdc62eeb637489b77cde7c0600af4c57..974818fd92419d05df6599d3e3f5ee5197e3df0d 100644 (file)
@@ -5,6 +5,9 @@
                <email>lxqt@gentoo.org</email>
                <name>LXQt</name>
        </maintainer>
+       <use>
+               <flag name="backlight">Enable backlight control features.</flag>
+       </use>
        <upstream>
                <remote-id type="github">lxqt/liblxqt</remote-id>
        </upstream>