dev-libs/hidapi: Remove old
authorManuel Rüger <mrueg@gentoo.org>
Sun, 27 Sep 2015 11:26:45 +0000 (13:26 +0200)
committerManuel Rüger <mrueg@gentoo.org>
Sun, 27 Sep 2015 11:27:26 +0000 (13:27 +0200)
Package-Manager: portage-2.2.22

dev-libs/hidapi/Manifest
dev-libs/hidapi/hidapi-0.8.0_pre20130121-r1.ebuild [deleted file]
dev-libs/hidapi/hidapi-0.8.0_pre20130121.ebuild [deleted file]
dev-libs/hidapi/hidapi-0.8.0_rc1_p20140201.ebuild [deleted file]

index e3d32dcb0fa0dc73523bf39c01ff6fc224c76c81..6e7eec4b51da065244e90bd5e97f0682510a40ef 100644 (file)
@@ -1,3 +1 @@
-DIST hidapi-0.8.0_pre20130121.tar.xz 257900 SHA256 70440f658dbf1f840647d0756e230fdfe479fd4980d3ba7b299715b1947a8916 SHA512 6735112cae24c845bf5ec1fc04c1cafc12c31a1ec5f8d560fd8089f1abf9b1f4aca2c027b1103b7154f698334d7f9ee8f5e72eb5571ecce5abf3fe716ca68096 WHIRLPOOL 94a691cbeafedd93ac786202f8acb2e4d1a6433cc379c9f7de792c0e1f881b34339df43289804105511f634b26144720e22377a37f1ac1c202a81907a988c773
 DIST hidapi-0.8.0_rc1_p20140719.tgz 103079 SHA256 33e206f5e145fc1bc6aeb55084d71b55d686533d23ad5bb762746ceba81e728b SHA512 204934a707da4e67b834823650b0cfd9be7b413972071129cc5aeeb93465834dde2f5ee23283c55d35b56e3aed8b7ad5fe947399839081f4d895fb65c8cd3e3d WHIRLPOOL 3c7d9cc4f39ebbe1f372a2e4f60990b1127e0c3025b85648d0f114ef652634e8e09d3ccd9e8f26ee6db191db1b2ccbb7afea3c3fa2018e8dfce034679c051f47
-DIST hidapi_0.8.0~rc1+git20140201.3a66d4e+dfsg.orig.tar.bz2 81765 SHA256 770e78bcfafccaaff25fbcf815aa2bee46b369e7f0ed12faa9f9260829b88e9c SHA512 55ab59086622bd4b76b630f6e3a0cb7edb335e736421ad0a9199ac7f2208c8880e1be3ef6ee18ca879f9d3dfdf872b0b0ed998087bc6d4716aada185bcebc1e5 WHIRLPOOL 8a18d8db2ea9b90802124936fe276060c6f890bf571cbc33811a0f026f73a689a426854348d195b2b8ad2aa31243fb2d209dca963f4daf535eb36ab0864035ea
diff --git a/dev-libs/hidapi/hidapi-0.8.0_pre20130121-r1.ebuild b/dev-libs/hidapi/hidapi-0.8.0_pre20130121-r1.ebuild
deleted file mode 100644 (file)
index 3066108..0000000
+++ /dev/null
@@ -1,69 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=5
-
-inherit autotools eutils #git-2
-
-# If github is desired, the following may be used.
-#EGIT_REPO_URI="git://github.com/signal11/hidapi.git"
-#EGIT_BRANCH="master"
-#EGIT_COMMIT="119135b8ce0e8db668ec171723d6e56d4394166a"
-
-DESCRIPTION="A multi-platform library for USB and Bluetooth HID-Class devices"
-HOMEPAGE="http://www.signal11.us/oss/hidapi/"
-SRC_URI="http://public.callutheran.edu/~abarker/${P}.tar.xz"
-# When 0.8.0 is officially available the following link should be used.
-#SRC_URI="mirror://github/signal11/${PN}/${P}.zip"
-
-LICENSE="|| ( BSD GPL-3 HIDAPI )"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86"
-IUSE="doc static-libs X"
-
-# S is only needed for the pre_package
-S=${WORKDIR}/${PN}
-RDEPEND="virtual/libusb:1
-       virtual/udev:0"
-DEPEND="${RDEPEND}
-       doc? ( app-doc/doxygen )
-       virtual/pkgconfig
-       X? ( x11-libs/fox )"
-
-src_prepare() {
-       if use X && has_version x11-libs/fox:1.7 ; then
-               sed -i -e 's:PKG_CHECK_MODULES(\[fox\], \[fox\]):PKG_CHECK_MODULES(\[fox\], \[fox17\]):' \
-                       configure.ac || die
-       fi
-
-       # Fix bashisms in the configure.ac file.
-       sed -i -e 's:\([A-Z_]\+\)+="\(.*\)":\1="${\1}\2":g' \
-               -e 's:\([A-Z_]\+\)+=`\(.*\)`:\1="${\1}\2":g' configure.ac || die
-
-       eautoreconf
-}
-
-src_configure() {
-       econf \
-               $(use_enable static-libs static) \
-               $(use_enable X testgui)
-}
-
-src_compile() {
-       emake
-
-       if use doc; then
-               doxygen doxygen/Doxyfile || die
-       fi
-}
-
-src_install() {
-       emake DESTDIR="${D}" install
-
-       if use doc; then
-               dohtml -r html/*
-       fi
-
-       prune_libtool_files
-}
diff --git a/dev-libs/hidapi/hidapi-0.8.0_pre20130121.ebuild b/dev-libs/hidapi/hidapi-0.8.0_pre20130121.ebuild
deleted file mode 100644 (file)
index d4407e0..0000000
+++ /dev/null
@@ -1,59 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=4
-
-inherit autotools eutils #git-2
-
-# If github is desired, the following may be used.
-#EGIT_REPO_URI="git://github.com/signal11/hidapi.git"
-#EGIT_BRANCH="master"
-#EGIT_COMMIT="119135b8ce0e8db668ec171723d6e56d4394166a"
-
-DESCRIPTION="A multi-platform library for USB and Bluetooth HID-Class devices"
-HOMEPAGE="http://www.signal11.us/oss/hidapi/"
-SRC_URI="http://public.callutheran.edu/~abarker/${P}.tar.xz"
-# When 0.8.0 is officially available the following link should be used.
-#SRC_URI="mirror://github/signal11/${PN}/${P}.zip"
-
-LICENSE="|| ( BSD GPL-3 HIDAPI )"
-SLOT="0"
-KEYWORDS="amd64 ~ppc ~ppc64 x86"
-IUSE="doc static-libs X"
-
-# S is only needed for the pre_package
-S=${WORKDIR}/${PN}
-RDEPEND="virtual/libusb:0"
-DEPEND="${RDEPEND}
-       doc? ( app-doc/doxygen )
-       virtual/pkgconfig
-       X? ( x11-libs/fox:1.6 )"
-
-src_prepare() {
-       eautoreconf
-}
-
-src_configure() {
-       econf \
-               $(use_enable static-libs static) \
-               $(use_enable X testgui)
-}
-
-src_compile() {
-       emake
-
-       if use doc; then
-               doxygen doxygen/Doxyfile || die
-       fi
-}
-
-src_install() {
-       emake DESTDIR="${D}" install
-
-       if use doc; then
-               dohtml -r html/*
-       fi
-
-       prune_libtool_files
-}
diff --git a/dev-libs/hidapi/hidapi-0.8.0_rc1_p20140201.ebuild b/dev-libs/hidapi/hidapi-0.8.0_rc1_p20140201.ebuild
deleted file mode 100644 (file)
index b729944..0000000
+++ /dev/null
@@ -1,79 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=5
-
-AUTOTOOLS_AUTORECONF=yes
-
-inherit eutils versionator autotools-multilib #git-2
-
-# If github is desired, the following may be used.
-#EGIT_REPO_URI="git://github.com/signal11/hidapi.git"
-#EGIT_BRANCH="master"
-#EGIT_COMMIT="119135b8ce0e8db668ec171723d6e56d4394166a"
-
-BASE_PV=$(get_version_component_range 1-3)
-RC_PV=$(get_version_component_range 4)
-GIT_PV=$(get_version_component_range 5)
-GIT_PV=${GIT_PV/p/git}.3a66d4e
-
-DEBIAN_PV=${BASE_PV}~${RC_PV}+${GIT_PV}+dfsg
-
-# S is only needed for the debian_package
-S=${WORKDIR}/${PN}-${DEBIAN_PV}
-
-DESCRIPTION="A multi-platform library for USB and Bluetooth HID-Class devices"
-HOMEPAGE="http://www.signal11.us/oss/hidapi/"
-SRC_URI="mirror://debian/pool/main/h/${PN}/${PN}_${DEBIAN_PV}.orig.tar.bz2"
-# When 0.8.0 is officially available the following link should be used.
-#SRC_URI="mirror://github/signal11/${PN}/${P}.zip"
-
-LICENSE="|| ( BSD GPL-3 HIDAPI )"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86"
-IUSE="doc static-libs X"
-
-RDEPEND="virtual/libusb:1[${MULTILIB_USEDEP}]
-       virtual/libudev:0[${MULTILIB_USEDEP}]"
-DEPEND="${RDEPEND}
-       doc? ( app-doc/doxygen )
-       virtual/pkgconfig
-       X? ( x11-libs/fox )"
-
-src_prepare() {
-       if use X && has_version x11-libs/fox:1.7 ; then
-               sed -i -e 's:PKG_CHECK_MODULES(\[fox\], \[fox\]):PKG_CHECK_MODULES(\[fox\], \[fox17\]):' \
-                       configure.ac || die
-       fi
-
-       # Fix bashisms in the configure.ac file.
-       sed -i -e 's:\([A-Z_]\+\)+="\(.*\)":\1="${\1}\2":g' \
-               -e 's:\([A-Z_]\+\)+=`\(.*\)`:\1="${\1}\2":g' configure.ac || die
-
-       autotools-multilib_src_prepare
-}
-
-multilib_src_configure() {
-       local myeconfargs=(
-               $(multilib_native_use_enable X testgui)
-       )
-
-       autotools-utils_src_configure
-}
-
-src_compile() {
-       autotools-multilib_src_compile
-
-       if use doc; then
-               doxygen doxygen/Doxyfile || die
-       fi
-}
-
-src_install() {
-       autotools-multilib_src_install
-
-       if use doc; then
-               dohtml -r html/.
-       fi
-}