app-admin/pprocm: EAPI 6 bump.
authorPatrice Clement <monsieurp@gentoo.org>
Fri, 24 Feb 2017 23:52:29 +0000 (00:52 +0100)
committerPatrice Clement <monsieurp@gentoo.org>
Sat, 25 Feb 2017 00:04:20 +0000 (01:04 +0100)
Package-Manager: portage-2.3.3

app-admin/pprocm/pprocm-1.0-r2.ebuild [new file with mode: 0644]

diff --git a/app-admin/pprocm/pprocm-1.0-r2.ebuild b/app-admin/pprocm/pprocm-1.0-r2.ebuild
new file mode 100644 (file)
index 0000000..67b967d
--- /dev/null
@@ -0,0 +1,34 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+MY_PN="PProcM"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="ncurses-based program to monitor CPU, disk, network and memory usage"
+HOMEPAGE="http://www.fusedcreations.com/PProcM/"
+SRC_URI="http://www.fusedcreations.com/PProcM/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="
+       dev-perl/POE
+       dev-perl/Sys-Statistics-Linux
+       dev-perl/IO-Pipely
+       dev-lang/perl"
+
+RDEPEND="
+       ${DEPEND}"
+
+S="${WORKDIR}/${MY_P}"
+
+DOCS=( AUTHORS README )
+
+src_install() {
+       newbin "${MY_PN}" "${PN}"
+       einstalldocs
+}