dev-ada/xmlada: Providing test
authorTupone Alfredo <tupone@gentoo.org>
Mon, 4 Dec 2017 20:48:54 +0000 (21:48 +0100)
committerTupone Alfredo <tupone@gentoo.org>
Mon, 4 Dec 2017 20:48:54 +0000 (21:48 +0100)
Package-Manager: Portage-2.3.13, Repoman-2.3.3

dev-ada/xmlada/files/xmlada-2016-gentoo.patch
dev-ada/xmlada/files/xmlada-2017-gentoo.patch [new file with mode: 0644]
dev-ada/xmlada/xmlada-2016.ebuild
dev-ada/xmlada/xmlada-2017.ebuild

index 7c28a02289f8566fe24dd08146c786667c4c2186..a90b963edd3c3af4046a526070cda850eee91499 100644 (file)
@@ -1,6 +1,6 @@
 --- xmlada-2016-src/Makefile.in.old    2016-12-04 21:58:57.251338692 +0100
 +++ xmlada-2016-src/Makefile.in        2016-12-04 21:59:31.332755615 +0100
-@@ -49,13 +49,13 @@
+@@ -49,16 +49,17 @@
  endif
  
  static:
  
  # Rebuild the tests (and not the XML/Ada code itself)
  test: force
++      GPR_PROJECT_PATH=schema:input_sources:dom:sax:unicode \
+       ${GPRBUILD} -p -XLIBRARY_TYPE=static ${GPROPTS} \
+               -XTESTS_ACTIVATED=Only xmlada.gpr
+--- xmlada-gpl-2016-src/tests/Makefile.old     2017-12-04 21:15:16.330459020 +0100
++++ xmlada-gpl-2016-src/tests/Makefile 2017-12-04 21:15:33.176156634 +0100
+@@ -1,8 +1,6 @@
+ TESTS= test_unicode \
+                test_state \
+-               test_xml \
+                test_adacore_dom \
+-               test_schema \
+                test_date_time \
+                test_numbers \
+                test_adacore_schema \
+@@ -71,6 +71,7 @@
+ test_multiple_xsd:
+       @echo "multiple xsd"
+       @cd schema/multiple_xsd; \
++              GPR_PROJECT_PATH=../../../distrib:../../../input_sources:../../../dom:../../../sax:../../../schema:../../../unicode \
+               gprbuild -q -Pdefault.gpr; \
+               ./validate > $(RESULTS)/multiple_xsd.out; \
+               cp $(RESULTS)/multiple_xsd.out $(RESULTS)/multiple_xsd.diff; \
diff --git a/dev-ada/xmlada/files/xmlada-2017-gentoo.patch b/dev-ada/xmlada/files/xmlada-2017-gentoo.patch
new file mode 100644 (file)
index 0000000..9e79572
--- /dev/null
@@ -0,0 +1,30 @@
+--- xmlada-gpl-2017-src/Makefile.in.old        2017-12-04 20:09:23.730805855 +0100
++++ xmlada-gpl-2017-src/Makefile.in    2017-12-04 20:09:51.586331155 +0100
+@@ -62,7 +62,8 @@
+ # Rebuild the tests (and not the XML/Ada code itself)
+ test: force
++      GPR_PROJECT_PATH=schema:input_sources:dom:sax:unicode \
+       ${GPRBUILD} -p -XLIBRARY_TYPE=static ${GPROPTS} \
+               -XTESTS_ACTIVATED=Only xmlada.gpr
+ # Run the tests. This requires an install of XML/Ada first
+--- xmlada-gpl-2017-src/tests/Makefile.old     2017-12-04 21:38:29.722818904 +0100
++++ xmlada-gpl-2017-src/tests/Makefile 2017-12-04 21:38:54.229382658 +0100
+@@ -1,8 +1,6 @@
+ TESTS= test_unicode \
+                test_state \
+-               test_xml \
+                test_adacore_dom \
+-               test_schema \
+                test_date_time \
+                test_numbers \
+                test_adacore_schema \
+@@ -71,6 +71,7 @@
+ test_multiple_xsd:
+       @echo "multiple xsd"
+       @cd schema/multiple_xsd; \
++              GPR_PROJECT_PATH=../../../distrib:../../../input_sources:../../../dom:../../../sax:../../../schema:../../../unicode \
+               gprbuild -q -Pdefault.gpr; \
+               ./validate > $(RESULTS)/multiple_xsd.out; \
+               cp $(RESULTS)/multiple_xsd.out $(RESULTS)/multiple_xsd.diff; \
index a99eb9103ca9f97d89254dd893c3a757989d987c..585a5492bb7db176aabf1548d4dc0c42086f6a81 100644 (file)
@@ -40,6 +40,11 @@ src_compile () {
        done
 }
 
+src_test() {
+       emake test
+       emake run_test | grep DIFF && die
+}
+
 src_install () {
        for kind in shared static static-pic; do
                if use ${kind}; then
index 4d5d16493c38aaca18dcb66389ada0328a2c251c..b80b4c4237f5161579efa792543bf01fc1d935a2 100644 (file)
@@ -26,6 +26,8 @@ DEPEND="${RDEPEND}
 
 S="${WORKDIR}"/${MYP}-src
 
+PATCHES=( "${FILESDIR}"/${P}-gentoo.patch )
+
 src_configure () {
        econf --prefix="${D}"/usr
 }
@@ -45,6 +47,11 @@ src_compile () {
        done
 }
 
+src_test() {
+       emake test
+       emake run_test | grep DIFF && die
+}
+
 src_install () {
        for kind in shared static static-pic; do
                if use ${kind}; then